Windows 10: CD/DVD drives causing issues with new PC

Page 1 of 3 123 LastLast

  1. Posts : 185
    Windows 10 64-bit home
       14 Jul 2016 #1

    CD/DVD drives causing issues with new PC


    I'm having lots of trouble with my two disc drives on my new custom-built Windows 10 machine. I put in my older Lite-on disc drives because they were both functioning perfectly in my old PC. One is a blu-ray reader and the other is a DVD burner.

    Today I decided to configure Exact Audio Copy on the new PC and it's been a nightmare. EAC keeps crashing and locking up when reading audio discs in the drives. I managed to configure one drive and then the other drive locked up. Then the drive that was working locked up next time. Each time EAC crashes it won't restart, and I have to reboot my PC. It takes over 2 minutes for my PC to shut down after EAC crashes. In the task manager EAC is still running but I can't shut it down without a reboot. Then EAC starts normally after rebooting and may or may not read a disc next time I try. Sometimes it accesses the disc, sometimes it freezes up again.

    Meanwhile, CD-Speed won't let me burn a test disc using my DVD burner - the burn button is greyed out. SmartErase won't let me erase a CD-RW or DVD-RW. Buuuurn lists my blu-ray reader but not my DVD writer in the drop-down list. It won't list my other drive. CD-Speed lists the DVD burner in the drop-down list, but not the blu-ray reader. All kinds of weird issues with the drives. I'm going nuts trying to figure out what's wrong. Everything else with my new PC is fine. Just the disc drives are all wacky. I disabled autoplay, and uninstalled the devices in device manager and let them re-install at next reboot. Still they aren't acting right. Both were fine together in my old PC.

    What could be wrong?
      My ComputerSystem Spec


  2. Posts : 185
    Windows 10 64-bit home
    Thread Starter
       14 Jul 2016 #2

    Further testing shows I can't switch from one drive to another in Exact Audio Copy. I just rebooted the PC, put a CD in my DVD burner, and configured it fine. But, once I ejected the disc, put it into the other drive, and selected that drive in the drop-down menu, it immediately got hung up (Not Responding). Same if I do it the opposite way. It hates it if I go back and forth between drives. It crashes every time. The fact that Buuuuurn doesn't list my burner in the drop-down list tells me something must be wrong here.
    Last edited by rivre; 14 Jul 2016 at 19:30.
      My ComputerSystem Spec

  3.    15 Jul 2016 #3

    You may want to try a different program. I use Nero, but that is not freeware. However, CDBurnerXP is a free program and although it says "XP" it is actually Win 10 compatible.

    For ripping audio CD's, I use Audiograbber (freeware).

    I have a recording studio and do a lot of audio CD work.

    CDBurnerXP

    Audiograbber

    One warning, both of these programs have crapware with them. Be sure to uncheck any extra items so you don't get them.
      My ComputerSystem Spec


  4. Posts : 185
    Windows 10 64-bit home
    Thread Starter
       15 Jul 2016 #4

    Thanks for the suggestion but I've been using EAC for 10 years and I can't imagine using anything else. It's the only program I trust to rip my discs. And as I mentioned, Buuuurn isn't showing the DVD burner in the drop-down list (it was on my old PC), it just lists my blu-ray burner, and Nero CD Speed is just the opposite - it only lists my DVD burner and not my blu-ray drive. So something seems to be wrong with my drive setup and I have no idea what.

    I found that at least on this PC, EAC hates it when I switch back and forth between drives while the software is open. If I shut the program down with the disc still in the drive, then remove the disc, then start EAC again, switch drives in the drop-down list, and then close EAC and restart it again, I can then use the opposite drive from what I was previously using. But if I just eject the disc and put it in the other drive and select it in the drop-down, EAC crashes every time. Now I have no idea if that's something new because honestly thinking back I don't think I had EAC configured with both drives before - I may have only set it up with a single drive to keep it simple. So maybe EAC has always acted strange with multiple drives and I just never encountered the issue because I never switched drives before in EAC? But then why does my other disc software act funny too? I try using Lite-On smarterase and it says I can't erase a DVD-RW or CD-RW because the discs aren't writable.

    Could I be having driver issues with the drives? I thought these drives used standard drivers that Windows installs? Windows installs the drivers fine automatically for both drives, and it says the drives are functioning normally. Could they be incompatible with Windows 10 because the drives are older (6+ years) drives? They were working fine on my old PC.
      My ComputerSystem Spec

  5.    15 Jul 2016 #5

    The only drivers for optical drives is the built in Windows/Microsoft drivers.

    I have older LG SATA interface optical drives that I reused in my current PC and no problems. I use these as they are the only SATA interface drives I found that will burn audio CD's at 8X. 16X, which is all the others will burn at (lowest speed) will not work in older audio CD players. I do a lot of audio CD burning for my recording studio clients and I need CD's burned at a compatible (to most older audio CD players) speed. (I also have a bank of 5 USB connected PATA interface burners that will also burn at 8X).

    I still think its your program. Do you have the latest version? If its 10 years old, it may require running the program in a Compatibility mode. If it worked OK in Win 7 then run it in a Win 7 compatibility mode.

    I've been working PC help forums since 2001 and a lot in audio and CD/DVD drives and this is the first time I've heard of the program you are using. I would still try the Audiograbber program, just to see if its your ripping program that is causing the problem.
      My ComputerSystem Spec


  6. Posts : 185
    Windows 10 64-bit home
    Thread Starter
       15 Jul 2016 #6

    So all my disc software is all of a sudden acting weird on my new PC? That's hard to believe.

    - exact audio copy
    - Buuuurn
    - Nero CD Speed (2 versions)
    - Lite-On SmartErase

    I don't know what to think of it really. It doesn't make any sense. Nero CD speed doesn't even let me click the burn button to create an extended test disc. It's greyed out. This is with a blank DVD+R media, and also blank CD-RW and DVD-RW media. Yet Nero did allow me to burn a benchmark disc. I don't get it. I'd blame EAC also if it wasn't for the other issues I'm having with the other software.
      My ComputerSystem Spec

  7.    15 Jul 2016 #7

    One of those programs may be interfering with the others.
    There was a problem at one time with Roxio "Drag to Disc" (Nero's version is "InCD" ) interfering with other CD/DVD operations. Users had to uninstall Drag to Disc so other burning would work.

    Check to see if any of those programs are running at startup. None of those needs to be in startup so disable any of those you find.

    I'll be gone the rest of the day - have a music gig this evening. I'll respond, if needed, in the morning
      My ComputerSystem Spec


  8. Posts : 185
    Windows 10 64-bit home
    Thread Starter
       15 Jul 2016 #8

    Nope, nothing is set to startup at boot. I confirmed by checking running processes. I don't actually have Nero installed. I just use the standalone CD-Speed, no installation required.

    Buuuurn always worked fine for me on my other PC with EAC and CD-Speed together. It showed my DVD burner in the drop-down list. Now it only shows the blu-ray reader, and that drive doesn't even have the ability to burn.

    Nothing seemed to interfere with each other on my old PC. Though I never tried to burn a test CD with Nero before because I never felt the need to as everything worked okay.
      My ComputerSystem Spec

  9.    16 Jul 2016 #9

    I still feel its one of the programs you are using. Whether just a bad install and a reinstall will fix it, or some incompatibility issue.

    Until you try a different program, you won't know.
      My ComputerSystem Spec

  10.    17 Jul 2016 #10

    Don't give up on this.
      My ComputerSystem Spec


 
Page 1 of 3 123 LastLast

Related Threads
HP Pavilion g6 Notebook PC, Hewlett-Packard, 1849 CPU: AuthenticAMD AMD A8-4500M APU with Radeon(tm) HD Graphics AMD586, level: 21 4 logical processors, active mask: 15 RAM: 8Gb Windows version: Windows 10 , 10.0, build: 10586 (upgraded from...
AVG Shell Extension causing issues with Windows 10 Explorer.exe in AntiVirus, Firewalls and System Security
I been looking up this issue for quite a while and came across this forum when trying to figure out this issue. Which I will note what I have tried to do so far. I have tried both recommended commands in the CMD sfc /scannow and the other one. I...
Hey all, It's my first post here, so I'll try to be as helpful in my explanations as possible. Basically I'm running Windows 10 64-bit (free download version) and am trying to use my HTC ONE (m7) with Trinus VR. For the least latency I'm...
SVCHOST.EXE Causing Performance Issues in Performance & Maintenance
Hi everyone, I am running Windows 10 on my HP laptop and SCVHOST is using all the system resources. I have run a performance trace for one minute and posted it here on OneDrive Microsoft OneDrive - Access files anywhere. Create docs with free...
Solved DVD Drives Causing Black Screen in Drivers and Hardware
Guys, I did a clean install of Windows 10 and, because of problems with installation,I disconnected all unnecessary DVD drives and expansion cards etc. I decided to reconnect my DVD drives today to two spare ports on the mobo but, when I...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:51.
Find Us