CD/DVD drives causing issues with new PC

Page 2 of 3 FirstFirst 123 LastLast

  1. Posts : 413
    Windows 10 64-bit home
    Thread Starter

    Yeah, I'm still no closer to finding a solution.

    Both drives appear under "This PC", and according to device manager they are both functioning properly. But something is very wrong:

    - I put a DVD-RW with some data on it in my DVD-RW drive. Opened smarterase. Tried both quick erase and full erase. It shows both drives in the drop-down list so I can select my burner. After the drive light comes on for a second, the tray opens and a message pops up: "Disc not support !".

    - I open up Burrrn and and I can't even select my DVD-RW drive. By default my blu-ray drive is selected but that drive is only a player.

    - Nero CD-DVD-Speed standalone doesn't allow me to select my blu-ray reader in the drop-down list - only the DVD-RW drive is shown.

    - Nero InfoTool standalone doesn't allow me to select my blu-ray reader in the drop-down list - only the DVD-RW drive is shown.

    - Exact Audio Copy has been crashing constantly whenever I switch drives in the drop-down list. I figured out that Exact Audio Copy will work for me IF I close the software before and after each step I take when switching drives in the drop-down list - close program, eject disc, close tray, open program, switch drives, close program, re-open program - then it doesn't crash. If I just switch drives with a disc in a drive, or without closing the software between steps, it crashes the software every time, requiring a PC reboot before I can re-start the software.

    The only software that seems so far to be acting normally is Imageburn. In Imageburn I was able to erase both my DVD-RW and CD-RW discs first try. With my disc erased with Imageburn, I was able to create a test disc successfully in Nero CD-DVD speed.

    I've been reading some forums and I see SPTI mentioned a lot - something about admin privileges. I tried running the software as an administrator and it still doesn't function correctly. Could there be some Windows setting causing a global restriction on how the drives are accessed or read? These are both SATA drives of course. Why do some programs see one drive and some see the other but not both? Why can't I erase my DVD-RW with smart-erase but I can with imageburn? Why doesn't Burrrn list my DVD-RW drive? I really need some advice here. I really don't want to have to buy two brand new drives hoping the will work, when I know both of these drives are fine.

    Maybe something in the BIOS?
    Last edited by rivre; 18 Jul 2016 at 13:57.
      My ComputerSystem Spec

  2. fireberd's Avatar
    Posts : 1,808
    Win 10

    I still think its related to some (or more than one) program you have installed. If Imgburn works, that says other program(s) are at fault.
    I have Imgburn (along with Nero) and I'm using the same version Imgburn that I used on Win 7 now on Win 10. Imgburn works better than Nero for making iso discs. I don't use RW media.

    I have seen cases where the built in Windows burning functions were interfering (I don't have that problem). Disabling the Windows burning function on each drive fixed problems in those cases.
    See THIS
      My ComputersSystem Spec

  3. Posts : 413
    Windows 10 64-bit home
    Thread Starter

    "Windows cannot find gpedit.msc".

    Group policies are not supported in the Home version.

    I still think it's got to be something to do with SPTI vs ASPI. Kprobe 2, which is another piece of software that gives disc/disc drive info, accesses both drives, and under driver, SPTI is forced on by default with no option to select APSI.

    From what I understand, Imageburn uses SPTI. Imageburn shows both drives and allows me to erase my discs.

    I have a feeling CD-Speed and Burrn aren't working due to some issue related to SPTI or the lack of it, maybe restrictions?
      My ComputerSystem Spec

  4. fireberd's Avatar
    Posts : 1,808
    Win 10

    Compatibility of software is what I've thought all along. That's why I keep pushing trying different programs.
    I have two SATA optical drives installed (both CD/DVD burner drives) and have not encountered any problems, reading or burning.

    I've burned discs (both CD-R and DVD+ and- R discs) with Nero, Imgburn, Macrium Reflect (to make bootable rescue disc), Karaoke CD burner and CDBurnXP. I've ripped audio CD's with Audiograbber and with Sony Sound Forge Audio Studio.
      My ComputersSystem Spec

  5. Posts : 413
    Windows 10 64-bit home
    Thread Starter

    I just installed a standalone version of Nero Infotool and it detects one drive - the DVD-RW drive. It even asks to put a disc in to determine drive speeds. But it doesn't "see" the blu-ray drive. Burrrn is just the opposite.

    VSO Inspector sees and lists both drives.
    Kprobe 2 sees and lists both drives
    Opti Drive Control sees both drives. Opti Drive control is written by the author of Nero CD-Speed/Discspeed.

    Imageburn is the only tool that sucessfully erases my RW discs. Nero Discspeed and smartburn either fail or don't allow it.

    Clearly there's something wrong, and it's more than just the software. All of this software used to work together on my old PC. I'm still thinking it's got to be something to do with access rights or SPTI vs ASPI.

    Never did find a solution to this. Everything I posted above is still the same. Am I to assume that Burrrn is incompatible with Windows 10? It sees only my BD-ROM drive - it does not list my Lite-On DVD burner in the list of available drives.
    Last edited by rivre; 29 Sep 2016 at 15:32.
      My ComputerSystem Spec

  6. fireberd's Avatar
    Posts : 1,808
    Win 10

    What OS was the old PC? If it was Win 10 was it an upgrade?
      My ComputersSystem Spec

  7. Posts : 413
    Windows 10 64-bit home
    Thread Starter

    Old OS was Windows 7 32-bit.
    New OS is Windows 10 64-bit.
      My ComputerSystem Spec

  8. Posts : 413
    Windows 10 64-bit home
    Thread Starter

    I found this on another forum:

    There seems to be an issue with Windows 10 and Nero Discspeed. It will only recognize one optical drive. I have 2 in my system, an LG Bluray burner and an older Samsung DVD burner. If I physically disconnect the Sata plug on the LG drive, reboot, restart the program, the Samsung is available in Discspeed. I have tried different versions of Discspeed and the winasi32.dll method with no luck. Any help would be greatly appreciated. Thanks

    I don't think that Discspeed is Win 10 compatible. It's been roughly 4 years since it was last updated. You could try running it in Win 7 or earlier compatibility mode.

    It seems Nero Discspeed and Nero InfoTool are giving me trouble, along with Burrrn (an old program) and Exact Audio Copy. Smarterase also refuses to erase any disc - it just says disc not supported. Compatibility mode doesn't help with these programs (does it ever?).

    KProbe 2 and Opti Drive Control, along with VSO Inspector and Imageburn, all seem to recognize both drives. Even DVD Shrink sees both drives, and that software is ancient.

    I wish somebody around here could chime in that is familiar with Exact Audio Copy or Discspeed - they might know if it is indeed incompatible or buggy with Windows 10.
      My ComputerSystem Spec

  9. fireberd's Avatar
    Posts : 1,808
    Win 10

    As your old OS Was Win 7, it may just be compatibility issues with the software you are using.

    I'm back to what I keep saying. Try/use software that is known to be Win 10 compatible.

    ADDED: My suggestion is to uninstall the ripping and burning software you have installed then restart the PC before installing a compatible Ripping program and Burning program(s) just as a precaution and to avoid any potential conflicts.
    Last edited by fireberd; 20 Jul 2016 at 14:44.
      My ComputersSystem Spec

  10. Posts : 2
    Windows 10 64-bit

    Inability to use multiple optical discs after Windows 10 upgrade ...

    Can I get a membership card - I ran into this problem also.

    No real solution but I do have a "workaround".
    I have a two optical disc desk top that ran windows 7 64-bit for years.
    I used CDex for ripping and burning activities. I could open individual instances of CDex for each optical disc.
    I updated to Windows 10 64-bit a few days ago and found out CDex would only open one optical disc; multiple instances would only open the same optical disc.
    I use the latest CDex (v1.81) that is supposed to be compatible with Windows 10. At least three previous versions back have this same behavior (I tried them)
    SO, I tried an alternate software, Fair Stars CD Ripper, which I've also seen good feedback about.
    Same behavior - even multiple instances can find only one optical disc.
    My workaround is this:
    I use CDex v1.81
    I open two instances.
    In one instance, I open "Settings" and change the setting (doesn't matter if it is selected or not, just change it) for "Use Native NT SCSI".
    Like magic, the selected optical disc changes to the other unit.
    Then I proceed to do whatever activities I planned with the discs.
    Once I close the instances, I have to reuse this same "trick" to use CDex on both optical discs again.
    Painful and disappointing, but workable.
    "My" opinion is this rather STRONGLY suggests Windows 10 has some fault or at least a significant difference to Windows 7.

    FWIW, my optical discs are Plextor PX-B320SA and Asus DRW-24B1ST-i.
    Old, but extremely reliable workhorses.

    Hopefully somebody out there (Microsoft, are YOU listening?) steps in with a REAL solution.
    Makes me wish I was a programmer sometimes instead of a hardware jock.
      My ComputerSystem Spec

Page 2 of 3 FirstFirst 123 LastLast

Related Threads
HP Pavilion g6 Notebook PC, Hewlett-Packard, 1849 CPU: AuthenticAMD AMD A8-4500M APU with Radeon(tm) HD Graphics AMD586, level: 21 4 logical processors, active mask: 15 RAM: 8Gb Windows version: Windows 10 , 10.0, build: 10586 (upgraded from...
AVG Shell Extension causing issues with Windows 10 Explorer.exe in AntiVirus, Firewalls and System Security
I been looking up this issue for quite a while and came across this forum when trying to figure out this issue. Which I will note what I have tried to do so far. I have tried both recommended commands in the CMD sfc /scannow and the other one. I...
Solved DVD Drives Causing Black Screen in Drivers and Hardware
Guys, I did a clean install of Windows 10 and, because of problems with installation,I disconnected all unnecessary DVD drives and expansion cards etc. I decided to reconnect my DVD drives today to two spare ports on the mobo but, when I...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:53.
Find Us