Windows 10: No mouse pointer after startup until i move the mouse

  1.    13 Jul 2016 #1

    No mouse pointer after startup until i move the mouse


    When windows starts up there is no mouse pointer, and will stay hidden until i move my mouse. This was the case without the logitech drivers; with the drivers installed but not running and with the drivers installed and running. So i doubt this is because of the drivers.

    Power options are set at maximum performance.
      My ComputerSystem Spec


  2. Posts : 1,970
    W10 Pro + W10 Preview
       13 Jul 2016 #2

    Open Settings....in "find a Setting" box at top type mouse....this should give you several options to play with.
      My ComputerSystem Spec

  3.    13 Jul 2016 #3

    My son's Dell XPS 2710 works the same way, and it has Logitech drivers as well. This may be a "feature," not a "bug!" Do please let us know if you find a fix, however. Thanks for posting,
    --Ed--
      My ComputerSystem Spec

  4.    13 Jul 2016 #4

    EdTittel said: View Post
    My son's Dell XPS 2710 works the same way, and it has Logitech drivers as well. This may be a "feature," not a "bug!" Do please let us know if you find a fix, however. Thanks for posting,
    --Ed--
    The thing is, this happened from the first time i started win10, before i even installed the logitech drivers. But i will keep looking, i might have a new mouse coming in soon (tesoro sagitta), if its the same thing with that one it must definitely be windows fault

    And i have played around with all possible settings to no avail.
      My ComputerSystem Spec


  5. Posts : 799
    W10 pro x86 and Vista x86
       14 Jul 2016 #5

    Both my laptops partly do this.

    If I restart no pointer is visible. If I shutdown and then start the pointer is visible. One laptop has quickstart enabled, the other which is an old Acer does not. Both behave identically.
      My ComputerSystem Spec

  6.    20 Aug 2016 #6

    Still the same after the AU.
      My ComputerSystem Spec


  7. Posts : 799
    W10 pro x86 and Vista x86
       21 Aug 2016 #7

    Its not a bug. I've a vague recollection that W8.1 did the same.
      My ComputerSystem Spec

  8.    21 Aug 2016 #8

    My USB devices have been "funky" since my upgrade to W10. Everything works, but there are annoying glitches: the initialization delay since the beginning. I also have to move the mouse after sleep before it is recognized, although it does come up on it's own if you wait long enough, and this behavior started after the Anniversary Update. I also have a "Safely Remove" icon permanently affixed to my Taskbar because W10 mistakenly sees a hub as a removable device.

    I speculate that W10 has changed the protocol for driver instructions. So we are in a situation where either hardware manufacturers are going to have to release all new drivers for all their older devices that work on the new protocol, or do nothing, save the money, and wait for people to replace their hardware.

    These problems have been going on long enough now that if it could have been fixed with an update it would have been.
    2 cents
      My ComputerSystem Spec

  9.    08 Sep 2016 #9

    Might as well ignore it indeed, its not like its super annoying, tried a different mouse yesterday and still it only popped up if i moved it, who knows it might even get fixed in the long run

    Thanks for all the replies though!
      My ComputerSystem Spec


 

Related Threads
I have a pretty powerful computer, running an i7, nvidia 980 gtx, 16GB ddr3 ram, all on a 1TB SSD. Just upgraded from 8.1 which was extremely smooth and 10 feels LAGGY. The mouse pointer seems to lag and even explorer windows seem to stutter as...
Mouse Pointer Sticking in Drivers and Hardware
Every 5/10 minutes, my mouse pointer keeps sticking, for around 1 second, then jumps to where it should have been. It's almost as if the pointer isn't actually sticking but the screen isn't updating. This started happening after upgrading to Windows...
Wonder if anyone could help. Switched on a friend's PC today with Windows 10 fully updated (upgraded from Windows 7 around a month ago), and it loads to where the login screen should be ie after the Windows 10 logo etc, but then the screen is...
Mouse pointer disappeared in General Support
Any help will be appreciated. Installed Windows 10 overnight. After reboot, I've lost my mouse pointer. The machine is a lenox Yogi. Thanks!
I recently upgraded to windows 10 which went well except my pointer "hid" behind popups. Everything worked, if my pointer went over a selection it would highlight the selection and I could select with no problem, I just couldn't see my pointer. I...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:47.
Find Us