1. Joined : Jul 2016
    Posts : 6
    Win 10
       09 Jul 2016 #1

    Can't print to Brother networked printer


    Hi,

    I'm just wrapping up installation of a new computer, including a clean install of Windows 10. We have a networked Brother MFC-8480DN. I went to Brother's site, retrieved and installed the full driver and software package for this printer and 64-bit Win 10. There were no errors or warnings indicated during the installation. I rebooted the computers, and attempted to print a test page from Word. Nothing happened -- Word didn't give any error messages, but nothing was queued to the printer.

    The printer is set as my default printer. The status shows 'working properly'. The device troubleshooter is unable to detect any errors. In attempting to print a test page from the Printer Properties dialog, it immediately pops up with 'Test page failed to print'.

    I can "talk" to the printer. There's a web management page which I can reach without problem through a browser. One of the programs installed with the Brother package was a scan and fax utility, which I tried and had no problem scanning something.

    So I'm really at a loss what the problem might be, or where to go from here. I hope someone can help.

    Thanks,

    Ken
      My System SpecsSystem Spec


  2. Joined : Oct 2014
    Posts : 118
    Windows 10 Enterprise
       09 Jul 2016 #2

    Ken,
    Is the printer connected to your network via wirelessly or by Ethernet cable? Can you connect the printer directly to the workstation in question and make sure it prints? Also, if your printer is connected via wireless, I've had to reboot my wireless router before to get my brother printer to print. For some strange reason....it will occasionally hang up, and a simple reboot of the router is all it takes.
      My System SpecsSystem Spec


  3. Joined : Jul 2016
    Posts : 6
    Win 10
       09 Jul 2016 #3

    Thanks for the reply.

    The printer is connected to the router via ethernet cable. I just hooked it up via USB -- Windows immediately created a new printer (same name, plus "Copy 1"). I tried printing a test page, and it was successful. I went back to the original (LAN) printer and tried, but again the test page failed to print.
      My System SpecsSystem Spec


  4. Joined : Oct 2014
    Posts : 118
    Windows 10 Enterprise
       10 Jul 2016 #4

    OK, now we know its not the printer. What you need to know now is the ip address of the printer. Once you have the IP address of the printer, then change the port of the printer driver to match the ip address of the printer, and you should be able to print.
      My System SpecsSystem Spec


  5. Joined : Jul 2014
    San Jose, California
    Posts : 1,962
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       10 Jul 2016 #5

    This is probably the way you setup your network. I suggest that you login into your router and set a static IP for your printer. eg. 192.168.1.10 so that each time you power on the printer/router, the same IP will be assigned to it. Delete both printers in your PC then with the printer connected to the router, re-install the driver again, if the software regconize the printer then go ahead and complete the setup, if not, you might have to manually to enter the IP.
      My System SpecsSystem Spec


  6. Joined : Jul 2016
    Posts : 6
    Win 10
       10 Jul 2016 #6

    play2mefish said: View Post
    change the port of the printer driver to match the ip address of the printer, and you should be able to print.
    That's proving to be easier said than done.

    I know the ip address of the printer (same as I used in the browser I mentioned in my OP), but I don't know how to change the port address of the driver. Looking at the printer properties, there's a 'Ports' tab, but there's no option to edit an entry. I can add a new entry, but I have no idea how to associate it with the printer.

    I deleted the device and re-scanned, it recreated the entry but nothing else changed. Tomorrow perhaps I'll try removing everything and reinstalling the Brother stuff again.

    Thanks again.
      My System SpecsSystem Spec


  7. Joined : Jul 2016
    Posts : 6
    Win 10
       10 Jul 2016 #7

    Well, just discovered the problem by comparing it to another computer here (it's still Win 8.1).

    It turns out that on the 'Advanced' tab of the printer properties, there's a dropdown box to select the driver. And for some reason, the driver was set to something called 'Brother Laser Leg Type1 Class Driver' rather than 'Brother MFC-8480DN Printer'. Selecting the latter fixed the problem.

    Thanks to both of you for your suggestions.

    Ken
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Unable to install Epson printer or Brother Labeller
Hi since changing to W10 I am unable to install the above on my lap top, both worked fine on my old vista machine, little notice comes saying something like ..incompatable with the O.S, is there away to get around this ? The printer, an Epson...
Drivers and Hardware
Can't Access networked Brother Laser printer- To print or use Web I/f
I have a home network that includes- Two Windows 7 PCs Two Linux machines A Brother MFC7820N networked multifunction printer All the above are on wired connections. Then there's an 802.11n wireless link for laptops and media devices. ...
Network and Sharing
Brother MFC J825DW Printer is Offline
Dangit, Microsoft has messed up my printers once again! My Brother MFC J825DW (Inkjet) printer won't print because Windows has set it to offline! My Brother MFC 7460DN (Laser) printer just trucks right along. Anybody know how I can get my...
Drivers and Hardware
Unable to get Brother Printer drivers working in Win10
After upgrade from 7 to 10 my 2 brother printers were visible and apparently ready. The HL2270DW would not print - just spooled forever but the MFCJ825DW worked. I tried using the Brother uninstall tool to remove the laser driver then installed the...
Drivers and Hardware
Solved Brother MFC-J825DW Printer Drivers Gone
I have a Brother MFC-J825DW Printer that was working fine as a network printer; however, when Windows updated to Build 10061, the printer no longer worked. I went to Brother and downloaded the full driver package and tried to install the printer...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:29.
Find Us
Twitter Facebook Google+



Windows 10 Forums