Hi guys, first post and I hope this is in the right place.

I've recently had to do a system restore to an earlier point to get my computer going again. My problem is that after the restore, I have no sound. Here is what I've tried:

Uninstall/Reinstall updated Drivers.
Tried multiple different drivers from older to newest.
Check services.msc and restarted, and ensured Audio/Audio Backend were set to auto.
Safe mode uninstall and reinstall driver with register cleaning.
Tried installing drivers in compatibility mode.
Updated ALL drivers (chipset/bios/etc).
Right clicked in playback devices to show disabled/etc - no dice.
Googled this issue for 9 hours and tried everything I came across to no avail.

I had this problem once before, and I did find a fix in like a 20 page thread. Now i don't know where that thread went, but I know it has to be fixable. Now though I don't remember where I found that thread and I don't know how to fix this again !

This is racking my brain and driving me insane, my microphone doesn't work, my sound won't play, but it does recognize my headphone jack. However the internal sound on my motherboard will not work!

I have a Dell Latitude E5550 running Windows 10. I feel like I have tried everything, but I know SOMEWHERE there is that one thing I did before and I don't know what it is! Please for the love of all that is good, can someone help me? I feel I'm losing my mind trying to get this sound working again! I know it is possible, but I can't for the life of me remember how I did it once before, or what I Googled to find out!