USB mouse not working Windows 10

  1.    26 Jun 2016 #1

    USB mouse not working Windows 10

    My mouse on windows 10 just sopped working the other day. The strange thing is, it works at the very beginning when launching windows. But then just stops responding; the red light from the tracker also turns off.

    When I go into the device manager I see a yellow triangle on HID compliant mouse. There it say Device Cannot Start (Code 10). I tried uninstalling the driver. Disconnected the mouse, reconnected - and it works! But at the same time I see windows is installing the driver. Once it installed the driver and detected the mouse model, the mouse stops working again. I tried uninstalling USB drivers, rebooting PC - same problem.

    I also installed Driver Toolkit program. There it detects problems with Renesas Electronic USB 3.0 Host Controller (ADB Interface) and SteelSeries HID Device (Human Interface Devices). I assume the last is something to do with my mouse, because the model of the mouse is Steelseries Kana.

    I tried downloading drivers for the last two online - nothing helps.

    I also tried doing system restore. Didn't help. Honestly, don't want to do factory reset.

    The problem started after I just went out without switching off my laptop, when I returned and waked it up, the problem started the one I am describing.
      My ComputerSystem Spec

  2. topgundcp's Avatar
    Posts : 2,438
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       26 Jun 2016 #2

    suggest that you use USB2.0 port for mouse instead.
      My ComputerSystem Spec

  3. Berton's Avatar
    Posts : 5,506
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       26 Jun 2016 #3

    Same here. I've seen some issues with using older USB Thumb drives, mice and printers on USB 3.0 ports instead of USB 2.0 ports, have a few Thumb drives with the issue. The USB 3.0 ports may be backward compatible with USB 2.0 but not all slightly older devices don't work in the USB 3.0 ports.
      My ComputerSystem Spec

  4.    26 Jun 2016 #4

    Well, I guess I "solved" the problem. If you can call it solved.

    Don't know if it is USB 3 issue. I don't have USB 2 ports, all of them are USB 3 (I think). Other devices that are connected are working fine. It is just the mouse. I had this laptop for 3 years and never encountered this problem. Don't think I also made any device changes. Unless Windows did something for me by itself.

    First thing I did was restoring fresh install settings. Guess what, didn't help. Then I did complete fresh install, wiping all the files. And still the same yellow triangle and error code; mouse not responding. I mentioned that I went to the manufacturer website for the drivers. And as I said before, the mouse worked for a while and then stopped again. Interesting thing was that in device manager there was two HID compliant mouse entities, one of which didn't have a yellow triangle and the other did.

    Then I went to the control panel for the device troubleshooter. I started the troubleshooter, it detected the problem in HID compliant mouse, said it was fixing it and required a reboot. I rebooted and then I was receiving constant Blue Screen of Death. At the error panel it was saying there was an issue with wdf01000.sys. I tried launching in safe mode. But there all of my input devices weren't responding at all; keyboard, touchpad - dead.

    I decided to do factory reset. Went through that. Whadya you know - still the same error. I thought there was something with the bios or my PC all together was breaking.

    Anyway, I tried searching for my mouse drivers, this time not going to the manufacturer website but to some other website. And the problem was fixed! The drivers were kinda different from the earlier ones. I don't know if it was that I installed the different drivers from a different website, or did factory reset also helped.

    In short, seems everything is working fine now. But I still get a yellow triangle in the device manager and there is still two entities of HID compliant mouse. Kinda feels that the solution is temporary.

    I got a feeling that there is something with the BIOS. Right now I am restoring my Windows 10 installation. Who knows, the problem might come back.
      My ComputerSystem Spec


Related Threads
After I installed Windows 10 from windows 7 I couldn't use my mouse and keyboard it works when I boot up BIOS Utility but when im on windows 10 it does not work. I tried switching usb ports and that didn't work either.
After the latest updates to Windows 10 on 1 September, my Logitech mouse has lost several of its functions (including the scroll function) in all applications. I downloaded the latest Setpoint and reinstalled it and then rebooted, but nothing has...
Hi I recently upgraded my HP Pavilion 15 laptop from Windows 8.1 to Windows 10 . I have an HP x7000 wi fi touch mouse that was working really good with me when i was working with Windows 8.1 . The problem here it refuses to pair with the device so...
I use left handed mouse, and swapping left / buttons works OK. I also set the wheel button to be "double click". But the wheel button brings up the context menu instead of double click. If I change to right hand mouse, the wheel button gives double...
I updated to Windows 10 last night, and when I went to use my laptop this morning, the touchpad didn't work. I plugged in a USB mouse and it works fine; I've checked the device manager (I have ELAN) and it said the touchpad should be working. Yet it...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:52.
Find Us