No external devices issue-why?

Page 1 of 3 123 LastLast

  1. Posts : 73
    Windows 10 Pro
       #1

    No external devices issue-why?


    I suspect it's because of some update windows dl without me knowing, but just yesterday when I plugged my phone via USB or tablet or any external device for that matter, it did pop up in Windows Explorer as new usb device connected and I could transfer data to and from it. Today when I plug in any of those devices(phone, tablet, flash drive) they don't. I can't even see them in Disk Managment.
    Now I haven't made any tweaks in my system, I didn't installed anything new, what's more - I haven't made any changes on my phone as well. And yet, yesterday it worked, today it doesn't.
    What could be an issue here? Is it indeed some broken update?
    And most of all how to fix this?
      My Computer

  2. dalchina's Avatar
    Posts : 24,316
    Win 10 Pro (1903)
       #2

    Hi, you might try post #3 here:
    USB ports not working - Windows 10 Forums

    It's always worth searching the forum (I searched for
    usb ports not working
    for you as I know this issue has occurred already)

    There are more threads if that doesn't help. If not resolved, please post back with what you've tried.
      My Computers


  3. Posts : 73
    Windows 10 Pro
    Thread Starter
       #3

    Thank you for that, but unlike poster in that thread my USB devices worked and I had no problems with them until few days ago when they just stopped. Now whatever I plug in to my USB out in my computer doesn't work. No matter if it is my phone, memory stick, external HDD. It just stopped detecting any eternal devices.
      My Computer


  4. Posts : 2,735
    Windows 10 Pro X64
       #4

    Hi,

    Have you checked device manager for "Unkown Devices" ?

    This may help as well hopefully:

    http://mspoweruser.com/solved-usb-de...ed-windows-10/

    https://www.drivereasy.com/knowledge...rts-dont-work/

    Cheers,
      My Computers


  5. Posts : 73
    Windows 10 Pro
    Thread Starter
       #5

    Thx for that. Although this didn't solved the problem, in device manager under USB root hub there was a problem(code 43) what I did was uninstalled this device and installed it again using driver from my motherboard manufacturer. So far this works.
      My Computer


  6. Posts : 2,735
    Windows 10 Pro X64
       #6

    Hi,


    OK. Good to hear that.
    You were probably experiencing some resource conflicts.

    Best,
    Last edited by fdegrove; 01 Jul 2016 at 09:59.
      My Computers



  7. Posts : 73
    Windows 10 Pro
    Thread Starter
       #7

    Although I thought the issue is solved, it's not. Next day after powering off my machine and turning it on, the issue has come back. But now I did checked device manager and there is no conflict or shut down device. Everything looks fine. I tried to install USB drivers from my motherboard as I did the last time but installer told me that there is no supported device found. What do you guys think I should do now?
      My Computer


  8. Posts : 2,735
    Windows 10 Pro X64
       #8

    Hi,

    In case you have "Fast On" enabled can you please disable it and reinstall all the USB drivers followed by a reboot or reset ?

    Windows 10: Enable or disable fast startup

    • Type Control Panel in the search box.
    • Click Control Panel.
    • Click Power Options.
    • Click Choose what the power buttons do.
    • Click Change settings that are currently unavailable.
    • Scroll down to Shutdown settings and uncheck Turn on fast startup.
    • Click Save changes.

    Cheers,
      My Computers


  9. Posts : 73
    Windows 10 Pro
    Thread Starter
       #9

    fdegrove said:
    Hi,

    In case you have "Fast On" enabled can you please disable it and reinstall all the USB drivers followed by a reboot or reset ?



    Cheers,
    Thx for that but I did try it and there are no changes. System as before doesn't see any USB devices. I've tried plugging external HDD directly from my desktop via 3 different USB ports(I've got 2 on the front). Plugged cable to the usb ports on the front of my pc, and tried one at the back. I've tried using USB hub but still nothing.
      My Computer


  10. Posts : 2,735
    Windows 10 Pro X64
       #10

    Hi,

    Assuming no errors for USB ports in device manager have you checked event viewer for any errors relating to the USB devices ?

    Cheers,
      My Computers


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:01.
Find Us




Windows 10 Forums