Page 2 of 5 FirstFirst 1234 ... LastLast
  1.    20 Jun 2016 #11
    Join Date : Jun 2016
    Posts : 1,474
    Win10 1607

    Yes the best driver is not always the latest by intel , which is why I check Fernando's site when I do a reinstall.

    http://www.win-raid.com/t25f23-Which...D-drivers.html



    iastorA.sys I think is for Raid systems while istor.sys is for AHCI systems...see Derekimo's post above in his pic, looks like he is still running version 10.X.X.X , on an AHCI system istorA.sys wont be active.

    ***Edit: the difference is drivers before 11.5 use iastor.sys and 11.5 up uses iastorA.sys (and iastorF.sys) for both Raid and AHCI

    Fernando recommends version 11.2.0.1006 for just about every Chipset but the table in the 1st post makes it easy to decide.
    Last edited by Kbird; 20 Jun 2016 at 14:44.
      My ComputerSystem Spec
  2.    20 Jun 2016 #12
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 387
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter

    Quote Originally Posted by derekimo View Post
    Have you looked under IDE ATA/ATAPI Controllers?
    That's the first place I looked, and I expected to see something like what you showed. Instead I see:

    Click image for larger version. 

Name:	Controler driver.PNG 
Views:	54 
Size:	9.8 KB 
ID:	86010
    yet Windows say I have some level of the Intel driver installed:
    HKLM\System\CurrentControlSet\Services\iaStorA ImagePath System32\drivers\iaStorA.sys
      My ComputerSystem Spec
  3.    20 Jun 2016 #13
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 387
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter

    Quote Originally Posted by Kbird View Post
    ...
    istorA.sys I think is for Raid systems while istor.sys is for AHCI systems ...see Derekimo's post above in his pic, looks like he is still running version 10.X.X.X , on an AHCI system istorA.sys wont be active.
    Oh. I'm using ACHI, not Raid. So that means the driver is installed but not used? Then I'll try installing the recommended driver.

    Quote Originally Posted by Kbird View Post
    Fernando recommends version 11.2.0.1006 for just about every Chipset but the table in the 1st post makes it easy to decide.
    Hmm. With my level of knowledge I didn't find anything in the Fernando posts particularly easy to understand. I thought he said that for Intel 8 series chipsets that 13.2.4.1000 was the preferred driver and that 11.2.0.1006 might not run. The Belarc Advisor says I've got Intel Series 8 C220 chipset.
      My ComputerSystem Spec
  4.    20 Jun 2016 #14
    Join Date : Aug 2015
    Maine
    Posts : 40,250
    Windows10Pro 64Bit

    Create a folder on your flash drive or any internal or external drive: Drivers
    Open Admin command prompt and run: Dism /Online /Export-Driver /Destination:X:\Drivers
    Replace X with the drive letter of your drive.
    Now you will have a backup, plus a list of all your drivers installed, using a windows command.
      My ComputersSystem Spec
  5.    20 Jun 2016 #15
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,207
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    Download: Driver 4.1 Backup Download . It is portable, just unzip and run. Much better than DISM command.
    Will give you all the drivers in your system with details. Backup/restore supported:
    Click image for larger version. 

Name:	2016-06-20_11-03-35.png 
Views:	2 
Size:	389.9 KB 
ID:	86018
      My ComputerSystem Spec
  6.    20 Jun 2016 #16
    Join Date : Jun 2016
    Posts : 1,474
    Win10 1607

    Quote Originally Posted by pokeefe0001 View Post
    That's the first place I looked, and I expected to see something like what you showed. Instead I see:

    Click image for larger version. 

Name:	Controler driver.PNG 
Views:	54 
Size:	9.8 KB 
ID:	86010
    yet Windows say I have some level of the Intel driver installed:
    HKLM\System\CurrentControlSet\Services\iaStorA ImagePath System32\drivers\iaStorA.sys


    Hi , yes you are using the Microsoft AHCI Driver at the moment , the 11.2.0.1006 Driver is the recommended Raid Driver even in Win10 for many, for your z87 the best AHCI is the 13.XXXX series Drivers looking at the table.




    Intel Chipset/Southbridge:
    Recommended AHCI driver:
    Recommended RAID driver:
    Intel ICH7R/M, ICH8R/M and ICH9R/M Intel RST v11.2.0.1006 WHQL only for ICH7R/M and ICH9M
    modded Intel RST v11.2.0.1006 for all of them
    Intel RST v11.2.0.1006 WHQL
    Intel P45 and X58 Chipset/ICH10R Intel RST(e) v11.7.4.1001 WHQL Intel RST v11.2.0.1006 WHQL (best performance) or
    Intel RST(e) v11.7.4.1001 WHQL (newer)
    Intel 5-Series Chipsets (like P55) Intel RST(e) v11.7.4.1001 WHQL or
    Intel RST(e) v12.9.4.1000 WHQL
    Intel RST v11.2.0.1006 WHQL (best performance) or
    Intel RST(e) v12.9.4.1000 WHQL (much newer)
    Intel 6-Series Chipsets (like P67 or Z68) Intel RST(e) v12.9.4.1000 WHQL Intel RST v11.2.0.1006 WHQL (best performance) or
    Intel RST(e) v12.9.4.1000 WHQL (much newer)
    Intel 7-Series Chipsets (like Z77) Intel RST(e) v13.1.0.1058 WHQL Intel RST v11.2.0.1006 WHQL (best performance) or
    Intel RST(e) v13.1.0.1058 WHQL (much newer)
    Intel 8- and 9-Series Chipsets (like Z87 or Z97) Intel RST(e) v13.1.0.1058 WHQL or
    Intel RST(e) v13.2.4.1000 WHQL
    Intel RST(e) v13.2.4.1000 WHQL or
    Intel RST v11.2.0.1006 WHQL
    Intel 100-Series Chipsets (like Z170) Intel RST(e) v14.8.9.1053 WHQL Intel RST(e) v14.8.9.1053 WHQL
    Intel X79 Chipsets Intel RST(e) v13.1.0.1058 WHQL Intel RST v11.2.0.1006 WHQL (best performance) or
    Intel RST(e) v13.1.0.1058 WHQL (much newer)
    Note: Both options require the RST BIOS mode.
    Intel X99 Chipsets Intel RST(e) v13.1.0.1058 WHQL or
    Intel RST(e) v14.8.9.1053 WHQL
    Intel RST(e) v13.1.0.1058 WHQL or
    Intel RST(e) v14.8.9.1053 WHQL
    Note: Both options require the RST BIOS mode.


    Have fun!
    Fernando
      My ComputerSystem Spec
  7.    20 Jun 2016 #17
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 387
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter

    I've just done some very unsuccessful experimenting.

    I installed driver 13.2.4.1000.
    It made my original problem far worse. Files were loaded in spurts for about 30 seconds and then completely stopped. The program reported 52% of the files had been loaded. That did not change for another 30 seconds so I killed the program and rolled back the driver. In the Event Log I saw
    1. About 20 iaStorA eventid 129 errors (Reset to device, \Device\RaidPort0, was issued) were logged,
    2. followed by event id 7040 The start type of the Microsoft Standard SATA AHCI Driver service was changed from demand start to boot start.)
    3. followed by a flood of Kernel PnP eventid 225 errors (The application x with process id n stopped the removal or ejection for the device PCI\VEN_8086&DEV_8C02&SUBSYS_85341043&REV_04\3&11583659&0&FA.)

    I think the 225 events happened after I killed the program trying to load the files, but I'm not sure.
    I rolled back the driver.

    Since I'm not using Raid, and was not using any removable drives at the moment, I decided this was not a good situation.

    I installed driver 131.0.1058.
    I got only 17% of the files loaded before they stopped loading.
    No iastor errors, but but the 7040 error and the flood of 225 errors were there.
    I rolled back the driver.

    Just for grins I tried installing the 11.2.0.1006, but Windows said I was more current.

    I'm not sure what to do now, but I've definitely concluded that the driver level can cause the file loading problem I've got. At the very least I can make the problem much worse. :-)
      My ComputerSystem Spec
  8.    20 Jun 2016 #18
    Join Date : Jun 2015
    UK
    Posts : 2,166
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)

    Quote Originally Posted by Kbird View Post
    Yes the best driver is not always the latest by intel , which is why I check Fernando's site when I do a reinstall.

    http://www.win-raid.com/t25f23-Which...D-drivers.html



    istorA.sys I think is for Raid systems while istor.sys is for AHCI systems ...see Derekimo's post above in his pic, looks like he is still running version 10.X.X.X , on an AHCI system istorA.sys wont be active.

    Fernando recommends version 11.2.0.1006 for just about every Chipset but the table in the 1st post makes it easy to decide.
    Are you sure? Both of my PCs which do not have RAID had the driver istorA.sys installed.
      My ComputersSystem Spec
  9.    20 Jun 2016 #19
    Join Date : Jun 2016
    Posts : 1,474
    Win10 1607

    Quote Originally Posted by Steve C View Post
    Are you sure? Both of my PCs which do not have RAID had the driver istorA.sys installed.
    Both my systems are using Raid , one on 11.7 and the other on 11.2 and the 11.7 (x58) system is using iastorA by the look , but not 100%positive....

    hmmmm is istorA different from iastorA.sy perhaps? or is that a typo?

    will do some reading at WinRaid....

    Click image for larger version. 

Name:	Capture12.JPG 
Views:	1 
Size:	125.8 KB 
ID:	86029
      My ComputerSystem Spec
  10.    20 Jun 2016 #20
    Join Date : Jun 2016
    Posts : 1,474
    Win10 1607

    In regards to my raid systems , so far I found this in the thread about issues with Win10 (me ...I did the nlite 11.2.0.1006 thing after 2-3 broken Win10 installs )

    This is talk about RAID....not AHCI
    All MS Operating Systems from Win8 up do contain a new generic Intel RST(e) RAID driver v12.0.1.1019 (Win8) resp. v13.2.0.1022 (Win10) named iaStorAV.sys, which is used by the OS as the DEFAULT Intel RAID driver for all Intel platforms from ICH8R up.

    Users with an Intel RAID system may run into severe problems, when they try to "downgrade" the already running in-box Intel RAID driver or any other previously installed Intel RST(e) RAID driver from v11.5 up (named iaStorA.sys) to a "classical" Intel RST RAID driver named iaStor.sys (latest version: v11.2.0.1006). According to my own experience you may get an unbootable and unrepairable system after having done such Intel RAID driver "downgrade".
      My ComputerSystem Spec

 
Page 2 of 5 FirstFirst 1234 ... LastLast


Similar Threads
Thread Forum
Installed Updates GUI History. Where is the data (list) stored ?
A minor issue... Windows 'Backup and Restore' treats the installed Windows Update list as temporary and something that should not be included in a disk image. This means that any restore process returns a 'no updates have been installed' message...
Windows Updates and Activation
AMD VGA Drivers Only Partially Installed
When I tried to install AMD VGA drivers, the installer hung during the installation of AMD Catalyst Install Manager. Now, that manager is only partially installed, and I can't install the drivers, because the installer generates an error message...
Graphic Cards
Finding what drivers are installed
Have tried Googling and I cannot find what drivers have been installed am concerned re the audio one for the machine as I have a problem with it. There are no audio drivers listed on the Asus site for audio for W 10 and I have seen vague references...
Drivers and Hardware
Is there a list with the latest Windows drivers per OS ?
Hi, Short intro: i'm a sysadmin and recently joined this forum. Mainly to train myself in analyzing BSOD's and whilst doing that, helping people out. Now the reason i became interested in BSOD's is because of BSOD's at work. We use SCCM for...
Drivers and Hardware
Solved Odd bug: strange entry in the list of installed apps
I noticed earlier today a strange entry in my list of installed apps/programs in the state menu. All it says is TrayItem followed by a list of characters. You can see it in the image below. I am not sure why its there, but I do know when it...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:19.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums