Windows 10: USB Keybard Not Working In BIOS

  1. Posts : 31
    Windows® 10 Pro (64-bit)
       15 Jun 2016 #1

    USB Keybard Not Working In BIOS

    Hi Team,

    My laptop keyboard had liquid spilled over it so it stopped working. I took it to a local repair shop who tried to unplug-replug the keyboard cable but it did not work. So as a workaround we kept the USB cord unplugged and this way USB keyboard started working right from BIOS. Unfortunately I cannot find this keyboard anywhere in shop, ebay, etc. So for now, I am using a USB keyboard.

    I happened to enable Fast Boot option in BIOS and it seems it disabled Legacy USB support in BIOS. Now this USB keyboard will become operational only after boot. Means I can no longer enter BIOS by tapping F2. The Caps/Num Lock light will lit up few seconds after the Windows Logo Screen and right before the logon screen.

    What are my options? The laptop make is Samsung NP530U4B-S02IN.
    I need to enter BIOS as I was planing to go back to Windows 8.1 due to lack of supported Win 10 drivers by Samsung/AMD.

    P.S. It feels good to be back here after such a long time. :)
      My ComputerSystem Spec

  2. RWOne's Avatar
    Posts : 486
    Windows 10 Pro (Mix of Builds) / Linux Mint
       15 Jun 2016 #2

    I don't see how enabling fast boot will turn off USB legacy support, however ...

    You're stuck, your likely option available is to reset the BIOS.

    You can try rebooting to advanced iptions and see if you can get into it from there:
    Advanced Startup Options - Boot to in Windows 10 - Windows 10 Forums

    You could also try - remove battery, remove AC cord, press and hold power switch on laptop for a count of 60.
    Put back together and retry booting.

    Lastly, open it up and pull BIOS Batt, repeat above.
      My ComputerSystem Spec

  3.    15 Jun 2016 #3

    IF the CSM in the Bios wasn't enabled when Fastboot was enabled it maybe possible to lose Legacy support I believe, not sure if that bios has that option though?

    RWOne is right ....Advanced start should give you an option to enter the UEFI Bios Firmware when you reboot.

    Also try hitting Numlock as you boot and see if it enables the Keyboard and then hit F2 ?

    you could also Flash the Bios , which should reset the Bios to all Defaults ,which should save you from having to pull it apart to pull the bios battery out.
      My ComputerSystem Spec

  4. RWOne's Avatar
    Posts : 486
    Windows 10 Pro (Mix of Builds) / Linux Mint
       15 Jun 2016 #4

    Since I'm used to it, offering to open it up is no issue for myself. If you got to that point and needed to, but was uncomfortable in doing so, an alternative is what I listed above that statement.

    Plus, if the laptop has removable covers for memory/hard drive, etc. You could remove those and look for the battery, on occasion it is accessible there (Think watch batt soldered to two wires, the wires plug into the board, not like a desktop MB whereas the batt fits in a holder) ... If you could get to it that way, its a thought.

    But try all else first.
      My ComputerSystem Spec

  5. Posts : 31
    Windows® 10 Pro (64-bit)
    Thread Starter
       15 Jun 2016 #5

    Thanks for the information. This is a 2012 model and there's no UEFI. So i don't have this option to enter uefi via advanced start up option. This laptop has a very poor reparability score. Trust me, is quite hard to open. Plus the battery is non removable too.

    I didn't know that flashing bios will reset it to defaults. This is something I'm gonna try now. If this doesn't work, then i will try the last resort, i.e. removing bios jumper to reset it.
      My ComputerSystem Spec


Related Threads
My numlock key used to be preset after a computer restart or reboot, now it has to be manually pressed before the number key section and led indication is operational. I have checked and it is selected on in my bios settings. Any suggestions would...
SSD and the Bios? in Installation and Upgrade
Hey, I'm trying to think ahead here... I'm expecting a new SSD in the mail soon... Will I have to change any of the settings in my laptops bios before I start it up and install Windows?
Hi everyone Today my keyboard stopped working, there was a usb error message pop up but i didn't realise what it was about, then then my k70 corsair keyboard stopped working, i tried restarting and doing an sfc scan but nothing changed, then i...
Updated bios - activations stopped working!!!!! in Windows Updates and Activation
I had issue with my USB Via 3.0 not working so I upgraded the bios to the latest version which has fixed the problem... ( Windows was activated but now I am now having a problem with activation.......... Error code: 0xC004C003 What can I do?
Hi there Adding non UK keyboard and input method works for Touch keyboard but seems to get ignored on physical USB keyboard (wireless). (Build 9926). Worked fine in previous build. Typing or mouse clicking on the ISL on screen keyboard types...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:01.
Find Us