I am having the worst problem, and nothing I have been able to do has solved it. I recently did a clean install of Windows 10 x64 on my work computer. My printer is directly connected via USB. I installed the latest drivers from HP (located here). At first, it failed, and I found I had to disable Smart Install for it to complete. So I uninstalled completely, and reinstalled. It prints the first one or two times, but then my problem arises. Whenever I try to print, whichever program I am printing from crashes, and in the "see what's printing" window, it is stuck on Spooling. I've tried everything, such as restarting the spooler, uninstalling and reinstalling again (and checking Print Management to make sure the drivers were completely gone), and even updating to the latest firmware 20160224. HP Print and Scan Doctor doesn't help at all. I've uninstalled and reinstalled numerous times since, but nothing works. The last time I uninstalled, I rebooted, and I think Windows 10 automatically found the printer, but it still gives me the same problem. I'd like to add that I can print to other printers in the office fine.

Here's the oddest thing: Before I did a clean install of Windows 10, I was on an upgrade. The printer worked fine then, and I believe I used the same drivers as the latest ones here at HP's site. Can anyone help me? This is extremely frustrating, as I cannot print.