Windows 10: 2TB Seagate drive not recognized Windows 10 (no Disk Management)

  1.    05 Jun 2016 #1

    2TB Seagate drive not recognized Windows 10 (no Disk Management)

    I have a 2TB Seagate GoFlex Desk external hard drive that works fine on my previous Windows XP computer (I know, very old) but is not recognized at all on my less-than-a-year old Toshiba laptop (S55-C5274) running Windows 10. I have been through support with Seagate, Microsoft, and Toshiba, with each of them point the finger at the other with no resolution. According to Seagate, the drive is compatible with Windows 10 and should work.

    Unlike other users' problems I've read, my Windows 10 PC does not recognize the external hard drive anywhere - no sound recognizing something is there when plugging in, nothing in This PC/My Computer, and nothing shows in Disk Management or Device Manager. So unlike many others, I am unable to just do a partitioning to assign a letter via Disk Management - the computer doesn't even recognize it's there. The Seagate drive, however, does light up when plugged into the Windows 10 computer, and as I mentioned, still works perfectly on the Windows XP machine, where it is accessible via My Computer.

    I have tested every USB port on the Windows 10 machine, and all work fine with other drives and peripherals, so it's not a hardware issue. Also, I have moved all my data from the Seagate drive onto a 2nd external drive, so losing data is not an issue. I even reformatted the Seagate drive (NTFS) via the Windows XP machine, but that did not change anything. Also, I have never used the Seagate software to manage the drive (which is not compatible with Windows 10) on either PC, and it has always worked fine without the software. Finally, the Toshiba Windows 10 PC is up to date with Windows Updates.

    I'm tired of being bounced around with zero help from Seagate, Microsoft, and Toshiba. Can anyone here help? I really hate to have a perfectly good 2TB drive become useless with all future PCs...

    Thank you!
    Attached Thumbnails Attached Thumbnails Disk Management.jpg  
      My ComputerSystem Spec

  2.    05 Jun 2016 #2

    my first suggestion to you is the test that our disk drive in another PC and see if it recognizes it
      My ComputerSystem Spec

  3.    05 Jun 2016 #3

    gijoetech1 said: View Post
    my first suggestion to you is the test that our disk drive in another PC and see if it recognizes it
    The Seagate drive does work in my older Windows XP PC.
      My ComputerSystem Spec

  4.    06 Jun 2016 #4

    If the drive has a power supply try unplugging both the USB cable & the power cable from the drive & then reconnect _USB first then power. If no external power supply it may be that the drive isn't getting enough power from the Win 10 PC to run it.
    If you have any files/folders on the drive, connect it to the XP & save them to online storage if you have space there or save them to the computer, then do this:

    • Type in "DiskPart" in command line.
    • Type in "list disk" in command line to show all disks in this machine.
    • Use "select" to set the focus to the specified partition.
      For example "
      select disk 1".
    • Use "clean" command to remove GPT disk from the current in-focus disk by zeroing sectors.

    1. Go back to Disk Management, you can see GPT disk is "Not Initialized" now.
    2. Within Disk Management, right click on disk info, choose "Initialize Disk", You can see GPT disk is "Unallocated" now.
    3. Right click on disk info, choose "New Partition…", follow Partition Wizard and format it.

    Ignore the mention of GPT disk as this works for all drives incl USB, HDD etc.

    I have both a 4TB & 6TB external HD & have had problems with the 4TB losing connection mid backup or not appearing at all under device manager or anywhere, worked perfectly under Win 8.1, I was disconnecting the power supply to the drive regularly so I did the above & apart from the odd occasion the drive appears to disconnect when running backup it now reappears when USB cable is plugged back in again (it didn't before). The only other option if your PC & XTHD is USB 3 is to use a USB 2 hub which works.


    Last edited by Bastet; 06 Jun 2016 at 05:58. Reason: Additional information added
      My ComputerSystem Spec


Related Threads
I have a internal 3.5" HDD WD Black 2 TB and try to hook it up in the PC but it doesnt not appear anymore in My Computer. It was working few weeks ago. When opening Disk Management it says the disk is not initialized and it didnt state how many GB...
There is no drive assigned. I wonder what it refers to? I've checked the registry but can't figure it out. How would I remove it? 63548
windows 10 disk management in Drivers and Hardware
hello i was wondering if anyone could help me with my problem. i have a msi laptop and since the 1511 update i now have partitions that where not there before hand. i can not delete these partitions and was wondering if anyone else has this...
I managed to get a WTG device running 10 IP set up with WinToUSB, and I happened to notice that in disk management, both the boot disk (physical partition of flash drive) and the virtual hard disk (C: in this case) are visible, and that you can...
I recently upgraded to Windows 10 and post that It was working fine without any issues. I have two external drive connected to it. 1. 1 TB Iomega powered drive. - now RAW 2. 2TB seagate external drive. The 1tb drive suddenly became RAW and I...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 07:28.
Find Us