Windows 10: N/B/running hot


  1. Posts : 181
    Windows 8.1 Pro/Windows Preview 10
       05 Apr 2015 #1

    N/B/running hot


    My North Bridge is at 126%. It's on a Asus Crosshair IV Formula Motherboard




    Now this one I built for my boy and it sat lol for about a year. I'M RIDING IT NOW. Is that to hot for it. I no the N/B gets hotter than S/B due to air flow. And I did have a 3500RPM fan on it. I must have took it off. So my question to you is it to hot if so should I put that fan back on. If I can locate it lol.



    I touch them both and they don't feel hot.
    Last edited by Gina France; 05 Apr 2015 at 19:41.
      My ComputerSystem Spec


  2. Posts : 8,794
    Windows 10 Pro X64
       06 Apr 2015 #2

    That is a common issue with your motherboard. What kind of cpu cooler are you using?

    You should add a fan and point it at the NB
    Last edited by Dude; 06 Apr 2015 at 09:30.
      My ComputerSystem Spec

  3.    07 Apr 2015 #3

    Had same problem with my Gigabyte MB, those AMD NBs do run hot, no matter which make. Managed to get it down to 80c by installing a better, active cooler on it.
      My ComputerSystem Spec


 

Related Threads
Source: Running Cocos2d-x on Windows 10
Folks, As my title indicates, I've got a few machines. They're all running nicely. (Well, except for the Surface, but that's just the way the surface is...). I'm VERY interested in upgrading to Windows 10 when it is released, especially since...
programs not running... in Installation and Upgrade
Friends came over... wanted to show them the Windows 10 beta I am running. When i click on the start icon, nothing. When I click on IE-11 nothing. Yet when I click on File-explorer or FireFox there isn't a problem. I have rebooted and...
Hello, my first post here, hope it's in the right place. I've been running Windows 10 since the day after the preview was released. However I took a different route than most when evaluating the OS, I installed it on my school laptop. Now it's not...
Running on 1 core out of 4 in Drivers and Hardware
Did anybody check Advanced Boot options in Msconfig. Seemed to me that my computer is booting too slow, checked those options and lo and behold it's been set to one core only. !!!! After fixing that it boots and run much faster.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:20.
Find Us