Windows 10: windows 10 purposely corrupts ntfs partition on old disk, cannot mount Solved

  1.    26 May 2016 #1

    windows 10 purposely corrupts ntfs partition on old disk, cannot mount

    i am becoming quite pissed.
    a Western Digital hard drive i know is perfectly good, that was used as a windows 7 disk and had an automatic upgrade done on it but became problematic...
    I have had to grab a spare drive, install linux and boot on that, then mount my problem WD drive to grab my data off of it.
    I have done ntfsfix in linux on this problem WD hard drive,
    now when i boot my good computer (which is running windows 10) and i have this problem WD hard drive as a slave, as my windows 10 boots it sees the WD hard and does a disk check on it which gets to 100%, and then my good computer running win10 I can see the problem 160gb WD drive in disk manager as disk #4 and it shows up under My Computer.
    the drive in disk mgr shows as
    - 100mb system reserved H:
    - 148gb NTFS, Local Disk I:
    - 450mb healthy (recovery partition)

    In My computer I can open up H: and it shows empty.
    I try to open I: and it won't open says it is not accessible access is denied.
    From disk manager i right click on I: for properties - tools - check drive for errors, and this reports with "The disk check could not be performed because windows can't access the disk".

    what do i need to do in windows 10 to access this partition?
    I tried mounting it in windows 7 and had no luck either, but the drive will mount in linux and read/write all day long no problem.

    Click image for larger version. 

Name:	a1.jpg 
Views:	4 
Size:	140.4 KB 
ID:	81826
      My ComputerSystem Spec

  2.    27 May 2016 #2

    it's like when running windows 10 it purposely won't let you access a partition on another disk that has windows 10 on it.
      My ComputerSystem Spec

  3.    27 May 2016 #3

    Try to run chckdsk I: /f, i think you have to do it in Safe Mode.

    Also see Checking and repairing a disk with CHKDSK - Ask Leo!
      My ComputerSystem Spec

  4.    27 May 2016 #4

    after 3+ hours of my life wasted,
    my solution ultimately was to mount this problem drive (which had updated to windows 10) in linux and then copy the data off to yet another hard drive that was a basic ntfs format. Then I had a clean accessible copy of the data - everything under the user account folders such as Desktop, Documents, and everything under Appdata so i could recover things like windows live mail and contacts and firefox bookmarks.
    Then on the pc where this was all supposed to work, i had to buy another hard drive (ssd) where i could do a clean install of the oem windows 7 pro then did the upgrade to windows 10.... then mount the clean ntfs drive with the recovered data.

    The original WD drive that had the botched update to windows 10 i had such a hard time trying to mount and access from another windows 10 computer- either mine or the pc in question that was running win10 on the ssd i had to buy for it. Turned out in order to do anything, you must use disk manager then right click on the ntfs partition, select properties and then security. You can't get to security any other way than this it seems. And only then... AND ONLY IF you make the owner of the drive that of the current user logged in to the windows computer can you then access the partition and see/copy data. Does not matter if your user count is already part of the Administrators group and that permissions on the mounted drive you can't access shows access for "Administrators" group. After 5+ tries of applying different permissions to every file on the drive from the top most level, because that's all you are allowed to do, and wasting a couple hours, i managed to open up that ntfs partition and copy data from it.

    really pathetic going from XP, to 7, to 8, and now at version 10 this silliness is happening.

    and on this drive botched from the automatic win10 update, when it did boot on its pc it would do a disk check on boot for whatever reason the file system kept getting marked as dirty. then it would boot into a roaming profile. And then trying to schedule a repair on restart and have it go into safe mode on reboot would never work.
      My ComputerSystem Spec


Related Threads
I upgraded my windows 7 pro to Windows 10 pro and decided to do a clean install. The install partition ( boot partition ) is on a HDD with three other partitions. I tried to install from the Windows 10 disk, created from the downloaded ISO...
So I've tried multiple different installations of windows 10 on my hp envy 17 (no slug of a machine, i5-12gb ram etc) Stretching back to the previews. I'm also running windows 7 on the laptop in a dual boot situation. The disk has a built in HP...
I posted a thread here about my Windows 10 installation problems Some of the installation log errors are these: 2015-11-17 10:38:33, Error ...
Disk Partition Tool can't extend C in Performance & Maintenance
My desktop computer has a few hard drives in it and for some reason C: is on the second disk. It's maxed out and needs to be made bigger. I've uninstalled everything but have failed to make enough space to even backup my phone (Silly iTunes insists...
I have a 3 TB disk partitioned into two parts. In Win 7 they had two different drive letters. Win 10 does not recognize the second partitioned portion of the disk and has labeled it unallocated. The disk manager provides no option to allocate the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:36.
Find Us