USB device descriptor failed

  1. FreedomRydr's Avatar
    Posts : 18
    Win 10 Pro - WIP (from 7-Ult)
       #1

    USB device descriptor failed


    Most of the threads on this error are old, (2015) so I am starting a new one. I only notice it when I happen to be in the device manager. I have no problems with any of my connected USB devices (that I have observed).

    I have tried uninstalling it, and rescanning and it pops up again, so apparently it is something that is connected. Without disconnecting All of my USB devices one at a time (which I am wont to do, as it is not bothering me, other than that it is there!) It has been there for quite a while, so apparently is not anything new being connected.

    Is there no way to identify WHAT is connected to this port, or even what port it is?

    BTW, it only shows up in the USB Controller section, no matching errors in any of the devices themselves!

    Curiouser and curiouser...
      My Computers

  2. simrick's Avatar
    Posts : 15,923
    W10Prox64
       #2

    Hi.
    In Device Manager, right-click the problem device and select Properties. In the General Tab, it gives the error code. In the Details tab, use the arrow down to select Hardware Ids. Then google the ID to identify. Could be an internal USB connection to something like wifi, BT, or card reader. Those cables do go bad sometimes.
    Example: USB\VID_046D&PID_0A04&REV_0007
      My Computer

  3. Slartybart's Avatar
    Posts : 3,502
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       #3

    In addition to simrick's advice:

    DevMgr
    Select / highlight problematic device
    View Menu > Devices by connection
      My Computer

  4. simrick's Avatar
    Posts : 15,923
    W10Prox64
       #4

    Slartybart said:
    In addition to simrick's advice:

    DevMgr
    Select / highlight problematic device
    View Menu > Devices by connection
    Thanks Slartybart - forgot about that one!
      My Computer

  5. Slartybart's Avatar
    Posts : 3,502
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       #5

    simrick said:
    Thanks Slartybart - forgot about that one!
    Sometimes it helps - the Hardware Ids always tells you something
      My Computer


  6. Posts : 1
    Win10
       #6

    Hi and sorry for digging up this old topic, but it's one of the top links on google so someone in the future might find this helpful:

    I had the same issue when trying to connect my phone to my laptop - tried everything described here and on other sites without success.
    The issue was the USB cable! I verified it with other computers and other phones and yes, it's always the same cable that gives me the "USB device descriptor" error message.

    So before you start messing with the drivers, just try a different cable first.
      My Computer


  7. simrick's Avatar
    Posts : 15,923
    W10Prox64
       #7

    HarryHamster said:
    Hi and sorry for digging up this old topic, but it's one of the top links on google so someone in the future might find this helpful:

    I had the same issue when trying to connect my phone to my laptop - tried everything described here and on other sites without success.
    The issue was the USB cable! I verified it with other computers and other phones and yes, it's always the same cable that gives me the "USB device descriptor" error message.

    So before you start messing with the drivers, just try a different cable first.
    Thanks for posting HarryHampster! Cheers!
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:35.
Find Us




Windows 10 Forums