Windows 10: Windows won't let me install a graphics driver.

  1.    22 May 2016 #1

    Windows won't let me install a graphics driver.

    My old laptop has an Intel Series 4 Chipset Family in it, or Intel 4500M integrated graphics according to the manufacturer website. I'm trying to play a game (FTL), which by all accounts should run fine on my laptop, but it suffers from god awful frame rates which is/was a common issue apparently with the game on older hardware, and the general consensus to fix the problem was to "update your graphics drivers".

    Now, FTL needs OpenGL 2.0 or later preferably. When I put Windows 10 on this system it installed Microsoft's own graphics driver for the system, which has been fine and dandy up until now but it appears that it only ever installed OpenGL 1.1 on my system. After a bit of digging for specs it appears my graphics card is quite capable of operating with OpenGL 2.0. So, the only way to get OGL2.0 is to put Intels own graphics driver on the system...

    The manufacturer's drivers haven't been updated since 2011, and Intel's latest driver for this particular chipset family was last updated in 2012. So I downloaded Intels drivers in the form of a zip package so I could hopefully just go through device manager to install them, however when I do this and click on browse for updated drivers and select the driver's directory, Windows tells me shortly afterwards that it has determined the driver currently installed is up to date and won't let me go any further.

    I figured I could bypass this by doing it the "Have disk" route instead, and so I I selected the "Let me choose etc." option and went to have disk and it asks me to find an .inf file but then I select the autorun.inf from the driver package, and even though I have the x64 version of the driver in this package, Windows chucks out an error saying that no suiotable driver could be found and that I should make sure the drivers are for 64bit systems. There's only one other .inf file in the package and selecting that produces the same result.

    So I decided to try and be sneaky. I chose to uninstall the Microsoft graphics driver (selecting the option to delete it too). Screen goes black, I hear the "boo be de boop" hardware inserted sound so I take that as my cue to restart the computer. So I do. Sure enough when it restarts the displays back but has gone all low res and a quick check shows that Windows as reverted to the basic display driver just to get me by. I turned off wifi so it can't check and update the driver by itself in the background, and I go to install the Intel driver the same way again.

    But yet again, even with the crappy basic graphics driver installed, when I try and install Intels driver I just get the same exact errors as before. "Windows as determined blah blah" or "This isn't a comptible driver blah blah".

    "FINE" I say defeated. I decide to just run the Intel setup.exe that's int he driver package. I figure it'll probably install some unessesary crap I don't want but at least I'll finally get the driver on the system and hopefully see OpenGL updated to 2.0 like it should be.

    Except when I select the setup.exe it chucks out an error saying I haven't got the latest .NET Framework installed and I should update it then try again. So, yea, what a load of old cobblers. FOr a start, I don't want any extra .net framework on my system, and besides that I thought it was included as standard these days anyway so, I'm pretty stuck.

    Is there a way I can get these sodding drivers installed at all? I'm pretty damn sure my framerate issues with that game are because Microsoft's own iteration of the graphics driver for some stupid brainless reason only has OpenGL 1.1 support, which is bloody ancient by today's standards. According to the driver info they were updated in 2015 anyway so why the hell didn't they add OGL 2.0 support? How hard would it have been for them to do that...

    I actually dug around and found the OpenGL dll file in Intel's package (it's called something different but I have confirmed it's the opengl32.dll just renamed. I tried replacing the one in System32 with the one from the driver package and after fiddling around taking ownership of it and altering permissions so I could rename the old dll and move in the new one calling it the same name, a restart later found my long shot in the dark was a complete miss as my system still identified as having OpenGL 1.1 and the game's frame rate was still crap. Though, I don't know if I should have done more than just replace the dll file or if what I did there is a testiment to the fact that even Intels drivers wouldn't update OpenGL to 2.0 and I'm pretty much boned.
      My ComputerSystem Spec

  2.    22 May 2016 #2


    Not sure about any of this & it does not apply to my system. However you could try the "Stuff" they have "Messed around with" for Windows 8, here

    Good luck if you try it!
      My ComputerSystem Spec


Related Threads
Hello guys, I need help for my new build. from a fresh install of windows 10 i try to install the drver for my IGPU Intel HD 530. each time i do that i get a BSOD with this message: VIDEO_TDR_FAILURE igdkmd64.sys Or sometimes it's...
I upgraded both my desktop and laptop to Windows 10 recently. The desktop's upgrade went smoothly; NVIDIA already has Windows 10-compatible drivers. However, my laptop with Intel HD Graphics is a different story. I've tried the Dell-certified...
I have an Acer Aspire XC603G Desktop running Windows 10 Home 64-bit. I went to the Intel website and downloaded the utility that detects which drivers I need. The utility detects a different driver than my system detects. Should I get the driver...
I use Intel HD Graphics 4000 that came with my i5 3570. My main online game is an old golf sim, Links 2003. I am able to play the game quite well in Win 7 with the 2012 video driver version, but all the more current versions have problems with...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 12:21.
Find Us