Windows 10: ASMedia SATA Controller Firmware?

  1. yanniclord's Avatar
    Posts : 25
    Windows 10 Pro Fall Creators x64
       12 May 2016 #1

    ASMedia SATA Controller Firmware?

    Before anyone says anything, this lies in-between Windows and Linux, and i am not exactly sure where i should go with this, but as it is a driver/firmware issue that i most likely will need to fix over/with Windows, i take this up here.

    Hi guys. So, i tried installing Ubuntu along with Windows 10. Aside from the typical problems that occur, i have the problem that when booting Ubuntu, i get an "ATA8.00: STATUS DRDY" error. After some research, the problem seems to be the ASMedia SATA Controllers. However, the solution would be that i should move the connected drives from the ASMedia SATA Controller to the Intel Controller. Easier said than done, because i was not aware of this issue before until now, so i have my SSD (Main Drive) hooked to the ASMedia SATA Controller, which i cannot move, because of obvious reasons. I have heard that it is possible to flash a new firmware for the ASMedia SATA Controller, but i cannot find it. I have a "ASRock Z97 Extreme4" Motherboard, and if anyone could help me, i'd appreciate it. Oh, also, i have the ASMedia 106x SATA Controller.

    Solved the above part, i ended up switching over to the Intel SATA Controllers from the ASMedia SATA Controller.

    And another thing, i really don't like GRUB, so i would like to add Ubuntu to the Windows Boot Manager (Windows 10, Graphical, not Command Line like Windows 7 or lower). I checked for a way to add Ubuntu to the Windows 10 bootmanager, the only one i found was someone saying i need to use BCDEDIT in the cmd, but i am not exactly sure how, so if someone could help me on that too, i would be more than happy.

    Thanks for the help in advance!
    Last edited by yanniclord; 12 May 2016 at 20:01.
      My ComputerSystem Spec

  2. yanniclord's Avatar
    Posts : 25
    Windows 10 Pro Fall Creators x64
    Thread Starter
       13 May 2016 #2

      My ComputerSystem Spec


Related Threads
SATA III SSD shown as SATA II in Drivers and Hardware
Hi everyone.:nerd: I have just noticed that my Intel 520 SSD Drive is showing as SATA II drive. Now, I am aware that it is connected to a SATA2_0 port controlled by native Intel SATA II controller on my mobo and current speed should be 3gb/s. Why...
Asmedia 1074 USB hub drivers in Drivers and Hardware
My Asrock X99 OC Formula uses Asmedia 1074 USB hubs to add USB3 ports. (These aren't USB3 controllers; they're simply hubs.) I believe that these include the USB3 front panel ports. I think that I have a problem with those. My Seagate external...
Hello : Since I updated to win 10 . in device manager I'm having a problem with my usb host controllers , looks like I need a update for win 10 .49848
When I first setup win 10 I accidently set me keyboard to UK style. I should have selected US. Now, when I boot up, the " and the @ are reversed. I go into keyboard setup and change it to US. ease of access change how it works ........ change...
I have a Aśus Maximus V Gene mob that has two Sata mob inputs not controlled by the Intel Sata driver. I am having difficulty installing the latest Asmedia driver downloaded from the Aśus support site. With Win 7 there isn't a problem, but win 10 TP...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:29.
Find Us