Windows 10: USB issues after upgrading to Windows 10

  1.    12 May 2016 #1

    USB issues after upgrading to Windows 10

    Hi! Looking for help with some issues that developed after installing Windows 10....

    Background: No problems with Windows 7. Had computer for 5+ years....held off on upgrading to Windows 10 in fear of problems, but was in queue to get the upgrade. Pop up would come up every so often to upgrade, but I dismissed the requests. Well, one of my kids must have accidentally allowed the upgrade to happen. I navigated the system & found no real issues, so I kept the upgrade to Windows 10. I noticed I had a problem with "permissions" on USB drives after I backed up my sister's old Iphone to my hard drive (she has no real computer for storage space). Anyhow, I was gonna put all of her pictures and videos on a flash drive to give to her for safe keeping. After I copied them over to the drive, I tried to look at them to make sure everything went over well. I recieved a "you don't have permission to view this file" message. I deleted everything and tried again. Same message. I'm thinking maybe Apple has some type of proprietary stuff embedded in the files so I just shelve the project for a while.

    Fast forward to recently. I was trying to edit a USB drive that had music on it. It recognizes the drive, but it would not let me delete any files. I recieved another "permissions" message. I was able to copy files over to the drive, but I got "files already exist, do you want to overwrite". I clicked yes and the files were copied. I thought that was odd, because the files copied were NOT on the flash drive like the comuter said they I used a fresh, blank flash drive and copied some pictures to it. Same event took place. The computer told me the files already existed if I want to overwrite or abort. They do copy over if I click overwrite.

    I start googling permissions and administrator stuff (I had only one default admin account)....and created another user. Followed the direction of some other websites to try to put permissions as global for the admin account. It looks like I should have full control of everything.

    Yesterday, I took an old flash drive with pictures on it. The computer recognizes the drive and I can see the files on the drive, but if I try to open one, I get the "you don't have permission, etc." message. I took the same flash drive onto my laptop and I can view the pictures.

    Clearly, something is screwed up with my USB stuff from the upgrade to Windows 10. I was wondering if you folks could give me a few suggestions on how to remedy my problem. I would rather not reinstall Windows 10 if I do not have to. After several hours of searching, some suggest it could be a drivers issue, while others say it can be cured thru "device permissions".

    I have a custom build unit with an ASUS motherboard. Any help is greatly appreciated.
      My ComputerSystem Spec

  2.    13 May 2016 #2

    Any ideas?
      My ComputerSystem Spec

  3.    03 Oct 2016 #3

    Have you ever found a solution to this? Are you running any sort of Antivirus? A computer I am currently working on is experiencing the same issue. The owner has said that she it was copy files and reading files on the USB fine prior to installing antivirus.

    Note: This computer was upgraded from Win 7 to Win 10
      My ComputerSystem Spec


Related Threads
Hi, I've just tried upgrading to Windows 10, and when it was complete, and I was working through the setup it asked me to find a network to complete the rest of the setup. In completing this step, my network was nowhere to be found. I tried...
Hi, I am looking for a bit of advice if possible. I really don't know what to call my problems, and I don't know if its related to my laptop, or the upgrade. Firstly, when dragging an internet page up or down, using the mouse pad (buttons work...
I'm running 8.1. I got the prompt that the download for Windows 10 has started. When I click the "View download progress" button in the "Get Windows 10" window, it brings me to the "Windows Update" window where it starts checking for new updates but...
I have a Notebook, Desktop and a Laptop. All connected using a Home Network. All were on Windows 7 until the Desktop and the Laptop was upgraded to Windows 10 (Desktop: Windows 10 Home Premium, 32 bit. Laptop: Windows 10 Home Premium 64 bit). The...
Last week i managed to upgrade to windows 10 after about 8-10 attempts. once i got upgraded i was having issues with the store, adding accounts to mail and login using Microsoft account details. one of the suggestions i was given was roll-back to 7...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:00.
Find Us