Question on disk space avail RAID 0

  1. awalt's Avatar
    Posts : 73
    Windows 10 Pro

    Question on disk space avail RAID 0

    I am confused, hope you can help - I have 2 2TB disk drives configured as RAID 0. This is confirmed in Intel RST. RST says 3815 GB total size, roughly 4 TB available, which is what I would expect as RAID 0 supposedly makes available the sum of the drives in the array as its size.

    But File Explorer in Windows 10 Pro confuses me - it basically says 2 TB is the size. I might assume it is just wrong, but the "used" space is around 1/2 TB, which is what I believe the actual size used really is.

    I have 3 questions:

    1) Is this just an error in File Explorer on the space reported?
    2) How much space do I have left? File Explorer says 1.5 TB, I would hope it is 3.5 TB.
    3) Is there a utility or way I can get an accurate report of space truly used, free and total if File Explorer is unable to handle RAID 0 arrays?

      My Computer

  2. bobkn's Avatar
    Posts : 3,750
    Win 10 X64 Pro 21H1 19043.1052

    Haven't messed with "fake RAID" in years.

    Are the disks GPT? Windows requires that to use > 2GB in a single disk; I suppose the same would be true for a RAID array of 4GB.
      My Computers

  3. awalt's Avatar
    Posts : 73
    Windows 10 Pro
    Thread Starter

    Thanks bob, they are MBR disks. So refreshing my memory, that means Windows only can handle/see 2 TB of the 4 TB array?

    See attached picture of drive - seems to affirm Windows is ignoring a bunch of the disk, right?

    So if I reformat in MBR, or if I used 2 1 TB disks, I would get the sum of the storage in RAID 0?

    Thank you for your help, it has been very useful!
    Question on disk space avail RAID 0-1.jpg
      My Computer

  4. DeaconFrost's Avatar
    Posts : 1,366
    Windows 10 Pro x64

    If I am understanding correctly, you would need the drive to be GPT in order to be able to use the entire volume as a single, solid C drive.

    There may be a way to convert it to GPT, but they may put your existing data at risk. Someone else would have to answer that.
      My Computer

  5. EdTittel's Avatar
    Posts : 4,156
    Windows 10

    Paragon's Hard Disk Manager will convert MBR to GPT, but even they warn users to back up the MBR stuff before making the conversion. That said, if you're going to back it up anyway, why bother with converting. Make a backup, reformat the disks and set up your GPT-based RAID 0 array, then restore the backup thereupon. If this is a boot or system drive, however, I would urge you to reinstall the OS after reformatting with GPT. I've tried converting such a drive to GPT before (on a pair of Samsung 850 EVO SSDs) and was not able to get the system to boot after making the conversion, not even after attempting to repair the boot environment using a repair disk to rebuild same.
      My Computers

  6. awalt's Avatar
    Posts : 73
    Windows 10 Pro
    Thread Starter

    To update everyone on the conclusion, I successfully converted the RAID0 array to GPT! These were the steps I did:

    1. Backed up image of the drive (it was my bootable C: drive) with Macrium.
    1a. Changed BIOS boot options setting from legacy boot option to UEFI with hybrid with CSM
    2. Booted with Macrium rescue image (note I had not updated by rescue USB, it was older and under "fix boot problems" only had Windows 8 but this all worked. I have since updated it to the latest, supporting Windows 10.)
    3. Go into diskpart, clean the drive, convert to GPT, create the efi and msr partitions: the commands in diskpart -
    list disk (find which disk is the one you are working on)
    select disk xx
    convert gpt
    create partition efi size=200
    format fs=fat32
    create partition msr size=128
    4. Close the command window, then use Macrium on the rescue disk boot to restore just the volume with my data out of the image, onto the unallocated space of the drive. Be sure to expand the sliders to take up the whole space in this partition. Then let it restore.
    5. At this point, I did "Fix boot problems", rebooted, and it could not find the disk. Not sure why, I did the "Fix boot problems" again, rebooted, and it worked fine! All the data was there and Windows 10 came up fine, I verified in diskpart the drive was GPT plus the space was now 3.72 TB available, not 2 TB.
    6. Changed boot options in BIOS to UEFI without CSM, and verified system and rescue disk still booted. I did this step with the newly updated Macrium Rescue image USB drive, full support of Windows 10.

    My only question - in step 6, once I changed the boot option to UEFI without CSM, the rescue disk takes about 3 minutes to boot - the light blinks the whole time, but it does come up fine eventually. Before, the rescue disk would boot up in about 20 seconds or so. Same USB drive, same port. Why is that?

    Thanks for everyone's help, and I hope my notes help someone else out!
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:02.
Find Us

Windows 10 Forums