1.    03 May 2016 #1
    Join Date : May 2016
    Posts : 3
    Windows 10

    Seagate Expansion Drive Appearing and then disapearing


    I have a perplexing problem. I have a Seagate 2TB external drive that when I plug it into my USB3 port it appears in Explorer and sometimes I can even navigate through some of its folders. However after 2-5 minutes it just disappears and a message comes up "USB Not recognized".
    When I insert it into a USB2 port I cannot see anything. Whilst it is visible I can see it in my Disk Management but as soon as it disconnects itself this disappears. I have tried to format it but it does not stay connected for long enough!
    I am running Windows 10. The same problem seems to also occur on a windows 8 machine.
      My ComputerSystem Spec
  2.    03 May 2016 #2
    Join Date : Sep 2015
    Posts : 51
    W10

    Is it getting it's power from a single USB port?

    If so try either a Y cable to get power from two ports, or a powered hub.
      My ComputerSystem Spec
  3.    03 May 2016 #3
    Join Date : May 2016
    Posts : 3
    Windows 10
    Thread Starter

    Quote Originally Posted by 1nitram2 View Post
    Is it getting it's power from a single USB port?

    If so try either a Y cable to get power from two ports, or a powered hub.
    Thanks but no, it is getting its power from a separate power cable plugged into a power point.
      My ComputerSystem Spec
  4.    04 May 2016 #4
    Join Date : Apr 2016
    Manchester, U.K.
    Posts : 564
    Windows 10 Pro 64bit

    I have a Seagate 4TB drive with similar problem, plugged into the USB3 if I run a backup too often it disconnects, when reconnecting it it doesn't appear in My Computer nor under device manager. I have to unplug the power lead & reconnect then it'll appear but often it'll say the device requires a scan for errors which it finds & fixes, trying backup again & it does the same. Plugging into a USB 2 hub (powered) works fine. A 6TB drive permanently connected to USB 3 has never had any problems.
    You could try the same - unplug drive from USB & from Power then reconnect.
      My ComputerSystem Spec
  5.    04 May 2016 #5
    Join Date : May 2016
    Posts : 3
    Windows 10
    Thread Starter

    Quote Originally Posted by Doctor9fan View Post
    I have a Seagate 4TB drive with similar problem, plugged into the USB3 if I run a backup too often it disconnects, when reconnecting it it doesn't appear in My Computer nor under device manager. I have to unplug the power lead & reconnect then it'll appear but often it'll say the device requires a scan for errors which it finds & fixes, trying backup again & it does the same. Plugging into a USB 2 hub (powered) works fine. A 6TB drive permanently connected to USB 3 has never had any problems.
    You could try the same - unplug drive from USB & from Power then reconnect.
    Thank you for the suggestion. Unfortunately I have tried that and when I do unplug and re-power I can see the drive once more, but then 5 mins later it disappears again! I do not even have time to run a scan - if I do the drive will disconnect before the scan finishes. The same if I try to reformat - it fails the reformat when the drive disappears.
      My ComputerSystem Spec
  6.    05 May 2016 #6
    Join Date : Apr 2016
    Manchester, U.K.
    Posts : 564
    Windows 10 Pro 64bit

    Have you tried running ckdsk? If you can get it to run the next time you start Windows, it'll take days though - mine did.
    Try formatting via command prompt with admin

    1. Go to DOS command line (click on "Start Menu", then "Run", type in "cmd" in textbox, and hit "OK")
      • Type in "DiskPart" in command line.
      • Type in "list disk" in command line to show all disks in this machine.
      • Use "select" to set the focus to the specified partition.
        For example "select disk 1".
      • Use "clean" command to remove GPT disk from the current in-focus disk by zeroing sectors.


      1. Go back to Disk Management, you can see GPT disk is "Not Initialized" now.
      2. Within Disk Management, right click on disk info, choose "Initialize Disk", You can see GPT disk is "Unallocated" now.
      3. Right click on disk info, choose "New Partition…", follow Partition Wizard and format it.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Seagate slapped with class action lawsuit over hard drive failure rate
Seagate slapped with a class action lawsuit over hard drive failure rates | PCWorld
Windows 10 News
New Seagate Eternal Hard drive not showing in Windows 10
http://www.seagate.com/gb/en/external-hard-drives/desktop-hard-drives/expansion-hard-drive/ New Seagate Eternal Hard drive not showing in Windows 10. I never formatted it but I did copy it's files on to c drive the application only asks for you...
Drivers and Hardware
Losing Seagate drive
When I first turn on my Dell XPS 2720, the attached Seagate hard drive is visible, i.e. I can access through File Explorer. During the day I lose contact and the only way I can reconnect is by switching off the drive and repowering. This immediately...
Drivers and Hardware
External 1TB hard drive(Iomega - seagate inside) RAW drive - HELP
I recently upgraded to Windows 10 and post that It was working fine without any issues. I have two external drive connected to it. 1. 1 TB Iomega powered drive. - now RAW 2. 2TB seagate external drive. The 1tb drive suddenly became RAW and I...
Drivers and Hardware
Seagate External Drive Not Waking
I have a Seagate external drive that I save my backups to. I run my backup around midnight, when the computer has not been used for a good 5-6 hours. I have been getting errors with the backup that the drive has not been accessible and thus the...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:21.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums