Page 1 of 2 12 LastLast
  1.    01 May 2016 #1
    Join Date : Feb 2016
    Posts : 8
    Windows 10 pro

    CD drive missing from File Explorer


    I'm trying to burn an audio CD yet the application doesn't recognise any CD drive. Checking further, the CD drive is not listed in File Explorer until a CD media is inserted that holds valid data. The drive disappears when the media is ejected.
    Under view options, the box is unticked for "hide empty drives".
    Under device manager the drive shows as present and working normally.
    I have tried switching autoplay on and off with no effect (suggested as a fix elsewhere).
    Any ideas?
      My ComputerSystem Spec
  2.    01 May 2016 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,137
    Win 10 Pro (1703)

    Hi, reported a number of times in the forum.

    Just search in the box above
    DVD drive missing
    CD drive not recognized
    etc to see how often

    Try:


    1. Run Command Prompt as an Administrator. (Windows key + X, click Command Prompt (admin) )

      2. Copy/type the following and enter

      reg.exe add "HKLM\System\CurrentControlSet\Services\atapi\Controller0" /f /v EnumDevice1 /t REG_DWORD /d 0x00000001

      3. Reboot the system

      My DVD drive was then automatically recognised. Yippee.


    Solved Windows 10 - my dvd/cd drive is not recognised, at all - Page 3 - Windows 10 Forums
      My ComputerSystem Spec
  3.    01 May 2016 #3
    Join Date : Feb 2016
    Posts : 8
    Windows 10 pro
    Thread Starter

    Ok, tried that, but it didn't solve the problem. The command above was executed successfully, but still no CD drive on reboot, see drives list below from explorer:
    Click image for larger version. 

Name:	Capture.PNG 
Views:	20 
Size:	7.4 KB 
ID:	77745
      My ComputerSystem Spec
  4.    01 May 2016 #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,137
    Win 10 Pro (1703)

    Oh, sorry, I didn't read your post properly.

    What you are describing is entirely normal...
      My ComputerSystem Spec
  5.    01 May 2016 #5
    Join Date : Feb 2016
    Posts : 8
    Windows 10 pro
    Thread Starter

    If normal, why is the drive not recognised as present in Windows Media Player when I attempt to burn an audio cd?
      My ComputerSystem Spec
  6.    01 May 2016 #6
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,137
    Win 10 Pro (1703)

    Here's WMP, no disk:
    Click image for larger version. 

Name:	Snap 2016-05-01 at 20.12.13.jpg 
Views:	18 
Size:	17.2 KB 
ID:	77749
    and with a blank disk inserted:
    Click image for larger version. 

Name:	Snap 2016-05-01 at 20.17.58.jpg 
Views:	18 
Size:	14.6 KB 
ID:	77750

    However, for example, if I eject the disk, WMP doesn't change- it doesn't update to show there's no disk.

    Explorer can be quite slow about that too.

    Also, inserting and ejecting the disk ought to produce an autoplay prompt each time- but it doesn't.

    Seems a feebly designed area if you try repeatedly inserting and ejecting a disk.

    If you eject the disk, and click on the DVD/RW icon in the navigation pane of explorer, this seems to force a scan- green progress bar- and explorer and WMP update.
      My ComputerSystem Spec
  7.    01 May 2016 #7
    Join Date : Feb 2016
    Posts : 8
    Windows 10 pro
    Thread Starter

    here's my view of the Burn tab in WMP:
    Click image for larger version. 

Name:	Capture2.PNG 
Views:	17 
Size:	11.0 KB 
ID:	77752
    Yet with an audio CD in the drive, in the Play tab, you see clearly the tracks on the cd
    and there are playable:
    Click image for larger version. 

Name:	Capture3.PNG 
Views:	17 
Size:	24.0 KB 
ID:	77753
    There is no DVD/RW icon in explorer as I mentioned above.
      My ComputerSystem Spec
  8.    01 May 2016 #8
    Join Date : Feb 2016
    Posts : 8
    Windows 10 pro
    Thread Starter

    An additional thought, might be significant. The hardware is a new pc, and up to now the cd drive has only been used to read cd media. This is my first attempt at any write operations. I've checked in device manager and established that the driver is up to date.
      My ComputerSystem Spec
  9.    02 May 2016 #9
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,137
    Win 10 Pro (1703)

    Check for cable problems (new desktop).
    Manually fix corrupted registry entries

    Note To use this method, you must be logged on to Windows as an administrator. If you need help verifying that you are an administrator, go to http://support.microsoft.com/gp/admin

    Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    This problem may be caused by two Windows registry entries that have become corrupted. To use Registry Editor to delete the corrupted Registry entries, follow these steps:
    • Press the Windows logo key + R to open the Run dialog box.
    • Type regedit in the Run dialog box, then press Enter. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow
    • In the navigation pane, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}


    • In the right pane, click UpperFilters.

      Note You may also see an UpperFilters.bak registry entry. You do not have to remove that entry. Click UpperFilters only. If you do not see the UpperFilters registry entry, you still might have to remove the LowerFilters registry entry. To do this, go to step 7.
    • On the Edit menu, click Delete.
    • When you are prompted to confirm the deletion, click Yes.
    • In the right pane, click LowerFilters.

      Note If you do not see the LowerFilters registry entry, go to12.
    • On the Edit menu, click Delete.
    • When you are prompted to confirm the deletion, click Yes.
    • Exit Registry Editor.
    • Restart the computer.


    12. Try uninstalling the driver, rebooting- this will refresh the default driver stack.
      My ComputerSystem Spec
  10.    02 May 2016 #10
    Join Date : Feb 2016
    Posts : 8
    Windows 10 pro
    Thread Starter

    Fixed!!
    Looks like it was my misunderstanding all along. It seems the DVD drive in my new computer is read only......I can hardly believe in this day and age these things still exist....what is the point!!
    Anyway, I have rescued the DVD drive from my discarded computer and installed that, and all is fine, I now have a writeable DVD drive, phew.
    In the mean time, thanks to Dalchina for all the advice given.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Delete and Cut missing from File Explorer Context Menu
My first post here. I searched here but could not find an answer, maybe someone can shed some light on this. I am trying to help an elderly friend who has run into a problem that neither of us can solve. I consider myself pretty savvy on...
General Support
Missing print option in Windows 10 File Explorer
Using file explorer to browse directories, and right clicking the document, there is no print option!
General Support
Solved Drives missing from File Explorer's Navigation Pane
Hello, As shown below there are 2 drives missing from the Navigation Pane (vertical bar on the left of the File Explorer). How do I show them up there? Thanks in advance. 49901
Drivers and Hardware
File Explorer - Folders missing, found moved.
I am posting this here under General Discussion since it is so spooky as to almost be a Twilight Zone thing. We have a 3-computer local/home network with all dynamic data stored on a network drive. We use File Explorer frequently. Six or...
General Support
Solved One Drive haters - here's how to remove One Drive from File explorer
Hi there Thanks to topgundcp here's how to remove One Drive from File explorer after a reboot. OneDrive Integration in Windows 8.1 - Enable or Disable 1.Win+R->gpedit.msc 2.Navigate to: Computer Configuration\Administrative...
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:39.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums