Windows 10: Logitech Unfying USB Key No Longer Recognized Solved

Page 2 of 2 FirstFirst 12
  1.    30 Apr 2016 #11

    TairikuOkami said: View Post
    Check, if you have all the drivers.

    Driver Easy Free Driver Updater

    Also note, that firmware has to be updated manually, maybe it is blocked due to security reasons by something?

    Logitech Response to Unifying Receiver Research Fi... - Logitech Forums
    None of the displayed drivers in that program relate to Logitech.
    I cannot do what the second link suggests because as previously stated:

    ChickenShark said: View Post
    YES, I HAVE installed SetPoint and Unifying Software from the Logitech support page multiple times, neither recognize the device as plugged in.
    I will look into the drivers that the program says are outdated to see if there's a fix in there. Thank you for your suggestion.
      My ComputerSystem Spec


  2. Posts : 2,279
    Windows 10.3 Home 1703 x64 (Home per choice)
       30 Apr 2016 #12

    ChickenShark said: View Post
    I cannot do what the second link suggests because as previously stated:
    It is an update for Unifying receiver, not for devices.
      My ComputerSystem Spec

  3.    30 Apr 2016 #13

    Click image for larger version. 

Name:	No Unifying Receiver.png 
Views:	9 
Size:	14.6 KB 
ID:	77606
      My ComputerSystem Spec


  4. Posts : 2,279
    Windows 10.3 Home 1703 x64 (Home per choice)
       30 Apr 2016 #14

    Well, that definitely looks like a driver's issue.

    I have just noticed, you have USB Root Hub (xHCI) disabled. Is it on purpose or by default?
      My ComputerSystem Spec

  5.    30 Apr 2016 #15

    I believe it is by default, at least I have not touched settings for it. I will see to that, thanks.
    I did not know that it was disabled, thank you for noticing that.

    Edit:
    I cannot believe myself. Apparently that was the issue.
    I have no idea how that became disabled, I suppose somewhere along the update. Again, thank you very much for noticing that.
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
I just upgraded to Windows 10 as I planned to use the weekend to sort out any issues I might encounter during the upgrade. Well boy did I ever. My Seagate 3TB drive decided it no longer wanted to be recognized by Windows anymore. It shows up as a...
New Logitech Mouse in Drivers and Hardware
I bought a new Logitech Wireless Mouse. But I am having issues locating the Serial Number. The SN that is on the mouse is not working. It's s Logitech m275 mouse. I would like to download the software for it. Please help! Thanks in advance!
Hey everyone! So, I've been running into a weird situation and I was hoping to run into some clarification on what I could do to fix the problem. I got a 128GB Flash Drive which I proceeded to install a portable, bootable Fedora install on. Of...
Solved Logitech Software & Win 10 in Drivers and Hardware
Whilst doing some work, my mouse suddenly 'failed', cursor frozen nothing in mouse. After plugging in another mouse, I checked device manager and found that Win 10 had installed it as an Hid complaint mouse. So I went to logitech, downloaded...
When I first went from W8.1 to W10, everything worked except the sound. Now after several updates, the icon speaker in task bar has an x by it, and when I hover mouse over icon the message states that "no audio output device is installed." When I...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:21.
Find Us