Windows 10: usb xhci compliant host controller (code 10)

Page 1 of 2 12 LastLast
  1.    16 Apr 2016 #1

    usb xhci compliant host controller (code 10)


    Hi all,

    I noticed today that my USB3 do not work any more, and after checking device manager, can see a code 10 error for usb xhci compliant host controller

    I have tried un-installing and reinstalling this, but still the error.

    Trying to update the driver just tells me that the most recent driver is installed.

    The option to rollback driver is greyed out.

    This worked a few days ago as use these ports a fair bit.

    Any ideas?
      My ComputerSystem Spec

  2.    16 Apr 2016 #2
      My ComputerSystem Spec

  3.    17 Apr 2016 #3

    Thanks for the hint... However I wouldn't know where to get a non-Microsoft driver from. Would it be my motherboard manufacturer (Gigabyte) site?
      My ComputerSystem Spec

  4.    17 Apr 2016 #4

    Hi, post #11 in the second thread suggests that. I can't add more I'm afraid, not having worked through such an issue personally.
      My ComputerSystem Spec

  5.    17 Apr 2016 #5

    Thanks for trying...

    I'm not having much luck, seems a lot of people online have a similar issue with no resolution.

    I have a Gigabyte motherboard: GA-Z77-DH3

    Intel i5-2500k

    Anyone else able to help please?

    Cheers
      My ComputerSystem Spec

  6.    17 Apr 2016 #6

    How did you check for a driver update? If you tried Windows normal update check, try

    Drivermax

    - I do not recommend driver scanners for normal use- only in exceptional circumstances. It's found me a couple of drivers this year.
    It uses (recommends) restore points- so make sure System Restore is turned on.
      My ComputerSystem Spec

  7.    17 Apr 2016 #7

    Just downloading now... Is this not a standard driver update program that charges once it's scanned?

    I used Gigabyte,s site, windows update and Intel's scan

    EDIT: Scanned and USB xHCI etc. is up to date...
      My ComputerSystem Spec

  8.    17 Apr 2016 #8

    Drivermax allows 2 free a day.

    So go down the path 'What has changed or what have I changed' in the relevant period
    E.g.
    So do you have any restore points- before you noticed the change?
    Have you received any windows updates or driver updates during the period?
    (You can check the events tab per driver)
    Have you installed any software?

    Try reversing these changes.
      My ComputerSystem Spec

  9.    17 Apr 2016 #9

    Don't know if i can help but a couple things to check. List any Problem devices
    • Click the Start button, type msinfo32 in the search box. Hit Enter
    • Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so

    Let's check if Class Filters exist
    > Right click the controller->Properties, select Details tab
    > Scroll through the list and carefully look if Class Upper Filters and/or Class Lower Filters are listed
    > If found, select it. What appears in the Value pane? You can Ctl-A to select all, Ctl-C to copy, and then paste into next post to list the values
    Attached Thumbnails Attached Thumbnails Filters.jpg  
      My ComputerSystem Spec

  10.    19 Apr 2016 #10

    Sorry just seen these replies, and thanks for the help...

    I don't think I've changed anything myself, but I believe there were some Windows updates recently, but not for this device according to the events tab... Although I have now turned it on, I didn't have system restore active unfortunately.

    USB xHCI Compliant Host Controller PCI\VEN_1912&DEV_0015&SUBSYS_00000000&REV_02\4&256F5A3A&0&00E3 This device cannot start.

    Unfortunately class upper filters / lower filters don't show in the list, although there are other similar ones:

    Class
    Class GUID
    Class description
    Class icon path
    Class name
    No install class
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Hello to everyone, So, before some time I had Win 8 and everything was fine. After a while I have had installed fresh Win 8.1 system. After that I tried and tried to make USB 3.0 in function but not successful. Trying everything, reinstalling,...
I have a gigabyte GA-Z77X-UD3H which uses the via chipset for USB (VIA VL800 chip) I have an error in system device for Usb xHCI Compliant host controller I am just wondering what drivers I can use for this? Also I didn't load any other...
Hello : Since I updated to win 10 . in device manager I'm having a problem with my usb host controllers , looks like I need a update for win 10 .49848
HID Compliant Game Controller Driver in Drivers and Hardware
If I have my RealFlight Interlink Elite Controller plugged into a USB port on a computer running Microsoft Windows 10 Pro the screen saver and power save options will not work. This work perfectly with Microsoft Windows 7 Ultimate SP1 prior to my...
Hi, I don't know if I post in to right place. I have a ps3 controller and have been sing it in windows 8.1 as xbox 360 controller by "scpserver", "Zadig" and "motioninjoy" ps3 driver. When I update windows to 10, the device work perfectly the same...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:05.
Find Us