SSD shown in Safetly Remove Hardware and Eject Media

Page 1 of 5 123 ... LastLast
  1.    07 Apr 2016 #1

    SSD shown in Safetly Remove Hardware and Eject Media

    I have a problem with two of my SSD's showing up as removable and non internal. One has my operating system on it so I'm hesitant to remove that one, but the other one only has games on it so I can use that for testing purposes. Here's some of what I've tried based on scouring forums and the internet: Disabling write caching (on or off no change), disabling hotswap in the BIOS (they were already set to off), and trying to update my Intel Chipset (Intel doesn't support drivers or something for Windows 10, of course I had this same problem in Windows 7, and I did a clean install of 10).

    I'm using IDE ATA/ATAPI controllers - Standard SATA AHCI Controller

    I also tried installing the Intel Rapid Storage technology which didn't really do anything other that confirm that its only detecting my SSD it considers "internal". I have since deleted it because it was useless.

    Click image for larger version. 

Name:	Portable.png 
Views:	7 
Size:	101.4 KB 
ID:	73678

    If I go into the properties for my drive, the one that it thinks is external (oddly enough it also thinks its internal) either in the Device Manager or where ever, it shows that there's a portable partition on it (its listed under Disk Drives and Portable Devices). When I go to the tab for Events under the portable one, it says Device install required and Device not migrated. I should also mention I have Samsung SSD's and I installed Samsung Magician, though I'm not 100% sure why other than it came with the drive. The issue may have started with that software because I don't remember the problem being present after the clean install.
      My ComputerSystem Spec

  2.    08 Apr 2016 #2

    Hi, I'm not attempting to answer this, but it will help people if you post a screenshot as follows:
    Windows key +R
    diskmgmt.msc <Return>

    and post a screenshot. Thanks!
      My ComputerSystem Spec

  3.    08 Apr 2016 #3

    The solution to the problem is usually to install an updated SATA AHCI controller driver.
    Windows provides a generic AHCI driver but this does not work with all motherboards. So it is best to use the driver supplied by the motherboard manufacturer.

    If the manufacturer does not post an actual SATA AHCI driver they will usually post an Intel Rapid Storage Technology driver instead (for Intel based motherboards, of course) and that will normally install a working AHCI driver.

    What I've run into a couple times now on the forums is that some people are using the secondary SATA controller on the motherboard to take advantage of the extra 6GB ports. What happens is that the secondary controller and those ports are using a proprietary driver, not the standard SATA AHCI driver the main 6 ports on the chipset are using. Therefore you get this problem.

    I can't tell you why the secondary controller driver does not handle AHCI and hot swapping capability as it should. It could be just because it is a secondary controller and there is some functional conflict with the main chipset.

    If this is the problem in your case you can test this simply by connecting one of the problem SSDs to one of the 6 main ports on the Intel controller. If it shows up as a fixed drive there then that would pretty much clinch it.
      My ComputerSystem Spec

  4.    08 Apr 2016 #4

    For the record, it isn't actually a problem. There's nothing wrong and it isn't hurting performance. It is just the way Windows handles the particular AHCI drivers you have installed. If you can't find others to "resolve" the issue, I wouldn't worry about it.
      My ComputerSystem Spec

  5.    08 Apr 2016 #5

    The motherboard I'm using, the Asus P8Z77-V doesn't have any updated drivers for windows 10, some people were saying to use the windows 8.1 drivers. Can I just delete these portable partition (whats shown in the picture I linked above) and be done with it?
      My ComputerSystem Spec

  6.    08 Apr 2016 #6

    There are some beta chipset drivers on the Asus website: P8Z77-V | Motherboards | ASUS USA

    I'm using Windows 10 Pro 64 bit.
    Last edited by Redwolf; 09 Apr 2016 at 13:17.
      My ComputerSystem Spec

  7. essenbe's Avatar
    Posts : 11,599
    Windows 10 Pro and Windows 10 Pro Insider
       08 Apr 2016 #7

    To clear up any misunderstandings, please post a screenshot of disk management. Disk Management - How to Post a Screenshot of and post the screenshot here, this will tell you how.

    If you are concerned that the drives are showing up in safely remove, DeaconFrost is correct. That is just the way Windows handled the AHCI drivers. One of the features of being installed in AHCI mode is the drives are 'hot swappable' which means they can be removed or added without shutting down the computer. That is perfectly normal.
      My ComputersSystem Spec

  8.    09 Apr 2016 #8

    Disk Management

    Click image for larger version. 

Name:	Capture.PNG 
Views:	11 
Size:	52.2 KB 
ID:	73989

    The disks that are considered removable are C and H.
      My ComputerSystem Spec

  9. topgundcp's Avatar
    Posts : 2,438
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       09 Apr 2016 #9

    You might want to check your MB BIOS, it does have an option to enable/disable hot plug when the Sata configuration is set to AHCI Mode.

    Click image for larger version. 

Name:	a.jpg 
Views:	2 
Size:	106.9 KB 
ID:	74006
    Last edited by topgundcp; 09 Apr 2016 at 14:05.
      My ComputerSystem Spec

  10.    09 Apr 2016 #10

    Hot Swap

    Interestingly enough it only lists two disks in the SATA config in my BIOS, the two that aren't considered Portable, and those both have the Hot Swap feature disabled.

    I should also note for everyone helping me that I uploaded an updated BIOS for my motherboard several months back since someone thought that might help, alas it did not.
      My ComputerSystem Spec

Page 1 of 5 123 ... LastLast

Related Threads
Hello, I'm new to Windows 10 and to this forum. I can't find the eject hardware icon anywhere. Under windows 7 it was in the system tray at bottom right. Few questions, please: 1. So where is that eject hardware icon? 2. I'm assuming that mice...
I installed Windows 10 on my desktop and the safely remove hardware icon is always there even when nothing is plugged in. When nothing's plugged in, clicking the icon just shows 3 dots (...) and a link to open the Hardware and Devices window (or...
Okay, a puzzler... My taskbar shows that I can "Safely Remove Hardware and Eject Media". Funny...I don't have anything plugged in. Selecting the message tells me that I can "Eject Nvidia GTX 970". Wouldn't that be odd? It's the friggin' video...
When I use the Safely Remove Hardware to remove, for example a USB flash drive, I do not get the notification that the device can be removed. I used to get this in Win 8.1 and I still get it in Win 7. Is there a way to enable the message? (I...
Title says it all. Even without any flash drives connected to my PC, it still displays this. Didn't happen when I was back in Windows 7.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:20.
Find Us