SSD shown in Safetly Remove Hardware and Eject Media

Page 4 of 5 FirstFirst ... 2345 LastLast
  1.    15 May 2016 #31

    If you go into Device manager and the Properties of the Storage Controller, is that setting there unchecked?
    Click image for larger version. 

Name:	hot swap controller.PNG 
Views:	49 
Size:	227.4 KB 
ID:	79912
      My ComputerSystem Spec

  2.    16 May 2016 #32

    TV2 said: View Post
    Do you have Intel Rapid Storage Technology Driver installed now? (One of the versions posted on your motherboard's website)

    Have you ever installed IRST?
    I have installed IRST before and it seemed to do basically nothing so I uninstalled it. I currently have Intel Control Center and Intel Driver Update Utility installed, I'll likely get rid of both soon since I'm sure these were failed attempts to solve the problem.
      My ComputerSystem Spec

  3.    16 May 2016 #33

    Storage Controllers

    I don't use Marvell Storage controllers so my menu tabs are a little different. The controller properties doesn't have a polices tab, but the individual disks in Disk Drives does. This is what it looks like as of right now:

    Click image for larger version. 

Name:	Untitled.png 
Views:	3 
Size:	74.5 KB 
ID:	80245

    This is the properties for one of the culprit drives.
      My ComputerSystem Spec

  4.    17 May 2016 #34

    There's a workaround you can try Here which worked for me in Win 7 and should work in Win 10 and also you might find a better matching driver Here and ultimately it is a driver related issue and when you find the right driver the entries should disappear
      My ComputerSystem Spec

  5.    17 May 2016 #35

    My registry doesn't have a msahci key. Also I went to that website you linked for the drivers before to fix this problem, either the driver wouldn't install or it didn't have any change.
      My ComputerSystem Spec

  6.    17 May 2016 #36

    Redwolf said: View Post
    My registry doesn't have a msahci key. Also I went to that website you linked for the drivers before to fix this problem, either the driver wouldn't install or it didn't have any change.
    Try to do the same in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor which in my case at least (Win 10 Pro X64) is the entry for the Intel AHCI driver (For lack of better name as it's really just an inf file). Did you install it manually from within the Device Manager as Fernando recommends. Of course back up your registry or take a system image before adding the reg entries
      My ComputerSystem Spec

  7.    19 May 2016 #37

    I have a iaStorA, iaStorAV, iaStorDataMgrSvc and a iaStorV in my registry under the path HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\

    Which one should I add the key to?

    And I take it you mean for me to add the TreatAsInternalPort key that someone linked a page ago?
      My ComputerSystem Spec

  8.    19 May 2016 #38

    Go to Device Manager expand your IDE ATA/ATAPI Controllers entry double click on the SATA AHCI entry go to the Details tab and in the drop down menu under Property choose Service which will show you if it 's iaStoreA or others you mentioned then create the reg entries as suggested in that Article I posted above. Create the Controller0 key by right clicking the iaStoreA or whichever entry was listed in the Service entry as above choose New then Key name it Controllers0 then right click that and repeat to create the Channel0 key then add the Dword in the right pane and restart. If it works then create the other keys to block other drives
      My ComputerSystem Spec

  9.    22 May 2016 #39

    Under Service it said storahci, so I did as that link said and there's no change.
      My ComputerSystem Spec

  10.    06 Jun 2018 #40

    TV2 said: View Post
    What I've run into a couple times now on the forums is that some people are using the secondary SATA controller on the motherboard to take advantage of the extra 6GB ports. What happens is that the secondary controller and those ports are using a proprietary driver, not the standard SATA AHCI driver the main 6 ports on the chipset are using. Therefore you get this problem.

    I can't tell you why the secondary controller driver does not handle AHCI and hot swapping capability as it should. It could be just because it is a secondary controller and there is some functional conflict with the main chipset.

    If this is the problem in your case you can test this simply by connecting one of the problem SSDs to one of the 6 main ports on the Intel controller. If it shows up as a fixed drive there then that would pretty much clinch it.
    I just fixed this ejectable SSD issue and this was the cause for me. This motherboard (Crosshair V Forumla-Z) has 6 "normal" SATA ports (AMD) and 2 other SATA (Asmedia). The Asmedia ones are indistinguishable on the motherboard itself making using them by accident very easy to do, all 8 ports are together in two rows, same color and all that jazz. When I swapped the 840 Pro over to the AMD SATA port, problem solved.

    This is my old secondary system I have set up for my wife, I didn't want her ejecting it by accident, kind of curious what would happen though.
      My ComputerSystem Spec

Page 4 of 5 FirstFirst ... 2345 LastLast

Related Threads
Hello, I'm new to Windows 10 and to this forum. I can't find the eject hardware icon anywhere. Under windows 7 it was in the system tray at bottom right. Few questions, please: 1. So where is that eject hardware icon? 2. I'm assuming that mice...
I installed Windows 10 on my desktop and the safely remove hardware icon is always there even when nothing is plugged in. When nothing's plugged in, clicking the icon just shows 3 dots (...) and a link to open the Hardware and Devices window (or...
Okay, a puzzler... My taskbar shows that I can "Safely Remove Hardware and Eject Media". Funny...I don't have anything plugged in. Selecting the message tells me that I can "Eject Nvidia GTX 970". Wouldn't that be odd? It's the friggin' video...
When I use the Safely Remove Hardware to remove, for example a USB flash drive, I do not get the notification that the device can be removed. I used to get this in Win 8.1 and I still get it in Win 7. Is there a way to enable the message? (I...
Title says it all. Even without any flash drives connected to my PC, it still displays this. Didn't happen when I was back in Windows 7.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:42.
Find Us