Windows 10: Numlock does not work unless I unplug and replug keyboard after reboot Solved

  1.    07 Apr 2016 #1

    Numlock does not work unless I unplug and replug keyboard after reboot


    I have had this problem on three different keyboards, from three different brands on two different computers.

    After a reboot, the numlock will not work. The indicator light goes on and off as expected, but I only get numbers - the arrow keys do not work, no matter what state the numlock key is in.

    If I unplug the keyboard, wait moment and plug it back in the numlock key functions as expected. Then a few minutes later it goes back to only doing numbers. A second keyboard "reboot" will usually make it stay until the next computer reboot. Sometimes I have to do it a third time.

    All of the keyboards with this problem have been have been high-end mechanical keyboards like the Corsair K70 I am using now. When I upgraded my home computer to Win10 (Razor Blackwidow keyboard), the problem went away. No such luck on my office computer.

    Any ideas?
    Brad
      My ComputerSystem Spec

  2.    03 Oct 2016 #2

    It is solved!
    Turns out that Webroot Secure Anywhere intentionally, and with malice aforethought, disables the numlock key in web browsers. I have no idea why.
    They have had a registry hack fix for a few years, but my googling never encountered it until now. But the Win10 anniversary update negated the fix!
    Good news, they have a new one. Here is the message and link from their tech support:
    Hello,

    Here are the instructions for the registry patch
    I hope this fixes the issue for you. If not please reply with any error messages that come up and I'll look into it.

    http://download.webroot.com/IDShieldNumLock.exe

    If the tool is run without arguments will modify the registry and prompt if ID Shield now has control of Num-Lock (Enabled) or if ID Shield no longer has control (Disabled). It will then ask for a reboot to complete the process.

    If the tool is run with an argument it will be run silently (for example: though Agent Command - Advanced - Download and run a file). Pass it one of the following arguments:
    -disable turns OFF ID Shield's control of Num-Lock (meaning it is now Disabled). The following are also valid arguments (/off, -off, /disable).
    -enable turns ON ID Shield's control of Num-Lock (meaning it is now Enabled). The following are also valid arguments (/on, -on, -enable).
    If the tool is run with two or more arguments nothing will happen.

    To note the registry key that this affects is HKLM\SYSTEM\CurrentControlSet\Services\ikbevent "DWORD":Type 0x01 with this key in place ID Shield's control of Num-Lock is disabled and with it removed it is enabled.

    Regards,
    The Webroot Support Team
      My ComputerSystem Spec


 

Related Threads
Keyboard in RDP sometimes wont work in Network and Sharing
Hello, I am facing this strange issue, i keep some rdp windows open for work all day and at some point the keyboard just stops working on the remote desktops, only the mouse works, to get it working again i have to close the rdp session and...
I have two desktops using a single keyboard, monitor and mouse via a KVM device. One desktop is running Windows 7 but I've just upgraded the other from Windows 8 to Windows 10. All was 100% well on both machines before the upgrade. The Windows 7...
Someone's help sure would be appreciated. I worked on my computer for several hours then it suddenly rebooted and said it was working on updates. Then an error of ArcCon bad image " (C:\windows\system32\WTSApi32.dll) is either not designed to run on...
Keyboard won't work Sony vaio in Drivers and Hardware
My keyboard will not operate on my Sony vaio VGN-AR since I loaded 10 from Vista.
Any ideas as to why the Start menu and all apps do not work after every other reboot, tried the Poweshell fix, no luck
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:57.
Find Us