Windows 10: Using an SSD as a USB Data Drive

Page 2 of 2 FirstFirst 12
  1.    21 Mar 2016 #11

    It's not an "old" drive, just old in that the laptop for which it was a boot drive has been replaced. It's probably 18 months old and has the current firmware in it.

    As for Lightroom, it was partitioned and reformatted prior to copying the catalog. Lightroom has never used it for a scratch drive.

    As I said, once I moved it to a standard USB 3.0 port rather than using the USB 3 hub attached to the USB 3.1-c port it works fine. My "normal" 7200 rpm HDD(s) work fine plugged into the hub, but the SSD didn't like it. I had it plugged into the Windows 10 Professional desktop when I did the partitioning and formatting, plugged into a regular USB 3.0 port and it worked fine there. SO, I suspect there's something different when using the hub, but it's not a big deal since I can plug other things into the hub and use the SDD directly into a USB 3.0 port.
      My ComputersSystem Spec

  2.    21 Mar 2016 #12

    Hi,

    SO, I suspect there's something different when using the hub, but it's not a big deal since I can plug other things into the hub and use the SDD directly into a USB 3.0 port.
    That could well be it. The hub isn't "taxed" when using a regular spinner but is choking when a SSD is attached to it.

    Cheers,
      My ComputersSystem Spec


  3. Posts : 3,361
    W10 Pro x64/W7 Ultimate x64 dual boot main - W10 Pro Insider Preview/W7 Pro x64 - remote pc
       21 Mar 2016 #13

    Is the hub usb or ac adapter powered? For any basic hub powered by the port you can't actually plug much in. For those with separate adapters being self powered on the other hand I have seen this problem with flash drives cleared where on one hub a number of brands simply work work since they tend to draw on the current heavier then the hub can provided since it is already taking some of that away while the self powered hubs carry their own weight.

    When installed internally there is an abundance of current generally seen when a good supply is in use. SSDs should function as well as any other drive since the current levels are maintained. The first SSDs as well as later models were based on seeing that extra current typically seen when having been powered directly from the supply while newer models are a bit more energy efficient for use on laptops and lowered All in One type desktops with small power requirements there.

    In contrast as far as seeing a mechanical drive in a usb enclosure being plugged into a 7 port self powered 2.0 hub along with a 16gb 3.0 flash drive both are working as normal. The blue arrow points to the 1gb WD Black Sata 3 hd in the usb/eSata enclosure while the yellow points to the 16gb Kingston 3.0 flash drive.

    Click image for larger version. 

Name:	Drives on USB Hub.jpg 
Views:	2 
Size:	92.5 KB 
ID:	70853

    Remember the CyberPower 2.0 hub is self powered having it's own ac adapter and still will allow a second external enclosure with the WD Green 1tb Sata II drive to be plugged in as well as other flash drives both 2.0 and 3.0 type. The problem likely for not able to use the SSD does seem to point out a non self powered hub being the actual problem in further review.
      My ComputerSystem Spec


  4. Posts : 3,833
    Mac OS Sierra
       21 Mar 2016 #14

    I use a USB to SATA adapter, since my case for eSATA and USB already has a 300 GB in it.
      My ComputerSystem Spec


  5. Posts : 3,361
    W10 Pro x64/W7 Ultimate x64 dual boot main - W10 Pro Insider Preview/W7 Pro x64 - remote pc
       21 Mar 2016 #15

    And you plug that into..??? not a usb hub I have to assume but a separate port regardless of being 2.0 or 3.0 but a separate port where there is adequate juice to run the drive correct? Unless you have a well made hub that is self powered the most you would plug in on one of those would be a flash drive, camera, cell or smart phone to upload photos or something and not rely on them to support any hard drive. Another thing about charging cell phone is where you would also have to watch charging those on self powered hubs but either off the port directly or something like a wall plug in with a port there or here a Sharp alarm clock with two ac outlets on a switch of all things as well as single port! Found that in a Walmart one day after cooking one side of a hub when going to charge up a cell phone one too many time! http://www.walmart.com/ip/Sharp-Alar...Black/24225430

    Speaking of charging the cell phone now beeping again! I keep a Nitecore DigiCharger D4 slot flash light battery charger plugged into that being switched on or off when going to recharge or charge up new batteries(rechargeable only) being AAA, AA, C, D, 18350, 18650 Lithium, etc. since the charger auto detects the type and when finished charging. Amazon.com: Nitecore D4 New 2014 Version Black Digi Charger 2014 version 4 Slot LCD Display For IMR Li-ion LiFePO4 26650 22650 18650 18490 18350 17670 17500 14500 10440 16340 RCR123 Ni-MH And Ni-Cd AA AAA AAAA C Rechargeable Batteries.Certified By RoHS CE FCC CEC.With 1 X OOPSTEKĀ® Battery Box: Electronics

    So far the port on the clock has been A #1 for getting things charged up while for most portable devices as well as drives in enclosures despite having one plugged into the 7 port hub here would still be having them plugged directly into a separate port to meet not only the minimum current it will pull on but for the best detection and mounting of the volume(s) on the drive itself.
      My ComputerSystem Spec


  6. Posts : 3,833
    Mac OS Sierra
       22 Mar 2016 #16

    It sounds almost as if it may have crashed or the enclosure is bad. If you pull the drive and connect it to a machine on the SATA interface, does it work okay?

    You can also use a Linux Mint Live DVD to read the S.M.A.R.T. data and see if something is wrong. Fixing any issues is a little harder in linux. But you do not have to go hunt down the proper tools to error check, since Linux comes with that stuff built into the Kernel & OS.
      My ComputerSystem Spec


  7. Posts : 3,361
    W10 Pro x64/W7 Ultimate x64 dual boot main - W10 Pro Insider Preview/W7 Pro x64 - remote pc
       22 Mar 2016 #17

    Generally the drive's manufacturer would have their own diagnostic tools available since this is an SSD not mechanical where you can run the Seatools on any brand or download a brand's tools. As for something wrong with the enclosure that has already been ruled out since plugging it directly into a port and not the likely usb powered hub saw immediate results.. I suspect the drive was known to be in working in order before being placed into the enclosure as indicated by the OP.
      My ComputerSystem Spec

  8.    22 Mar 2016 #18

    The hub is powered by a Type-c port. The specs are that it's capable of generating 100 watts, 5 amps of power. So, I don't think there's a power problem. The SSD didn't crash, it works fine in a "regular" USB 3.0 (or 3.1) port. It just doesn't like being on this 4-port hub.
    I also, just for giggles, swapped the 1TB external and the SSD enclosures. Same result. The HDD doesn't care what it's plugged into. The SSD doesn't like the hub.
    The hub is CAPABLE of being self powered. I could plug in a power supply just to see what it would do, but in truth it's easier just to put the SSD into a port when I need it...
    I also need to test the camera tethering to see if that works properly going through the hub. I suspect it will since it's just shoving 40-50MB upstream directly into Lightroom whenever I take a shot. BUT, I'll test to be sure.

    As it is, the 4-port hub works fine for wireless mouse and keyboard, HDD, USB3 card reader, and the self-powered backup drive that event images get backed up to every 15 minutes. SO, I have plenty of direct USB ports available if needed...
      My ComputersSystem Spec


  9. Posts : 3,361
    W10 Pro x64/W7 Ultimate x64 dual boot main - W10 Pro Insider Preview/W7 Pro x64 - remote pc
       22 Mar 2016 #19

    That's good! The thing about the hub not being plugged in however means it is still drawing directly off of a port and not seeing the adequate current levels since you left the ac adapter out of the equation. The specs go by having that plugged in not by what is drawn from a port only. I have to suspect that as well as a detection problem as the two reasons why neither drive will work. With the enclosures as well as hub here I can imagine I could take your SSD and enclosure and plug it in on the 7 port hub and not have one problem since the power is from the ac adapter which maintains the proper current level.

    With the drives in the enclosures here one just happens to be a Sata 3 in a 2.0/eSata combo type enclosure being plugged into a the 7 port 2.0 hub into a 2.0 port! I have another 4 port 3.0 hub non powered still sealed in the package however I still need to get a good 4-6ft cable for in order to reach due to where the case is pushed back into the cabinet section on the pc desk here. The other hub came with a long enough cable to end up being placed between the two monitors on the dual display setup here.

    I have a friend with a laptop who is always running into problems of not being able to use only certain brands of flash drives like San Disk and Kingston but not Memorex, PNY, HP I tossed his way after buying it from an office supply store and naaaaa.. not good enough for the purpose! His is a strictly non powered 6 port hub I suspect was one I had picked up and tossed as well for this type of problem and then went for the led lit CyberPower 4 port hubs cooking one side two ports charging a cell phone on it one too many times and when you plug anything in on the blue led lit hub the drive or device sees a yellow amber led for each port light up. No mistake on whether or not the ac adapter is in or not!

    But with every flash drive plugged in it will work without a problem as well as anything else usb. Too my friend won't take one of the spares I keep onhand! Likewise I would definitely give yours a try there and may also find that ac adapter is what will make the difference.
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
How can you get say 7 or another 10 box to see the partitions on the hard drive with the crashed 10? I hook up the drive with external usb adapters and only thing I can see is the partition that isnt allocated. I have tried everthing on the drive...
Solved Save RAW drive - Don't want data in Drivers and Hardware
One of my WD Green 2tb drives has become raw and can't be used. Windows will not complete a format of it. Shows up in my computer. Is there any way of saving this drive?
Data Hard Drive in This PC in Drivers and Hardware
I got this PC yesterday and have noticed that there is a random empty drive in This PC. It says "762 GB free of 763 GB." Does this come with every OS and what is it used for?
Data on separate partition or drive? in Installation and Upgrade
Wondering how Windows 10 deals with putting data on a separate partition or drive. Does it use the same general method as in Windows 7, where it re-maps (for example) "Documents" to a folder on a different letter drive path? So that...
I intend to partition a hard drive I'll be buying to install Windows 7 and Windows 8.1 on each partition but I don't want to lose my data after I've installed Windows 7 and then 8.1 or maybe install the Windows 10 preview 32 bit. I am not going to...

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 03:50.
Find Us