1.    17 Mar 2016 #1
    Join Date : Jan 2015
    Posts : 152
    Win7

    Is my hard drive dying?


    My system has an SSD boot drive and a secondary internal hard drive. The hard drive is assigned drive letter E. I use it for general storage, downloads, etc.

    Starting today the system hangs at boot time on SATA Port 6 - which is where the hard drive is connected. If I pull the power connector off the drive and boot the system boots OK but (of course) without drive E. If i then connect the power cable to the drive it appears as a removable drive and works fine. CHKDSK finds no errors. Update Driver says the driver is current. Device Manager & Disk Manager show the drive properly. Basically the drive works OK.

    The only way I can get the system to run properly is to unplug the power cable from the hard drive and then reconnect it after the system boots. So is this telling me the drive is bad? Even though it works OK when mounted as removable?
      My ComputerSystem Spec
  2.    17 Mar 2016 #2
    Join Date : Jul 2015
    Posts : 9,552
    Windows 10 Pro

    In bios make sure your SSD is set as the priority (first) boot device and disable booting from SATA 6 and the hard drive connected to SATA 6.

    Also with all drives connected and visible in Device Manager/Disk Management, please post a screenshot of Disk Management. Make sure to read the tutorial, we need to see all the information in the expanded columns:
    Disk Management - How to Post a Screenshot of - Windows 10 Forums
      My ComputerSystem Spec
  3.    17 Mar 2016 #3
    Join Date : Jan 2015
    Posts : 152
    Win7
    Thread Starter

    Some improvement


    I was able to get the system to boot with drive E powered on by stopping the Samsung Magician software from starting at boot time. My boot drive is a Samsung 840 EVO and it looks like their Magician software defaults to auto-start. But it really isn't needed, so I have disabled the Auto-Start function.

    Now. although the boot still gets temporarily stuck on "Detecting SATA Port 6", it does boot OK with drive E: powered on. But after booting Drive E is not shown. Here is a screenshot of Disk Manager after booting is complete:

    Click image for larger version. 

Name:	before.JPG 
Views:	2 
Size:	139.4 KB 
ID:	69919

    and here is Disk Manager after I have unplugged/replugged drive E's power cable:

    Click image for larger version. 

Name:	after.JPG 
Views:	4 
Size:	134.3 KB 
ID:	69920

    My BIOS (Asus P6T motherboard) shows all 6 SATA ports, but only 2 are active: #2 with the SSD and #6 with the HDD. I've tried moving the HDD to a different port and the results are the same. The BIOS only lets me select boot order from existing drives; there is no option to disable booting from any specific SATA port.

    After showing up in Explorer drive E works fine. My best guess at this point is that something got whacked in the drive's firmware that makes it think it is only a removable drive (or something like that). My other removable drives USB connections) still behave properly. So this is a very obscure situation for sure.
      My ComputerSystem Spec
  4.    17 Mar 2016 #4
    Join Date : Jul 2015
    Posts : 9,552
    Windows 10 Pro

    Do you have an option to turn on/off hotswapping on the SATA ports in bios? You will want hotswapping turned off.
      My ComputerSystem Spec
  5.    17 Mar 2016 #5
    Join Date : Jan 2015
    Posts : 152
    Win7
    Thread Starter

    Nope - no such option.

    What gets me is yesterday the whole system worked fine. I wonder if there was some update that got installed automatically that has fouled things up.
      My ComputerSystem Spec
  6.    17 Mar 2016 #6
      My ComputerSystem Spec
  7.    17 Mar 2016 #7
    Join Date : Jan 2015
    Posts : 152
    Win7
    Thread Starter

    Thanks for the tip _ I was not aware that CHKNTFS existed. But no joy - it simply said Drive E: is not dirty. So using the /F switch won't help because when the system boots, it boots without drive E: visible. The only way I can make it visible is to unplug/replug its power cable after the system is running.
      My ComputerSystem Spec
  8.    17 Mar 2016 #8
    Join Date : Jan 2015
    Posts : 152
    Win7
    Thread Starter

    Good news! I formatted the drive and that seems to have fixed the problem. The system now boots ok and shows the drive. Will do some testing to make sure everything is OK.
      My ComputerSystem Spec
  9.    18 Mar 2016 #9

    Quote Originally Posted by bbinnard View Post
    Good news! I formatted the drive and that seems to have fixed the problem. The system now boots ok and shows the drive. Will do some testing to make sure everything is OK.
    Cool! Thanx for the feedback
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Possibility to use Nearly all memory on a flash drive/ hard drive?
now im a computer tec and i know that memory cards and hdd are sold as "base 10" like 1gb=1000mb to them instead of 1024mb but im revisiting this question because i was looking into this for some time now and there are some people claiming thats its...
Drivers and Hardware
Solved Hard drive inaccessible after upgrade - (apps stored on drive run)
Okay, here's a weird one. And of the searching I've done, it seems others who've had this problem have had encryption, which I don't. Problem: When I click on my H: drive or try to access it from the command line, it gives me an access denied...
Drivers and Hardware
External 1TB hard drive(Iomega - seagate inside) RAW drive - HELP
I recently upgraded to Windows 10 and post that It was working fine without any issues. I have two external drive connected to it. 1. 1 TB Iomega powered drive. - now RAW 2. 2TB seagate external drive. The 1tb drive suddenly became RAW and I...
Drivers and Hardware
Solved Clone secondary hard drive to new hard drive
Hi! Bought a replacement secondary hard drive, but want to know best tool to clone it. My main drive is an SSD with Windows on, but I used Kari's tutorial to move the user folder on to a secondary hard drive, so just unsure on the best way to go...
Backup and Restore
Hard Drive\Non-Hard Drive Question - How Much Space ?
I have a lot of hard drives on quite a few pc's. I have always read that you should keep a minimum of 15% of free space on any hard drive, which I do on all of my hard drives (7 I think). I recently bought a LIVA MINI-PC and instead of a hard...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:34.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums