1.    14 Mar 2016 #1
    Join Date : Mar 2016
    Posts : 5
    Windows 10

    Storage Spaces issues adding drive


    I have a 4x 2TB drive storage pool setup with storage spaces under parity mostly used for movies/tv shows. I decided to buy 2 more 4TB drives and add them, but I only have space for 1 more at the moment (only 6 SATA connectors on my MB). After adding it (and appearing successful), it attempted to rebalance but eventually stopped changing the %complete and Storage Spaces eventually crashed. I tried again with my second drive, and the same problem. If I do "get-storagejob" in Powershell, every time i boot up it has 3 jobs (screenshot in linked Imgur album) and 2/3 of them always fail at 42%.
    I've tried removing both of the drives that failed to add (crashes), I've tried cancelling the rebalancing (crashes), and many other things but Storage Spaces continues to crash as soon as those 2 jobs reach 42% or I do anything to change something.
    Data on the drive appears accessible, but any attempt to view results in eternally spinning progress bars (sometimes a second or two of video before sputtering out). I'm usually pretty good with Google and can solve my own problems but this has had me spinning my wheels for days.
    Computer:
    OS - Windows 10 Pro
    CPU - i7 6700
    MB - Z170A PC MATE
    Any other details should be in the CPU-Z pastebin if it helps.
    http://imgur.com/a/f2ObI
    http://pastebin.com/T0SMLrqh
      My ComputerSystem Spec
  2.    17 Mar 2016 #2
    Join Date : Jul 2015
    Land of Enchantment
    Posts : 177
    Win 10 Pro x64 1709

    You might try running the powershell command "Update-StoragePool -FriendlyName "[NameOfYourStoragePool]" without first and last quotes. Make sure you run powershell as Admin.
      My ComputerSystem Spec
  3.    17 Mar 2016 #3
    Join Date : Jul 2015
    California
    Posts : 203
    Kernel 4.x.x

    Since you need more SATA connectors, and you're now starting to get serious about hard drive storage, I'd suggest ditching the software route (storage spaces, SoftRAID, etc)_ and getting yourself a dedicated RAID controller. They have their own processors on the card to handle all the RAID processing. Most have some memory on the card as well to make things work more quickly/smoothly.

    You'd be surprised how much of a difference it makes. One downside though, if you don't have an options to skip boot roms in your BIOS/UEFI (ASUS does, I'm sure others do) it may increase your boot time by several seconds. An advantage too though, that you can do some management of your RAID from the card's BIOS without having to boot your operating system. (good when/if the OS goes haywire)

    Don't get a cheap one if you do decide to go this route. Just about every card under $150 is worthless.
      My ComputersSystem Spec
  4.    17 Mar 2016 #4
    Join Date : Mar 2016
    Posts : 5
    Windows 10
    Thread Starter

    Thanks for the suggestion Railtech. I have tried that before but when I type that it asks me to confirm, I confirm, and then it doesn't say anything else. Not sure if did what it's supposed to, but it still crashes after about 5 minutes like it has been.

    Hydranix, from what I understand RAID is very inflexible and has it's own querks. I couldn't find a straight answer on how to simply add a new drive to expand the storage space in RAID not to mention expanding with a *gasp* different sized drive. I wanted something that could grow with me and didn't all need to be on the same raid controller. Regardless, I'll consider your suggestion after I get through this.
      My ComputerSystem Spec
  5.    17 Mar 2016 #5
    Join Date : Jul 2015
    Land of Enchantment
    Posts : 177
    Win 10 Pro x64 1709

    One thing I have found on new drives larger than 1 TB is corruption from the factory. Seems quality control has gone down hill somewhat in recent times. I always run chkdsk /r against new large drives to correct any corruption before putting them in service.

    Another possibility is sector size. the sector size on disk must be the same on all the drives otherwise you will be unsuccessful.

    1. Run msinfo32 in command line that should popup a GUI window called "System Information"
    2. In the left pane select "System Summary->Components->Storage->Disks". This should load info of all drives in the right pane
    3. Find your desired drive and check the value for "Bytes/Sector". it should list the sector size of each disk
      My ComputerSystem Spec
  6.    18 Mar 2016 #6
    Join Date : Mar 2016
    Posts : 5
    Windows 10
    Thread Starter

    Thanks for your help again Railtech,

    After much frustration and trying to unplug each individual drive and restart over and over again in an attempt to isolate any single drive causing the problem, it magically started to repair itself. It must have been a physical connection causing some mysterious error because previously they all showed up as healthy in "Get-PhysicalDisk" powershell command as well as CrystalDiskInfo SMART checks. After the storage space started repairing itself, it also showed up with several new errors in CrystalDiskInfo for one of my oldest disks but is still listed as healthy in the Storage Pool list. I imagine it's starting to fail so I'll remove it as soon as things are repaired and stable.

    I'll be sure to run checks on the new drives before I integrate them, but I think the stress of rebalancing caused one of the older drives some issues and somehow that threw everything out of whack. If it had cleanly failed, I suspect the parity could have rebuilt with my new drives, but it was holding on just enough to cause the system to crash over and over again.

    Mystery solved, and hopefully updating the storage pool helped.
      My ComputerSystem Spec
  7.    18 Mar 2016 #7
    Join Date : Mar 2016
    Posts : 5
    Windows 10
    Thread Starter

    One more question. These are the results for the drive that started showing a SMART error. Is this in any way recoverable or should it be turfed?
    Click image for larger version. 

Name:	2016_03_18_21_53_201.png 
Views:	8 
Size:	361.4 KB 
ID:	70169
      My ComputerSystem Spec
  8.    18 Mar 2016 #8
    Join Date : Jul 2015
    Land of Enchantment
    Posts : 177
    Win 10 Pro x64 1709

    Oh yeah! That drive is toast! Good for a door stop! I notice that this drive is an SATA II drive not SATA III, are you mixing these together in Storage Spaces? If so I would advise against it and if so that could be an underlying factor to the drive failure.
      My ComputerSystem Spec
  9.    19 Mar 2016 #9
    Join Date : Mar 2016
    Posts : 5
    Windows 10
    Thread Starter

    It's one of 2 of my first big drives that is still SATA II so that means there will only be 1 left after this whole process is over. Do you think its important enough to get rid of it proactively?
      My ComputerSystem Spec
  10.    19 Mar 2016 #10
    Join Date : Jul 2015
    Land of Enchantment
    Posts : 177
    Win 10 Pro x64 1709

    If it were me I would remove the SATA II drives from the pool and only keep the SATA III drives. The SATA II drive will degrade the drive pool from a performance stand point and because the SATA III drives can handle data much better and faster will cause the SATA II drive to run maxed out all the time thus leading to drive failure and failure of the pool again.

    Best to just remove it now and get it over with.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Storage Spaces - Unable to Remove Failed Drive / Repair Pool
I had 3x 3TB drives in a parity pool. It started to fill up so i added a fourth 3TB drive and months later one of the original 3 began to fail on me. Performance was slow, then slower, then it showed disconnected. I retired the drive and added a...
Drivers and Hardware
Are nested storage spaces possible? (Like RAID 0+1)
I recently had a 3TB hard drive fail on me, and I am trying to come up with a much better solution for storing my data so that I don't have to recover everything from CrashPlan again. My plan is to have two 3TB Hard drives connected in RAID 0...
Drivers and Hardware
Windows 10 to 8.1 back to 10 now missing storage spaces
Hi All, 1.So I had windows 8.1 with storages spaces working fine 2.removed my windows 8.1 HD and put in a new HD installing windows 10 3.On windows 10 storage spaces is great and working fine 4. I noticed that I forgot to back up something on...
Drivers and Hardware
Error using storage spaces/mirror
I upgraded from W8.1 to W10. After the upgrade my mirrored volume was 'gone' (created with disk management). Fortunately I was able to restore the data on one of the disks. I cannot manage to recreate a mirror on Windows 10. I tried using disk...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:59.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums