1.    09 Mar 2016 #1
    Join Date : Aug 2015
    Posts : 38
    Windows 10

    Problem with USB2 to IDE/SATA Bridge


    Hi! I recently tried to use this device which worked on Windows 7 Professional before upgrading to 10. I found that the USB2 device fluctuated from appearing in Device Manager. Also the SATA drive appeared as named device, then Local drive or disappeared completely.

    I could hear the PC trying to ID the devices. Same behaviour with my laptop, also with Windows 10.

    So I bought a new Bridge from Novatech as this stated Windows 10 compatable but this device is behaving exactly the same way. Novatech assure me no drivers are required. The drive appears stable then disappears. Does anyone have any ideas?

    Thanks
      My ComputerSystem Spec
  2.    09 Mar 2016 #2
    Join Date : Jul 2015
    Posts : 9,552
    Windows 10 Pro

    Have you tried only a single HDD or SSD on it or is this common among several HDDs or SSDs connected to it? Also, are you using the external power supply?
      My ComputerSystem Spec
  3.    09 Mar 2016 #3
    Join Date : Aug 2015
    Posts : 38
    Windows 10
    Thread Starter

    Quote Originally Posted by NavyLCDR View Post
    Have you tried only a single HDD or SSD on it or is this common among several HDDs or SSDs connected to it? Also, are you using the external power supply?
    You'd think that, having messed around with computers for years, I would have known better than to rely on a HDD that, although worked fine the last time out, may be at fault! Tried 2 more HDD, all worked fine so now I have 2 x USB2 bridges!! You live & learn.
      My ComputerSystem Spec
  4.    09 Mar 2016 #4
    Join Date : Jul 2015
    Posts : 9,552
    Windows 10 Pro

    Quote Originally Posted by gwladok5 View Post
    You'd think that, having messed around with computers for years, I would have known better than to rely on a HDD that, although worked fine the last time out, may be at fault! Tried 2 more HDD, all worked fine so now I have 2 x USB2 bridges!! You live & learn.
    You still might want to try the data recovery software.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
SATA III SSD shown as SATA II
Hi everyone.:nerd: I have just noticed that my Intel 520 SSD Drive is showing as SATA II drive. Now, I am aware that it is connected to a SATA2_0 port controlled by native Intel SATA II controller on my mobo and current speed should be 3gb/s. Why...
Drivers and Hardware
Can't create a Network Bridge.
Hello everyone, I have installed Windows 10 Insider Preview Build 14267, and when I go to adapter settings in Network and Sharing Center, I can't make a Network Bridge. I am trying to get Wifi and Ethernet together to get internet on my desktop PC,...
Network and Sharing
Hauppage PVR USB2 no sound
I have a hauppauge PVR USB2 card. I was happy to see the Vista driver installing on my Win10 x64, but when I finally connected the cable, I discovered that I have no sound. Any other having this card ?
Drivers and Hardware
Windows Bridge for iOS: Let’s open this up
Source: Windows Bridge for iOS: Let’s open this up | Building Apps for Windows See also: Open Sourcing the Windows Bridge for iOS - Windows 10 Forums
Windows 10 News
USB3 HDD slower than ext laptop HDD USB2==>SATA cable
Hi there WD passport (small self powered 2 TB USB3 drive) has appalling performance compared with an OLD laptop HDD that I connect via a USB2==>SATA cable to USB2 port. Same file (2GB mp4 video) copied to a directory on the SSD. External...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:44.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums