Windows 10: Can't format external USB drive. Solved

  1. Posts : 804
    10 Pro Preview x64
       19 Feb 2015 #1

    Can't format external USB drive.

    I am trying to format 2 partitions on an external 1TB USB3 drive. I had 2 ExFat partitions (partitions 6 and 7) which I have deleted and created 2 new ones using diskpart which I want to format NTFS.

    When I try to format them using disk management it hangs, explorer crashes and I have to hard power off.

    When I try diskpart I get the error "The parameter is incorrect. See the System Event Log for more information.". There is nothing to be seen at all in the system log.

    Have I created the partition table incorrectly in some way? It was originally created manually using this utility GPT fdisk |

    The other partitions are working fine.
    DISKPART> list disk
      Disk ###  Status         Size     Free     Dyn  Gpt
      --------  -------------  -------  -------  ---  ---
      Disk 0    Online          113 GB      0 B
    * Disk 1    Online          930 GB      0 B        *
    DISKPART> list partition
      Partition ###  Type              Size     Offset
      -------------  ----------------  -------  -------
      Partition 1    System             300 MB    24 KB
      Partition 2    Primary            119 GB   301 MB
      Partition 3    Primary            119 GB   119 GB
      Partition 4    Primary            118 GB   238 GB
      Partition 5    Unknown            619 MB   357 GB
      Partition 6    Primary            120 GB   358 GB
    * Partition 7    Primary            452 GB   478 GB
        0 percent completed
    DiskPart has encountered an error: The parameter is incorrect.
    See the System Event Log for more information.
    DISKPART> select partition 6
    Partition 6 is now the selected partition.
        0 percent completed
    DiskPart has encountered an error: The parameter is incorrect.
    See the System Event Log for more information.
    C:\Users\adam\Downloads\gdisk-windows-0.8.10>gdisk64.exe 1:
    GPT fdisk (gdisk) version 0.8.10
    Partition table scan:
      MBR: protective
      BSD: not present
      APM: not present
      GPT: present
    Found valid GPT with protective MBR; using GPT.
    Command (? for help): r
    Recovery/transformation command (? for help): o
    Disk size is 244011446 sectors (930.8 GiB)
    MBR disk identifier: 0x00000000
    MBR partitions:
    Number  Boot  Start Sector   End Sector   Status      Code
       1                     1    244011445   primary     0xEE
    Recovery/transformation command (? for help): p
    Disk 1:: 244011446 sectors, 930.8 GiB
    Logical sector size: 4096 bytes
    Disk identifier (GUID): xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxxxx
    Partition table holds up to 128 entries
    First usable sector is 6, last usable sector is 244011440
    Partitions will be aligned on 2-sector boundaries
    Total free space is 427 sectors (1.7 MiB)
    Number  Start (sector)    End (sector)  Size       Code  Name
       1               6           76805   300.0 MiB   EF00  EFI System Partition
       2           77056        31327055   119.2 GiB   0700  VMS
       3        31327056        62609823   119.3 GiB   0700  FAT
       4        62609824        93733915   118.7 GiB   AF00  Yosemite Recovery
       5        93733916        93892607   619.9 MiB   AB00  Recovery HD
       6        93892608       125349887   120.0 GiB   0700  Basic data partition
       7       125349888       244011263   452.7 GiB   0700  Basic data partition
    Recovery/transformation command (? for help): q
    Attachment 12896
      My ComputerSystem Spec

  2. Brink's Avatar
    Posts : 33,167
    64-bit Windows 10 Pro build 18262
       19 Feb 2015 #2

    Hello Adam,

    Test with the command below instead to see if it may work. :)

      My ComputersSystem Spec

  3. Posts : 804
    10 Pro Preview x64
    Thread Starter
       19 Feb 2015 #3

    Invalid syntax unfortunately.

    PHP Code:
    The arguments specified 
    for this command are not valid.
    more information on the command typeHELP FORMAT 
    I've confirmed it isn't the drive as I can format on another 8.1 computer. It isn't the USB hardware as when I boot this PC into OSX it works fine. In windows 10 the newly formatted NTFS partitions I can write to but not delete or copy big files so it isn't just formatting.

    It is connecting through UAS which is new for me. I'll have to check the drivers, disabling the controller and so on I guess.
      My ComputerSystem Spec

  4.    19 Feb 2015 #4

    That looks like a W10 bug to me. I would report it.
      My ComputerSystem Spec

  5. Posts : 804
    10 Pro Preview x64
    Thread Starter
       19 Feb 2015 #5

    whs said: View Post
    That looks like a W10 bug to me. I would report it.
    I think so - I just need to work out what to say. It is connecting through here:

    Attachment 12929

    Things that connect through USB mass storage device work. Things that connect through USB attached SCSI don't. Every driver says "Driver version 10.0.9926.0"

    It would be interesting to know if anyone else can connect to external drive using UAS and if it works if the drivers look like this (Right click on drive, Properties, Hardware tab, Properties, Driver tab, Driver Details)

    Attachment 12930

    Edit I've marked this thread solved and asked the same (hopefully more clearly) here Can anyone use USB attached SCSI in 10? :)
    Last edited by adamf; 20 Feb 2015 at 08:15.
      My ComputerSystem Spec


Related Threads
I'm doing fabbo with Win10 /s Because of some annoyances - hopefully fixed in the RTM Version - my USB drives cannot be ejected safely from their controller in Win10. So I eject them with the hardware release mechanism from the external...
External Hard Drive Issue. in Drivers and Hardware
Hi, I have version 10130 which I installed as an ISO file via my dvd drive,this was after Windows update failed on several occassions to upgrade it from 10074. The problem that I have is that my Seagate 750gb External Hard Drive is not accessible...
Can a small hard drive be converted to gpt & can you format a virtual drive as gpt with secure boot on? It looks like Microsoft is going to require Uefi enabled not sure about secure boot though for upgrade. I think that why I am had issues with...
Solved Can't format a partition in win 10 TP in Installation and Upgrade
hey there, can anybody please tell me why I can't format a normal data partition in Windows 10TP? It goes through the whole normal procedure and then gives me an error stating "Windows cannot complete the procedure". Even logged in as Administrator...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:39.
Find Us