Weird problem, Realtek USB 3.0 GbE adapter not working on one PC


  1. Posts : 146
    Windows 10 Pro 64bit
       #1

    Weird problem, Realtek USB 3.0 GbE adapter not working on one PC


    I have a weird problem on my Windows 10 Home laptop since a few days my Realtek USB 3.0 GbE adapter isnt working anymore. It worked fine before and it is also still working fine on my desktop PC, a Windows 10 Pro.

    It always shows "identifying network": https://i.imgur.com/nn7vHvU.png automatic and manual IP config dont work, both work fine on the desktop. It took me some time but I think the problem is a weird driver issue. Because on the laptop the device shows as:

    https://i.imgur.com/ZKwldFJ.png

    Realtek USB FE Family Controller, which seems to be wrong. The correct naming should be, was, and is still on the desktop:

    https://i.imgur.com/QG9Kzuk.png

    I looked onto the Realtek site and it seems there was a driver update a few weeks ago to: 10.5.1019 and it seems that Windows downloaded the driver a few days ago on my laptop and since then it got broken. The desktop has still the old driver 10.5.915.

    I tried to deinstall the driver via device manager and also clicked remove the driver on my laptop and Windows installed version 10.5.915 again afterwards, but it stays broken, it stays with the weird naming "Realtek USB FE Family Controller" instead of "Realtek USB GbE Family Controller" like it is on the desktop.

    I also noticed when I plug in the adapter, it is first named correctly "Realtek USB GbE Family Controller" in the device manager on my laptop but then deactivates again and activates as "Realtek USB FE Family Controller".

    I also noticed the network settings totally differ on the desktop and the laptop:

    Desktop (working) correct identified driver: https://i.imgur.com/EUDWsle.png

    Laptop (not working) obviously not right identified/loaded driver: https://i.imgur.com/5PMkCCf.png

    I guess FE stands for Fast Ethernet but the cable and switch port is GbE of course. And even if it was Fast Ethernet, that doesnt count for why it isnt working at all.

    Link also shows working and as GbE on the laptop: https://i.imgur.com/kg1PZbi.png
      My Computer


  2. Posts : 2
    Windows10
       #2

    Hello!

    I have exactly the same problem but I don't even have a net adapter. I have windows 10 in a surface pro 4. Please someone can help?
      My Computer


  3. Posts : 146
    Windows 10 Pro 64bit
    Thread Starter
       #3

    I solved the problem on my own of course because this forum is totally useless. You need to go into the device manager and activate show hidden/not connected devices. Then you will see the fast Ethernet version of the driver installed but "hidden", click on it and remove it. It's some nasty Windows bug I guess.
      My Computer


  4. Posts : 2
    Windows10
       #4

    First, Thank you for your answer!!


    I did what you tell me. remove it like this:


    https://i.imgur.com/myV8Y9X.png
    https://i.imgur.com/0YmFS35.png
    https://i.imgur.com/iyj8WBH.png


    So there is only the Gbe the good one. But as fast as I plug in the adapter the fe come back.
      My Computer


  5. Posts : 146
    Windows 10 Pro 64bit
    Thread Starter
       #5

    Delete both, also tick delete driver, then re-stick. Make sure 10.5.915 is installed afterwards and not the other one.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:48.
Find Us




Windows 10 Forums