Windows 10: Siberia V2 not working

  1.    16 Feb 2016 #1

    Siberia V2 not working after power shortage

    So I recently got a new computer and I connected my Siberia V2 USB version to one of the USB ports, and it worked fine. And suddenly the power went out due to a shortage and my computer got abruptly turned off. Few hours later I booted it up again and found out that my headset could no longer work. I checked my device manager and this is what I saw
    Click image for larger version. 

Name:	help1.PNG 
Views:	2 
Size:	29.3 KB 
ID:	64561
    It was showing up under Other Devices. I tried uninstalling it, restarting, and repluging the the headset but it didn't work either. The headset is shown to be connected on SteelSeries Engine 3. I've been looking for a fix to no avail and I hope that some one could help me fix this problem. Thanks in advance.
    Last edited by fraustbyte; 16 Feb 2016 at 12:08.
      My ComputerSystem Spec


Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:59.
Find Us