Windows 10: Storage Spaces - Unable to Remove Failed Drive / Repair Pool

  1.    15 Feb 2016 #1

    Storage Spaces - Unable to Remove Failed Drive / Repair Pool


    I had 3x 3TB drives in a parity pool. It started to fill up so i added a fourth 3TB drive and months later one of the original 3 began to fail on me. Performance was slow, then slower, then it showed disconnected.

    I retired the drive and added a replacement, literally the same model 3TB drive. I cannot however, get it to remove the failed physical disk and repair the pool. I even tried adding another 2TB drive i had available in case it needed the extra space (didn't make sense but i was reaching).

    I get the "drive could not be removed because not all data could be reallocated. add an additional drive to this pool and reattempt this operation."

    Any ideas on what i need to do? I have searched a lot and don't really seem to be getting anywhere. The only way i was able to retire the drive was through powershell. I'm assuming it's a GUI issue and perhaps i'm not approaching it correctly via powershell. Attempting to repair virtual disk didn't work.

    Any help is appreciated! I really don't want to lose this data. I wasn't able to backup much before the drive failed completely.

    Click image for larger version. 

Name:	spaces.png 
Views:	8 
Size:	52.0 KB 
ID:	64470
    Last edited by samsonbiatch; 18 Feb 2016 at 20:31.
      My ComputerSystem Spec

  2.    16 Feb 2016 #2

    Nada??
    Last edited by samsonbiatch; 18 Feb 2016 at 20:36.
      My ComputerSystem Spec

  3.    18 Feb 2016 #3

    Bump!
      My ComputerSystem Spec

  4.    23 Feb 2016 #4

    Click image for larger version. 

Name:	repair.png 
Views:	1 
Size:	38.6 KB 
ID:	65917Click image for larger version. 

Name:	getjob.png 
Views:	1 
Size:	47.3 KB 
ID:	65918Click image for larger version. 

Name:	spaces.png 
Views:	1 
Size:	52.0 KB 
ID:	65919

    still nothing.
      My ComputerSystem Spec

  5.    08 Aug 2017 #5

    I'm having the same thing happening and it's driving me absolutely crazy. I have added new drives thinking that was it. I've tried setting up a new storage space and even a storage pool, same stuff. I am fine with losing the 12% that was on that hard drive, I just wish it would let me remove it. Basically my storage space is pointless now and I'm stuck, I can read from it, but nothing can be written to it.

    Did you ever figure anything out with yours? What did you end up doing?
      My ComputerSystem Spec

  6.    08 Aug 2017 #6

    I realize this is old, just hoping you had some success and could help. One difference, mine will not repair using powershell, doing 'Get-StorageJob' shows it immediately suspending.

    Driving. Me. Crazy.
      My ComputerSystem Spec


 

Related Threads
I recently had a 3TB hard drive fail on me, and I am trying to come up with a much better solution for storing my data so that I don't have to recover everything from CrashPlan again. My plan is to have two 3TB Hard drives connected in RAID 0...
Hi there Beware if you CREATE storage spaces under W10 and roll back to W8.1 -- you'll get configuration error. DO NOT RESET the storage spaces as you'll lose the data. I think the file structures have changed in W10. What to do...
Hard Drive Storage Pool (Windows 10) in Drivers and Hardware
Hi I have a storage pool set up on my Windows 10 PC The storage pool is a total of 6.5TB at the moment with 2.7TB of Data on it I'm getting the Warning "Low Capacity" add another drive
Hi All, 1.So I had windows 8.1 with storages spaces working fine 2.removed my windows 8.1 HD and put in a new HD installing windows 10 3.On windows 10 storage spaces is great and working fine 4. I noticed that I forgot to back up something on...
Error using storage spaces/mirror in Drivers and Hardware
I upgraded from W8.1 to W10. After the upgrade my mirrored volume was 'gone' (created with disk management). Fortunately I was able to restore the data on one of the disks. I cannot manage to recreate a mirror on Windows 10. I tried using disk...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:14.
Find Us