Computer is a Toshiba Laptop Model L775D-S7132. I've posted this on the Win 10 Insiders Forum also but so far no results.

I've been very lucky having been an Insider starting with Build 8874 (I believe) back in October 2014. Through all the new Build installs since then, I've had no real serious problem.

However, with Build 14257 installed yesterday, my CD drive is not recognized in Explorer and sports the Code 19 Registry error in Device Manager. I did all the quick and easy stuff first (all several times) including update driver, scan for hardware changes, uninstall/reinstall. Ran Hardware troubleshooters (several) and all agree there's a problem but didn't fix. Tried all five Windows Support suggestions found HERE which include deleting the upper and lower filters in the Registry (I didn't have either) and adding a Registry entry. Also tried Safe Boot with no luck. Trying a CD in the drive results in the blinking light when first started but then nothing else.

I can, of course, revert to the prior build and try all over again but that is a 5 hour job here with my relatively low DSL speeds. If I can't get it fixed, I'll probably just wait and hope the next Build installation fixes it.

If anyone has any other ideas, I would be interested in hearing them.