How Long Does It Take to Open Devices & Printers?

Page 5 of 7 FirstFirst ... 34567 LastLast

  1. mck
    Posts : 133
    Windows 10 Home
       #41

    Steve C said:
    The setting All Control Panel Items\Printers was gleaned from the Classic Shell Menu I used. I sent a shortcut to the desktop which works and looks like this:

    ... snipped image to save bandwidth ...

    However, you don't see the printers setting in Control Panel.

    You can install a printers shortcut without using Classic Shell. Run the command shell:PrintersFolder This opens the classic printer folder. Then drag the address to your desktop to create a printers shortcut. See https://www.tenforums.com/tutorials/...dows-10-a.html for all shell commands.
    Hi Steve C,

    Thank you very much for taking the time to respond and even post that picture. I think I'm going to use the SETTINGS > DEVICES for now since that opens instantly for me, and continue to investigate, every now and then when I have time to kill, why "Devices & Printers" is slow to open for me.

    Happy New Year,
    mck
      My Computer


  2. mck
    Posts : 133
    Windows 10 Home
       #42

    topgundcp said:
    All my PC's open it almost instantly.
    One of the followings might be the cause:
    1. The program is trying to discover all the devices in your PC and on the networks. Once in a while the Router DNS cache is expired causing the PC to re-discover all devices on the network, this is why to better assign a static IP for each device on the network in the router.
    2. One of the HD/SSD is corrupted and the program is having hard time to discover.
    3. Built in bluetooth device. By default, the services for this device is set to "Manual (triggered)". Open the services, set all related bluetooth device services to "Automatic"
      NOTE: If you don't have any bluetooth device then disable these services.
    Hi topgundcp,

    *1. - I think I need to remain with dhcp instead of a static IP for each device so that when guests come over, I can just give them my wi-fi password and they can use my network without my having to do anything. --- To test if this is my problem, what do I have to do? I previously tried turning off Network Discovery and it did not make any difference.

    *2. - I don't have any problems with my C: system SSD or my D: data HDD during my daily use. Also, I do periodic full backups of the SSD and HDD and the backup program has not complained during the backup creations or during the verify followups. I guessing both devices are OK and that neither device is causing the delay.

    *3. - During my Googling, I read about bluetooth possibly causing the problem so tried setting both bluetooth entries in Services to automatic and to disabled. Neither had any effect.

    Thanks so much for taking the time to help,
    mck
      My Computer


  3. Posts : 2,790
    Linux Mint 20.1 Win10Prox64
       #43

    @mck
    *1. - I think I need to remain with dhcp instead of a static IP for each device so that when guests come over, I can just give them my wi-fi password and they can use my network without my having to do anything. --- To test if this is my problem, what do I have to do? I previously tried turning off Network Discovery and it did not make any difference.
    It should not affect anything, the router still assigns an IP via DHCP. Assuming you have 10 network devices (network printer, smart TV, IPAD, IPHONE etc...) and reserve an IP for each so if you have a guest login into your network, the router should automatically assign the next available IP except those that were reserved.
      My Computer


  4. Posts : 2
    Windows 10 Pro
       #44

    I'm facing a similar issue however in my case, with the help of process monitor, I managed to track it down to be caused by Windows Explorer which is querying the registry endlessly for HDAUDIO entries under HKLM\System\ControlSet001\Control\DeviceClasses\... Seems like a loop to me, removing Realtek HD Audio and Intel HD Audio drivers has not helped.
      My Computer


  5. mck
    Posts : 133
    Windows 10 Home
       #45

    topgundcp said:
    @mck

    It should not affect anything, the router still assigns an IP via DHCP. Assuming you have 10 network devices (network printer, smart TV, IPAD, IPHONE etc...) and reserve an IP for each so if you have a guest login into your network, the router should automatically assign the next available IP except those that were reserved.
    Oh, I didn't know DHCP can still be enabled while assigning static IPs. I'll research this further when I have some spare time. For now, 13 seconds delay for Devices & Printers isn't "too" bad.

    Thanks,
    mck
      My Computer


  6. mck
    Posts : 133
    Windows 10 Home
       #46

    argh9815 said:
    I'm facing a similar issue however in my case, with the help of process monitor, I managed to track it down to be caused by Windows Explorer which is querying the registry endlessly for HDAUDIO entries under HKLM\System\ControlSet001\Control\DeviceClasses\... Seems like a loop to me, removing Realtek HD Audio and Intel HD Audio drivers has not helped.
    What really doesn't make sense is why "Control Panel > Devices & Printers" can have 60 sec+ delays while at the same time "Settings > Devices" displays instantly.

    Thanks for contributing,
    mck
      My Computer


  7. Posts : 7,089
    Windows 10 Pro 64 bit
       #47

    mck said:
    What really doesn't make sense is why "Control Panel > Devices & Printers" can have 60 sec+ delays while at the same time "Settings > Devices" displays instantly.

    Thanks for contributing,
    mck
    And the printers shortcut I mentioned in post 39 also opens quickly. If the separate printers or devices shortcuts / links work quickly, why does the Devices & Printers option take so long?
      My Computers


  8. Posts : 19,215
    W11+W11 Developer Insider + Linux
       #48

    I had a problem like that with Devices & Printers from control panel in some earlier builds, specially with first Anniversary issue but later insider builds shrunk it to practically nothing, click and it opens.
    "Devices" from Start don't show all devices, just some but conventional "Devices & Printers" can be accessed also from that menu, There's a blue line at the bottom "Devices & Printers" that opens same thing as from Control panel.
      My Computers


  9. TV2
    Posts : 2,011
    W10 Pro 20H2
    Thread Starter
       #49

    mck said:
    Hmmm, another HP printer user who has slow opening of Devices & Printers. Wonder if anyone who does not have any HP printer, also has slow opening of Devices & Printers?

    mck
    I don't have any HP printers. Canon and Epson here. And I continue to have the long delay.
      My Computers


  10. TV2
    Posts : 2,011
    W10 Pro 20H2
    Thread Starter
       #50

    I have basically tabled this problem for the following reason (belief):

    From past discussions on this forum it seems that MS is planning on eliminating the Control Panel altogether sometime in the future. If this is true then it follows that they would not be putting time into working on the functionality of the legacy utilities. Therefore there will be no fix coming.

    Their nudge-nudge manipulation is: get used to using Windows 10 "Devices". Stop using the legacy "Devices and Printers".
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:27.
Find Us




Windows 10 Forums