USB 3.0 port transfer speed on HP Laptop not exceeding 40 MBPS


  1. Posts : 2
    Windows 10
       #1

    USB 3.0 port transfer speed on HP Laptop not exceeding 40 MBPS


    I tested the internal HDD with CrystalDiskMark and was able to get 109 MBPS both on sequential read and write tests. Then, when I tested my 1 TB WD My Passport USB 3.0 External HDD with CrystalDiskMark the sequential read and write speed did not exceed 40 MBPS the few times I tried. Got similar 30-40 MBPS speed when transferring movies from external HDD to internal HDD.
    So far, I have tried updating the external HDD and USB 3.0 Controller drivers. Tried with 'USB selective suspend setting' disabled (Under Power Plan Options). Also tried with write caching enabled. But havent been able to solve the issue.
    My laptop is running Win 10 Home 64-Bit. I am sure I used the USB 3.0 port. And, I used the USB 3.0 cable supplied with the external HDD. I don't have another USB 3.0 device so cannot figure out whether the issue is with my laptop of the external HDD.'

    Is there some Windows 10 setting that might be causing this?

    Please help me out here.
    Last edited by Speedster; 31 Jan 2016 at 05:16.
      My Computer


  2. Posts : 564
    Windows 10 Pro x64 21H1
       #2

    Internal and external speeds are fully different. Your internal hard drive runs off the South bridge Chipset, which all new SATA controllers are SATA III 6G. The USB 3.0 runs off a completely different controller or Chipset, such as AsMedia or VIA Chipset. That 40 MBS is actually a good transfer rate speed for an external 3.0 port.

    My Motherboard has USB 3.0 boost, and there was only one USB 3.0 flash drive in it, and the transfer rates were between 20mb to 35 mb a sec, which I think is normal for a flash drive. All other flash drives are USB 2.0 that I use in the ports
      My Computer


  3. Posts : 2
    Windows 10
    Thread Starter
       #3

    I was able to find a solution. Turns out that if you plug in a USB 3.0 HDD too slowly, then it will be recognized as a USB 2.0 HDD. This happens because in a USB 3.0 plug the USB 3.0 connector pins are in the second row. So, if you plug in the USB 3.0 HDD slowly then it gives the PC enough time to complete the protocol handshake and your USB 3.0 HDD is recognized as a USB 2.0 HDD before its fully plugged in. Which is why you don't get USB 3.0 speeds. So if you have a similar problem try plugging in your HDD quicker and see if it helps.
      My Computer


  4. Posts : 564
    Windows 10 Pro x64 21H1
       #4

    Hmm good catch. I'll keep that in mind
      My Computer


  5. Posts : 131
    Windows 10 Pro 64-bit
       #5

    I have found this to be as well. The USB 3 signals are behind the USB 2 pins and sometimes the USB metal shell is a little too long.

    I use USBTreeView to see the port speed.

    USB Device Tree Viewer
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:26.
Find Us




Windows 10 Forums