1.    26 Jan 2016 #1
    Join Date : Jan 2016
    Posts : 3
    Windows 10

    3 DVD drives on the same bus


    I have a Windows 7 PC with 3 DVD drives. Imgburn shows them as connected to 3 different SATA busses: [2:0:0], [3:0:0], and [4:0:0].

    After upgrading to Windows 10, all of them ended up on the same bus, [2:0:0], like this:
    Click image for larger version. 

Name:	bus.jpg 
Views:	19 
Size:	40.6 KB 
ID:	60877

    Why did that change? I tried connecting them on different SATA plugs, but they are always shown on that [2:0:0] bus. The thing is, I really need them to be on different busses, because of a particular requirement of a legacy application I use.
      My ComputerSystem Spec
  2.    26 Jan 2016 #2
    Join Date : Jan 2016
    Posts : 3
    Windows 10
    Thread Starter

    Things I tried:

    - Replace default Microsoft SATA driver with ATI driver. It didn't solve anything.

    - In BIOS settings, changed SATA type, from AHCI to Native IDE. It did kinda work, now they are shown in different busses, [0:1:0], [1:0:0] and [3:0:0]. But now I'm not using AHCI anymore, I don't like that solution.
      My ComputerSystem Spec
  3.    26 Jan 2016 #3
    Join Date : Jan 2014
    Inverness
    Posts : 1,198
    Win 10

    I don't know what problem you have. I have two drives on SATA0 and SATA1, the way they should be. I can burn to multiple drives at the same time with Nero (no other burning program that I've tried will burn to multiple drives at the same time).

    Imgburn shows my two drives as "4:0:0" whatever that means.
      My ComputersSystem Spec
  4.    26 Jan 2016 #4
    Join Date : Jan 2016
    Posts : 3
    Windows 10
    Thread Starter

    Quote Originally Posted by fireberd View Post
    Imgburn shows my two drives as "4:0:0"
    Thank you for your response. Is that on Windows 10 or Windows 7?
      My ComputerSystem Spec
  5.    27 Jan 2016 #5
    Join Date : Jan 2014
    Inverness
    Posts : 1,198
    Win 10

    That is Windows 10. I have a dual boot, Win 7/Win 10 and the drives work the same in Win 7 (and they worked the same when I had Windows 8/8.1).
      My ComputersSystem Spec

 


Similar Threads
Thread Forum
Where did the DVD drives go
Hello! A strange one for me. The DVD drives do not show except on Device Manager or Disk Management. SO NO DVD Drives in File Manager. Suggestions are greatly appreciated. Thanks and make sure that you have a great day!
Performance & Maintenance
SSD Drives
What is the fastest drive config. ? Is it the M2 socket. Getting ready for new build,speed is my main goal,hate to wait for computer to boot.
Drivers and Hardware
Two W10 drives
I just got a new DELL with a single HDD. I would like to take the system drive from my old HP Pavilion and install it as a second drive in the DELL (The drive is a very nice new WD). When I first boot up, the PC will see two system drives. ...
Drivers and Hardware
usb drives
Hi I have a usb hd but when i set the drive on then two screens cam up. The hd have to partions. How can i make that the screen not emerge and external hd partions Always have the same drive letter. But wen i connect the smartphone ore tablet...
Installation and Upgrade
Solved 2 Drives
I just noticed in File Explorer I have two opticle drives listed. When I click on drive G I get "Please Insert Disk Into Drive". Drive M is my opticle drive with a audio cd inserted. Anyone know why my drive is listed twice. 15556
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:50.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums