Windows 10: Print spooler chokes when attempting to print certain pdf files Solved

  1.    10 Jan 2016 #1

    Print spooler chokes when attempting to print certain pdf files


    The print spooler chokes on both of my Windows 10 machines when trying to deal with certain pdf files. For instance when I tried to print https://thebasscase.files.wordpress....01/so-what.pdf via my browser (Chrome), it printed the first 6 pages, but the printer showed an error when it came to the seventh page. When I then tried to create another job just to print the seventh page, it just hung around in the print spool and nothing happened at the printer. I tried this several times on two machines. It was also impossible either to cancel the job in the print queue manager or to stop the spooler in the services manager in order to manually clear the print queue, which meant that the only way I could clear the queue was to restart the machine. I got the same behaviour whether I was printing to my physical printer or to the MS pdf printer. I also got the same behaviour when I tried to print from a different browser (Edge). This is not the first time I have had a problem with an unprintable file like this in Windows 10. Is there a solution?
      My ComputerSystem Spec


  2. Posts : 3,434
    EL Capitan
       10 Jan 2016 #2

    Chrome has had an issue with printing PDF's from the built in PDF viewer. There is nothing wrong with your printer, Windows 10 install or Print Spooler.

    Save the PDF and then print from Acrobat if you need the pdf printed.

    Google refuses to fix their problem.

    If you open it in Firefox, it will print.
      My ComputerSystem Spec

  3.    11 Jan 2016 #3

    Thanks for your informative reply. I later discovered the Acrobat Reader workaround and was able to print. I also found that simply closing Chrome unjammed the print queue.

    Just a correction to something in my OP: I said that I had reproduced the problem using Edge, but I must have made a mistake then, because I was able to print the page in question just now using that browser. This means that viewing the pdf in Edge and printing from their is a slightly quicker alternative to using Acrobat.
      My ComputerSystem Spec


  4. Posts : 3,434
    EL Capitan
       11 Jan 2016 #4

    Print spooler chokes when attempting to print certain pdf files


    The reason that it works in edge, is because edge is using a better PDF viewer. Google no longer allows non-NAPI extensions in their browser, is why you have a lot of issues when printing within.
    Last edited by bro67; 11 Jan 2016 at 18:23.
      My ComputerSystem Spec


  5. Posts : 2,554
    Windows 10 Home x64: 1607 Redstone (1) Build 14393.1198
       11 Jan 2016 #5

    All I do if I want anything printed via PDF is click the 3 dots
    Scroll down
    Click Print the printer you are using appears
    Press print there and away you go
    I also only use Edge
      My ComputerSystem Spec

  6.    11 Jan 2016 #6

    Can I just add to what I said earlier that it turns out the page I couldn't print locally I could nevertheless print via Google cloud print to the same local printer. Therefore if the document does not contain sensitive data that you don't want to send through the cloud, cloud printing is a solution. Otherwise use Adobe Reader or a different browser as suggested above.
      My ComputerSystem Spec


 

Related Threads
Print Spooler in Drivers and Hardware
My update to Windows 10 from Windows 7 went without problems but none of the three printers attached to my computer worked and I have been struggling with the problem over the last two weeks. There is another long thread "Can't connect to Printer"...
"Print Spooler service isn't running" in Drivers and Hardware
For some reason, my printer doesn't show up in applications such as Microsoft Word or Libre Office, although I'm sure that it's connected properly to the computer because it still lets me scan documents. When I troubleshoot the printer, I get this...
Dear all, I'm stuck with my print spooler that doesn't want to start. It was working fine before the upgrade. I get the following message when going to the "view services on local computer" Windows could not start the Print Spooler service on...
Solved can't print in Network and Sharing
New laptop. Upgraded to Windows 10. Can't print to an HP 7520 which is on wifi. This was the 1st attempt to print on this PC. BUT, when I call up the PROPERTIES for the printer, I CAN PRINT diagnostics....I just can't print documents! And,...
I've had Windows 10 since Monday, I haven't been able to print anything, even making PDF files because the print spooler will not start. Or more accurately, it will start and then when you try to add a printer, it will stop. When I run the printer...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:01.
Find Us