Page 1 of 2 12 LastLast
  1.    10 Jan 2016 #1
    Join Date : Jan 2016
    Posts : 9
    Win 10

    Dell E6410 - No DVD after Win 10 install - Fixes don't work!


    Hello,

    I've just done a clean install of Win 10 on a Dell Latitude E6410. I didn't have acccess to Dell's own driver setup discs, so it's just what I got from Microsoft. Windows appears to run OK, but there's no sign of my DVD drive. That is, there are no DVD/CD entries in Device Manager, and no drive appearing in File Explorer.

    I know the drive is fine, because I've set up the laptop as dual boot with Linux Mint, and it works perfectly well there.

    I've tried doing the usual registry fix (reg.exe add "HKLM\System\CurrentControlSet\Services\atapi\Controller0" /f /v EnumDevice1 /t REG_DWORD /d 0x00000001), and rebooted, to no avail.

    I've checked HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}, and there are no entries for Upper or Lower Filters to delete.

    There are no entries for IDE ATA/ATAPI Controllers in Device Manager.

    There is one unknown device in the Other devices section, but from the driver details (ACPI\SMO8800\1) it appears to be the Dell Freefall sensor.

    The Drive is a TSSTcorp DVD+-RW TS-U633F D500. Dell say they don't support Win 10 on this machine, and don't seem to want to provide a driver for it on the model specific page. I may have found one elsewhere, but as the drive doesn't appear in Device Manager, I don't know how to update it...

    Can anyone suggest a solution?

    Thanks,

    Piers.
      My ComputerSystem Spec
  2.    10 Jan 2016 #2
    Join Date : Jan 2014
    Inverness
    Posts : 1,129
    Win 10

    First, the ONLY driver for optical drives of any type is the default built in Windows driver. It has been this way since Win XP.

    Since Linux detects it, this says its probably not disabled in the BIOS, although I would still check as Linux can do strange things. If its disabled or not detected in the BIOS, Windows will not detect it. Dell Calls the BIOS the "Setup" and its accessed by F2 at power on.

    If the BIOS is OK, reinstall the Intel motherboard chipset drivers - even if the version you have is the latest. One of the things the chipset drivers do is identify all the devices on or attached to the motherboard.

    There are chipset drivers on the Dell downloads but they are old. You can get the latest at Intel: Tablet, 2in1, Laptop, Desktop, Smartphone, Server, Embedded
      My ComputersSystem Spec
  3.    10 Jan 2016 #3
    Join Date : Jan 2016
    Tyler
    Posts : 45
    Windows 10 Pro / Windows Server 2012 (VM)

    FIREBERD-- Answer is what I would try next -- Make sure your Bios, DVD Firmware, are up to date -- Then Make sure your Chipsets are up to date -- I have upgraded a E6410 to Windows 10 -- But I made sure that all Firmware and Software was up to date - Had no Problems

    According to DELL the Latitude E6410 Should have these specs on firmware and software:
    BIOS -- A16
    Intel Chipset -- 9.2.0.1030 A05
    HECI Driver -- 6.2.40.1045 A08
    DVD -- D600 A04 Firmware
      My ComputerSystem Spec
  4.    11 Jan 2016 #4
    Join Date : Jan 2016
    Posts : 9
    Win 10
    Thread Starter

    Hello,

    Thanks for the suggestions.

    The DVD drive looks fine. As I said, it's no problem when booted to Linux, but anyway I ran the BIOS diagnostic tests and they came up clean. And, the laptop will boot to both the Win 10 and Linux install DVDs.

    I've updated the BIOS from A10 to A16, and the Intel Chipset to 9.2.0.1030 A05.

    When I tried running the HECI Driver update it generated an error message: "This computer does not meet the minimum requirements for installing the software".

    When I tried running the DVD Firmware update it generated the error message "Drive can't be found" (I guess that's as you'd expect!).

    I found these drivers via the Dell Product Support Drivers & Downloads page. I think I understand the basics, but the one thing I'm not clear on is how to determine the currently installed version numbers...?

    I also downloaded and ran the Intel Driver Update Utility Installer, but it found nothing at all. Should I have been searching manually, and if so, what should I have been looking for?

    So, any suggestions as to what I should do / try next?

    Piers.
      My ComputerSystem Spec
  5.    11 Jan 2016 #5
    Join Date : Jan 2014
    Inverness
    Posts : 1,129
    Win 10

    A BIOS reset (Clear the CMOS memory) is something to consider. However, its not usually easy on a laptop. With the PC powered off, remove the CMOS Memory backup battery for AT LEAST 10 minutes (Intel says 15 min).
      My ComputersSystem Spec
  6.    11 Jan 2016 #6
    Join Date : Jan 2016
    Posts : 9
    Win 10
    Thread Starter

    Quote Originally Posted by fireberd View Post
    A BIOS reset (Clear the CMOS memory) is something to consider. However, its not usually easy on a laptop. With the PC powered off, remove the CMOS Memory backup battery for AT LEAST 10 minutes (Intel says 15 min).
    OK, I can try that, but before I do, what makes you think this is a BIOS issue?

    Surely if there was something wrong at that basic level, I wouldn't be able to access the drive as I can currently through Linux.

    While you're here, how do I find out the currently installed versions for the HECI driver?

    Piers.
      My ComputerSystem Spec
  7.    11 Jan 2016 #7
    Join Date : Jan 2014
    Inverness
    Posts : 1,129
    Win 10

    I don't think the HECI is an issue, myself.

    Windows keys on the BIOS and although Linux sees the drive, there is still a chance something in the BIOS is preventing Windows from recognizing the drive. (obviously you can't update the drive firmware unless its in Windows as the Dell firmware update is not for Linux).

    When you "clean" installed Win 10, had you upgraded to 10 previously? (and did the drive work OK) or just going directly to Win 10 from an older OS? If you just went directly to Win 10, one more thing to consider is reinstalling the old OS (I assume Win 7) making sure the drive works OK in the old OS and then do an "upgrade" to Win 10 and see if the drive works. This is a hassle but may be the way to get the drive working.
      My ComputersSystem Spec
  8.    11 Jan 2016 #8
    Join Date : Jan 2016
    Posts : 9
    Win 10
    Thread Starter

    Hello,

    The PC was an old one from my company that actually had XP on it when I got it, though the authentication key sticker in the battery compartment is for Win 7 Pro OA (Dell). Because I couldn't get round the old company software (it was trying to force a network login), I decided to just wipe it and start again. My first clean install was actually Linux Mint 17.3, which I wanted to check out for a possible dual boot.

    I didn't have any Windows OS media, so downloaded the Win 10 32-bit iso and installed from that using the Win 7 Pro OA key. First I used the Linux partition manager to split the (160GB) drive in half, and it's now dual boot (Legacy Bios, not UEFI).

    I have, however, been lent a Win 7 Home Premium 64-bit disc by a friend, so I could try installing that. Do you know if that disc is going to accept a 32-bit key?

    Piers.
      My ComputerSystem Spec
  9.    11 Jan 2016 #9
    Join Date : Jan 2014
    Inverness
    Posts : 1,129
    Win 10

    I have a Win 7 OEM version and it came with two discs, one for 32 bit and another for 64 bit.
    The E6410 is a 64 bit OS machine and what I would use.
    If the Win 7 disc from the friend has never been activated you can use that, but if its already activated, no.
    If you can find a Dell OEM Win 7 64 bit disc you can use that.
      My ComputersSystem Spec
  10.    11 Jan 2016 #10
    Join Date : Jan 2014
    Posts : 1,385
    Windows 10 Pro (32-bit) Insider 16291

    Quote Originally Posted by Piers66 View Post
    When I tried running the HECI Driver update it generated an error message: "This computer does not meet the minimum requirements for installing the software".
    I'm going to throw in the suggestion to try installing/running driver update software in compatibility mode for an older version of the software, eg. Windows 8 or 7.
    Compatibility Mode Settings for Apps - Change in Windows 10 - Windows 10 Forums

    If the driver installer unzips itself to somewhere, also go there and set compatibility mode on the driver installer exe (probably setup.exe) before you run it.

    This helped me get some old drivers working on old hardware.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Will Windows work on a Dell XPS M1530 laptop with 4GIGs of Ram
Hello, I have a Dell XPS M1530 laptop with 4gigs of Ram running Windows 7 Professional. I have a 465GB HD with 356 GB free. Will windows 10 pro work? thanks in advance.
General Support
thinking about purchasing a dell e6410 laptop
good afternoon, I am thinking about purchasing a Dell E6410 laptop later this evening, I would want to update/upgrade it to windows 10 as soon as possible after getting it since I seem to like windows 10 much better than windows 7. I read a few...
General Support
Dell printer not compatible. Any other way to get it to work?
I've searched everywhere, uninstalled and reinstalled and it won't work. I've got my laptop networked to printer but it won't work either. I need help figuring out how to do that
Drivers and Hardware
Apps would like free solitaire won't install-any fixes?
Apps would like free solitaire won't install-any fixes?
Software and Apps
HIbernate does not work (and lots of the obvious fixes already tried
Exact description: Hibernate enabled (powercfg -h on) hiberfil.sys file present ( and = RAM) and tons of free space on C:\ When I click hibernate from power menu I see the following (a) Instant black screen but power light still on) (b) No...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:01.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums