Hot plug SATA HDD or DVD drive doesn't shows or not detected


  1. Posts : 2
    Microsoft Windows 10 x64
       #1

    Hot plug SATA HDD or DVD drive doesn't shows or not detected


    Usually when we plug in a SATA drive it will show up in explorer but it doesn't now after I install Windows 10 (clean install). It work well when I'm on Win 7.

    I've check the BIOS it indicate all ports AHCI an I never change anything since Win 7. So what could be the problem? As I swap drives often this feature really important for me, please help. Thanks.
      My Computer


  2. Posts : 151
    Windows 10
       #2

    You may use "Scan for hardware changes" in Device Manager.

    Hot plug still works in Windows 10 but sometimes with an unknown interference, it won't detect the swapping.
      My Computer


  3. Posts : 2
    Microsoft Windows 10 x64
    Thread Starter
       #3

    Private said:
    You may use "Scan for hardware changes" in Device Manager.

    Hot plug still works in Windows 10 but sometimes with an unknown interference, it won't detect the swapping.
    I have try but no luck. When use "show hidden devices" it is there. Thanks anyway.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:08.
Find Us




Windows 10 Forums