Hi, having some really frustrating issues with my laptop and had to create a profile on this site as nothing seems to be working. I have an Acer Aspire running Windows 10 (version 1511, OS Build 10586.36). I have been travelling for a while so haven't updated for quite some time, I think it was an update from a few weeks ago. Most things seem ok but seems to be a problem with the USB drives. Prior to the update, I had an external mouse and four extrenal hard drives (1 NTFS, 2 exFAT, 1 HFS+ which I connect use with Paragi HFS+), all of which worked fine. However, after the update, the external mouse works fine but only one of the hard drives (I think an exFAT one) appears in Windows Explorer. The mouse still works when I connect it. All the drives show up in the Devices list (and I can eject them). I have both USB 2 and USB 3 ports, neither work. The hard drives all still work on my girlfriend's Mac so there is no hardware problem. A quick search online seems to say that I should change the letter on the hard drive but when I go to disk management to change the letters, I get an error along the lines of 'The operation failed to complete because the Disk Management console view is not up-tp-date.....' It then tells me to refresh/restart, both of which I have done. I have even tried to run as administrator and then I get an error saying the path is not specified or something like that. I have no idea where to turn now. Can anyone help please?