Windows 10: Saitek pro Flight Yoke + Windows 10


  1. Posts : 2
    Windows 10 Professional 64bits
       10 Dec 2015 #1

    Saitek pro Flight Yoke + Windows 10


    Hi,

    I just mounted a brand new computer. A nice rig, with the best a could find on the market. My intention is to primarily use this computer for flight simulation and training purposes.

    I have the Saitek Pro Flight Yoke, witch I have been using on my old computer running Windows XP for 6 years. But when I plugged into my new computer, it never recognizes it after the computer initialization, so I had I physically disconnect and reconnect it to the USB port. So I decided to go to saitek.com and download the latest yoke drivers.

    After that, the problem got worse. The yoke are not recognizable anymore. When I tried to reinstall the drivers, It didn't work, since in the middle of the installation, it requires me to plug the yoke in the USB, but as it does not recognizes it, it does not let proceed with the installation.

    I have tried several things to isolate the problem. I plugged the yoke in all other USB ports, 2.0 and 3.0 (witch works fine with other peripherals), tested back on my old pc (and its working fine there) and clean the registry and try to reinstall the driver again.

    I'm almost sure it's something related to Windows, as during the computer initialization, the yoke lights turn on until Windows are up.

    I don't know what else to do. Anyone has some insight?
      My ComputerSystem Spec

  2.    15 Jan 2016 #2

    Hi bachian,

    Have you already found a solution to this problem?
    I have the same problem as you.
      My ComputerSystem Spec


  3. Posts : 2
    Windows 10 Professional 64bits
    Thread Starter
       15 Jan 2016 #3

    I took the drastic measure of formating my computer. Now it's not perfect, but it's working. I'm back on state where I need to physically disconnect and reconnect it to the USB port every time the pc restart.
      My ComputerSystem Spec

  4.    17 Jan 2016 #4

    Thank you for your answer.
    I think I'm going to take the same drastic step or go back to Windows 7.
      My ComputerSystem Spec

  5.    17 Jan 2016 #5

    It might be worth booting into Driver Verification Disabled mode when first inputting the yoke into the usb slot.
      My ComputerSystem Spec


  6. Posts : 1
    Windows 10 Pro (64bit)
       18 Feb 2016 #6

    Hi bachian,

    I have encountered exactly same incident as yours, and I noticed it might be caused by recent Windows 10 update (TH2) whichinitialized some device drivers, such as Saitek Pro Flight Yoke of ours.

    So, what I did are as follows;
    1. Run "Installer CD" which wasinitially bundled with Flight Yoke.
    2. The above installer will also stuck atthe timing to plug the yoke into the USB port as you/we experienced, and thenpress "cancel" to quit the installer.
    3. After above operation, the followingfolder has been created, in which driver files are extracted.
    c:/windows/temp/Saitek/Saitek_Pro_Flight_Yoke_SD6_64_Drivers
    4. Open "device manager", andselect Flight Yoke which would be shown as "unknown device", andselect "renew driver" designating above folder, then PC can recognizeFlight Yoke, now.
    5. Then, run "installer for Windows10" downloaded from Saitek official web site, and which will run properlyand terminate successfully.

    Hope this will be some help for yoursolution.
    Thanks,
      My ComputerSystem Spec


  7. Posts : 6
    Windows 10 Home 64bit/Win 7 64bit/Zorin
       14 Jun 2016 #7

    Thanks Outermarker,
    I was going round in circles with the the same issue with my flight yoke and your solution fixed things perfectly.
    I feel a take off coming on.lol
    Thanks again.
    NZTinker
      My ComputerSystem Spec

  8.    06 Jul 2016 #8

    Hi Guys,

    just installed fsx agin, but i got a problem with my drivers
    my pc does not detect the saitek yoke and when i try to renw the saitek driver he says that it is for windows 95 and to low for windows 10
    can someone help me?

    Best Regards
    Pieter
      My ComputerSystem Spec

  9.    21 May 2017 #9

    I now have the same problem. The Yoke and rudder pedals worked fine two weeks ago but they appear to have stopped working (no LED display on the yoke when plugged in, not showing up anywhere) since the latest Windows 10 update. Any advice please?
      My ComputerSystem Spec


 

Related Threads
Saitek controller not recgonised in Drivers and Hardware
After I upgraded my PC motherboard, my Saitek controller shows up as unknown in device manager. It does recognize my Saitek rudder peddles. I've tried to install the latest Saitek drivers and software, but it won't do the controller, but it does...
Since updating to window 10 1511 my Saitek X52 stick & peddles are acting weird. Before the update when the computer is on, the lights on the controller's were on. Now they'll be on then go off, then once in a while they will turn on then off. ...
Windows 10 keeps starting in flight mode! Does anyone know how to solve this? Thank you in advance.
I have a client running Microsoft Flight Simulator X on Windows 10. He have bought MegaScenery Hawaii and no matter what I do FSX does not see the scenery files. He also have Prepar3D and it pick up the scenes with no problem. I have...
Hi all! I hope someone can help me get fs 2004 running on Win 10. On This computor it ran on 8 and 8.1 with no problem. Win 10 it will not run. I tried run as admin,compatabilty mode, no joy. Intel I5 and 16 megs ram. Help if you can,be...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:37.
Find Us