Windows 10: Problem with WD My Book WD Unlocker showing twice when in Explore

  1.    05 Dec 2015 #1

    Problem with WD My Book WD Unlocker showing twice when in Explore

    I have a WD 3tb My Book using WD Unlocker for the drive. I use this drive unlocked as I am the only one using the drive and no password required. There are 2 problems I'm having.
    The first is that when I start Win 10 Pro, 64bit, I get an error message telling me that "The recycle bin on J:\\ is corrupted. Do you want to empty the Recycle Bin for this drive". It doesn't matter if I do either because the next time I start Windows, I get the message again. I did find a way to reset the Recycle Bin on the drive but it only lasts for a couple of days and it's back again.
    Secondly, When I'm in Explore, I noticed that the software that the My Book uses for security, password protection, is listed twice for the same drive, see attachment, and I'm thinking this should only show up once. Both instances of drive "H" are virtual drives. I called WD and talked to their tech department and the guy told me that this is the first time this subject has came up, maybe my machine is weird. I'm just wondering if this could have something to do with my first problem.
    At this point I'm totally out of ideas. I'm hoping that someone here could shed some light on either or both situations.
    Appreciate any help. Thanx
    Attached Thumbnails Attached Thumbnails WD UNLOCKER on 2 drives.jpg  
      My ComputerSystem Spec


Related Threads
I am running Window 10 and Google is my default browser.....Everything was great, till I have tried to log in with Internet Explore Now, I am forced to input Password to open my Window. I tried everything to get out of IE, but no success. ...
As the new mail has no visible address book this is what I am now doing so that I have a visible address book when emailing, first download Mozilla as it has a multitude of add ons & apps then in the add on select X-notifier the envelope emblem will...
explore.exe eating my CPU in Performance & Maintenance
Ok so my CPU is being eaten by explore.exe from like 35% to 70% Is there any fix?
western digital my book in Drivers and Hardware
After doing a clean install of windows 10 build 10130; my western digital my book 1tb external usb 3.0 hard drive will not retrieve my backups. Is this a possible windows 10 glitch; or is this a internal hardware issue with my device?
Won't book, won't post in General Support
Hi. I have problems I came to my pc today, and it wouldn't boot. After numerous attempts, and failure to enter the BIOS, I was shown the refresh/repair /reset page. I tried refresh, that did not resolve the issue. After a few more attempts to...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:28.
Find Us