Windows 10: Problem with ICH10 Family USB Universal Host Controller

  1.    01 Dec 2015 #1

    Problem with ICH10 Family USB Universal Host Controller


    Hello --

    Windows 10 Pro TH2 x64, i7-980x, Truckee 1.04 motherboard.

    Upon reinstalling Windows, it keeps trying to install ICH10 Family USB Universal Host Controller drivers for XP.

    In Device Manager :


    When I try install drivers using online search (Windows Update):


    The driver name is "OEM15.INF". I tried Driver Booster, Driver Max and Driver Toolkit to no avail. The thing is, I didn't have this problem before re-installation a couple of days ago. Maybe it's TH2?

    Please advise.
    Attached Thumbnails Attached Thumbnails devicemanager.JPG   error.JPG  
      My ComputerSystem Spec

  2.   My ComputerSystem Spec


 

Related Threads
Hello to everyone, So, before some time I had Win 8 and everything was fine. After a while I have had installed fresh Win 8.1 system. After that I tried and tried to make USB 3.0 in function but not successful. Trying everything, reinstalling,...
Hi Successfully completed a clean reinstall with no problems, this time it picked up my Nvidia 310M graphics card (will update my other thread) and installed the latest driver for it. Only one remaining issue and that is a driver for the...
Hello : Since I updated to win 10 . in device manager I'm having a problem with my usb host controllers , looks like I need a update for win 10 .49848
So I want to use wakeup on lan. I have searched google for answers of how to do this. I have done the power options on the ethernet adapter in device manager and went into BIOS to allow WOL (I couldn't find the option). I am using this app called...
I have a Aśus Maximus V Gene mob that has two Sata mob inputs not controlled by the Intel Sata driver. I am having difficulty installing the latest Asmedia driver downloaded from the Aśus support site. With Win 7 there isn't a problem, but win 10 TP...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:42.
Find Us