Page 1 of 3 123 LastLast
  1.    01 Dec 2015 #1
    Join Date : Aug 2015
    Posts : 20
    Windows 10

    Logitech 5.1 center speaker not working.


    Hi. I have a problem for a long time with my 5.1 Logitech surround system. My center speaker is not working (physically yes). I have ASUS Maximus Hero VII motherboard.
    Plugged jack layout: orange: subwoofer/center channel, black: rear speakers, lime: front speakers. I have no idea what is wrong. E.g.: while I'm watching a film, I can hear every effect clear, but I can't the dialogs, which is the center speaker's task i think. I'm using VLC the config is correct in the program.
      My ComputerSystem Spec
  2.    01 Dec 2015 #2
    Join Date : Jun 2015
    N.Y.
    Posts : 3,069
    Windows 10 Pro 64 bit

    Specify model of Logitech 5.1 speakers. Assuming then the Subwoofer is working then ? Making sure jacks are secure on back of the PC and the speaker unit. Not sure if these speakers have wires that detach or not also, if so make sure those are secured.

    Shows your board to have up to 7.1 surround sound. Did you check your Realtek Audio Manager settings besides the one in the VLC Player ? Do you have latest Realtek Drivers installed ? Movie on a bought disc, did or do all movies do the same ?

    Here is your board https://www.asus.com/us/Motherboards/MAXIMUS_VII_HERO/HelpDesk_Download/


    Try checking it also from Sound in the Control Panel, the Playback tab select the Speakers, they should be the default device according to the Sound device used in your case integrated sound device(Realtek). Highlight that device select Configure check to see it should list Stereo and 5.1 surround, highlight 5.1 and Test it, see if it reproduces sound in center channel. Probably do this with Realtek Software to.
    Other causes bad speaker or bad wires.
    Attached Thumbnails Attached Thumbnails Untitled.jpg  
      My ComputerSystem Spec
  3.    02 Dec 2015 #3
    Join Date : Aug 2015
    Posts : 20
    Windows 10
    Thread Starter

    I don't have bad wiring. I have Logitech X-530.
      My ComputerSystem Spec
  4.    02 Dec 2015 #4
    Join Date : Jun 2015
    N.Y.
    Posts : 3,069
    Windows 10 Pro 64 bit

    Quote Originally Posted by rugabi94 View Post
    I don't have bad wiring. I have Logitech X-530.
    Have you tried any of the suggestions ?? Have you moved the wiring when playing movies to know for sure as this was only a possible cause not a positive cause or even the wires that go from sub to the PC. Older model Logitech i had the X-540 once myself similar one.
    Is the movies you are playing 5.1 ?
      My ComputerSystem Spec
  5.    02 Dec 2015 #5
    Join Date : Aug 2015
    Posts : 20
    Windows 10
    Thread Starter

    Yes, I've put my earphone directly to my center/sub jack on the motherboard and it worked in the driver sound test. So it's not the motherboard's problem.
      My ComputerSystem Spec
  6.    02 Dec 2015 #6
    Join Date : Jun 2015
    N.Y.
    Posts : 3,069
    Windows 10 Pro 64 bit

    Quote Originally Posted by rugabi94 View Post
    yes
    Tried all of the suggestions from my first post # 2 still get no sound from center channel speaker and sure audio part is 5.1 ?
      My ComputerSystem Spec
  7.    02 Dec 2015 #7
    Join Date : Aug 2015
    Posts : 20
    Windows 10
    Thread Starter

    The output works and the center speaker is works. but between them something is not correct.
      My ComputerSystem Spec
  8.    02 Dec 2015 #8
    Join Date : Jun 2015
    N.Y.
    Posts : 3,069
    Windows 10 Pro 64 bit

    Quote Originally Posted by rugabi94 View Post
    The output works and the center speaker is works. but between them something is not correct.
    Read your first post said for long time center speaker is not working. Since same connector runs the sub to, does that work because you never answered ? Is it only with movies the center does not work ? Did you test it with Sound properties as asked in control panel or and even your sound device i believe Realtek audio manager ?
      My ComputerSystem Spec
  9.    02 Dec 2015 #9
    Join Date : Jun 2015
    N.Y.
    Posts : 3,069
    Windows 10 Pro 64 bit

    Here

    Click image for larger version. 

Name:	Untitled.jpg 
Views:	1 
Size:	131.0 KB 
ID:	51594
      My ComputerSystem Spec
  10.    02 Dec 2015 #10
    Join Date : Aug 2015
    Posts : 20
    Windows 10
    Thread Starter

    My sub is working correctly with test. The center does not working with test and movies.
      My ComputerSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
Logitech mouse not working in Windows 10
After the latest updates to Windows 10 on 1 September, my Logitech mouse has lost several of its functions (including the scroll function) in all applications. I downloaded the latest Setpoint and reinstalled it and then rebooted, but nothing has...
Drivers and Hardware
Realtek Audio 5.1 configuration : rear speaker switch to side speaker
Hello, I have a problem with any Realtek driver since I updated from Windows 8.1 to 10 (x64). On every boot, I have no sound on the rear speakers : the black pin switches automaticaly to "side". I have to reconfigure the black pin to rear every...
Drivers and Hardware
Logitech Wave Keyboard driver not working ??!!??!!
I've installed the driver but the 10 keypad will not work! the Num-lock key beeps when pressed but keypresses from numeric keypad do not show on screen. Your thoughts?? Thanks KLund1
Drivers and Hardware
Action Center Icon On Taskbar Not Working
Hi All, I've tried everything short of resetting my pc to get my action center icon on my taskbar to function normally. Right now it will turn white like a new notification is available, but when I click on it nothing happens. Also..when I press...
General Support
Solved Logitech Key Assignment Not Working (UAC is ON)
Hi... Just updated my OS from Windows 7 to Windows 10. Am currently testing our applications before we upgrade the rest of our PCs to Windows. One of my concern with Windows 10 is the Mail client won't run unless the User Account Control is...
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:12.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums