Windows 10: Logitech 5.1 center speaker not working. Solved

Page 2 of 3 FirstFirst 123 LastLast

  1. Posts : 3,034
    Windows 10 Pro 64 bit
       02 Dec 2015 #11

    rugabi94 said: View Post
    My sub is working correctly with test. The center does not working with test and movies.
    O.k. not working with test and you tested it in 5.1 selection right ? And center never works with anything else played besides movies ? Do you have Realtek audio driver software as i saw on ASUS site ?
      My ComputerSystem Spec

  2.    02 Dec 2015 #12

    I think it's not the software's fault because as I said earlier I've plugged my earphones directly to center channel and it's worked with the test.
      My ComputerSystem Spec


  3. Posts : 3,034
    Windows 10 Pro 64 bit
       02 Dec 2015 #13

    example pic if you have Realtek, check through it.

    Click image for larger version. 

Name:	21069-how-hell-do-you-get-surround-sound-itunes-2009-08-03_004831.jpg 
Views:	3 
Size:	56.3 KB 
ID:	51603
      My ComputerSystem Spec

  4.    02 Dec 2015 #14

    Click image for larger version. 

Name:	Névtelen.jpg 
Views:	4 
Size:	90.9 KB 
ID:	51605I have this.
    Click image for larger version. 

Name:	Névtelen.jpg 
Views:	15 
Size:	59.1 KB 
ID:	51606
    And this is my driver information,
      My ComputerSystem Spec

  5.    02 Dec 2015 #15

    If the center speaker is working when plugged into either the left or right jack on the sub, then the problem is one of either,

    1. the wires from the front right, that has the 3 wire connection to the computer and the cable that goes to the sub.

    2. the wiring inside the sub that splits up the connection from the front right to all the outputs on the sub.

    If it is either of those, number 1 would require a new front speaker; if number 2 a new sub (or try taking apart and see if you can fix the internal wiring).

    If any of those you would be better off buying a new speaker set, as to get replacements you're likely looking at a complete used set anyway.
      My ComputerSystem Spec

  6.    02 Dec 2015 #16

    I've tested it directly with my earphone as I said with 2 and 3 wire connection and it worked both.
      My ComputerSystem Spec


  7. Posts : 3,034
    Windows 10 Pro 64 bit
       02 Dec 2015 #17

    You also said testing it from the sound in control panel from the configure had no sound on a 5.1 test, try the same in pic you show now from that audio manager, same results ?
      My ComputerSystem Spec

  8.    02 Dec 2015 #18

    So. If I plug the center speaker to the front channel , it works, so it's not a speaker fault. If everything is on his place and I plug my earphone DIRECTLY to the motherboard's center/sub output, it works.
      My ComputerSystem Spec

  9.    02 Dec 2015 #19

    If that is the case then the problem is any of what I said above, something wrong in the cable or the wiring inside the sub.
      My ComputerSystem Spec


  10. Posts : 3,034
    Windows 10 Pro 64 bit
       02 Dec 2015 #20

    One of my last thoughts originally in my first post was bad wiring. Only another set of speakers will let you know if it is not something else.
      My ComputerSystem Spec


 
Page 2 of 3 FirstFirst 123 LastLast

Related Threads
After the latest updates to Windows 10 on 1 September, my Logitech mouse has lost several of its functions (including the scroll function) in all applications. I downloaded the latest Setpoint and reinstalled it and then rebooted, but nothing has...
Hello, I have a problem with any Realtek driver since I updated from Windows 8.1 to 10 (x64). On every boot, I have no sound on the rear speakers : the black pin switches automaticaly to "side". I have to reconfigure the black pin to rear every...
I've installed the driver but the 10 keypad will not work! the Num-lock key beeps when pressed but keypresses from numeric keypad do not show on screen. Your thoughts?? Thanks KLund1
Hi All, I've tried everything short of resetting my pc to get my action center icon on my taskbar to function normally. Right now it will turn white like a new notification is available, but when I click on it nothing happens. Also..when I press...
Hi... Just updated my OS from Windows 7 to Windows 10. Am currently testing our applications before we upgrade the rest of our PCs to Windows. One of my concern with Windows 10 is the Mail client won't run unless the User Account Control is...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 01:18.
Find Us