Windows 10: XAPOFX1_5.dll missing...

Page 1 of 2 12 LastLast
  1.    22 Nov 2015 #1

    XAPOFX1_5.dll missing...


    Hi, I have recently downloaded a game through Steam and it hasn't been working. I have discovered that the likely cause of this is due to a missing .dll file called XAPOFX1_5.dll. My question is how do I restore the .dll so I can get back to my games and is there an easy way to do it?

    SPECS:
    Acer Aspire V5-571
    Windows 10
    64 bit
    intel core i5

    Thanks in advance.
      My ComputerSystem Spec

  2. TairikuOkami's Avatar
    Posts : 3,419
    10.6 Home 1809 x64
       22 Nov 2015 #2

    Download Manual fix (there is 32-bit and 64-bit to choose from).

    xapofx1_5.dll free download - DLL-files.com

    Copy dll file to: C:\Windows\System32

    Restart the computer, if the problem still occurs, run CMD as admin and enter:

    regsvr32 "xapofx1_5.dll"
      My ComputerSystem Spec

  3. spapakons's Avatar
    Posts : 2,486
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.345)
       22 Nov 2015 #3

    Or simply install latest Directx 9.0c runtime. Yes, Windows 10 include DirectX 12, but some games look for older DirectX 9 files not present in Vista and later. Installing DirectX 9.0c runtime provides these files, one of them is XAPOFX1_5.dll

    During installation you may be prompted to also install .NET framework 3.5 Do that so legacy DirectX files work properly. For some games you may also be prompted to enable legacy DirectPlay, do that also.
      My ComputerSystem Spec

  4.    23 Nov 2015 #4

    I have tried the suggestion from TairikuOkami and it was unsuccessful. When I tried to run the game it displayed an error message which is hopefully attached to this post. As for spapakons suggestion, I would prefer to keep the latest DirectX installment. If absolutely worse comes to worse then I will look further into downgrading DirectX. Any more information would be very helpful thanks. Click image for larger version. 

Name:	Screenshot (19).png 
Views:	6 
Size:	511.5 KB 
ID:	50037
      My ComputerSystem Spec

  5. spapakons's Avatar
    Posts : 2,486
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.345)
       23 Nov 2015 #5

    From your screenshot I see you launched a simple Command Prompt, that's why it failed. You need a Command Prompt with Administrator rights, press Win+X and select Command Prompt (Admin). As for installing DirectX 9.0c runtime, this doesn't affect DirectX 12 in any way. It simply adds DirectX 9 files to SYSTEM32 (and other folders) for old games to find. So you don't actually downgrade DirectX 12 to DirectX 9, you simply add a compatibility layer for older games and applications requiring the older files.
      My ComputerSystem Spec

  6.    23 Nov 2015 #6

    Thanks for the response spapakons. The game I'm having trouble with is actually made for Windows 7 and later so I don't think DirectX 9 is a new enough version to work. As for the command prompt, it is an admin cmd in the screenshot and neither the regular or admin command prompt worked.
      My ComputerSystem Spec

  7. spapakons's Avatar
    Posts : 2,486
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.345)
       24 Nov 2015 #7

    Then you either downloaded the wrong version (32-bit or 64-bit) or the file is corrupt. Try installing DirectX 9.0c runtime to get the proper version.
      My ComputerSystem Spec

  8.    24 Nov 2015 #8

    If you are running 64 bit Windows you need to copy it to C:\Windows\SysWOW64 as well as C:\Windows\System32. You don't need to register it.
      My ComputerSystem Spec

  9.    24 Nov 2015 #9

    I have tried to copy the file to SysWOW64 as well as System32 but it didn't work. If I get the DirectX 9 Runtime, do I have to remove the dlls I have placed in these two files or will it repair it self? Also has anyone got a link to a valid DirectX 9 or other DirectX runtime download?
      My ComputerSystem Spec

  10. spapakons's Avatar
    Posts : 2,486
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.345)
       24 Nov 2015 #10

    The DirectX setup will replace any non-working files. Just run it.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Solved DVD drive missing in Drivers and Hardware
I hardly ever use it, so hadn't noticed until today that my DVD drive has disappeared from Device Manager (no DVD-CD ROMs appear there at all) and I cannot use CDs/DVDs in my PC. I strongly suspect Windows 10 as the culprit. I upgraded from W7 early...
Missing MSVCR110.dll in Browsers and Email
Can't open my mail because, it says,: MSVCR110.dll is missing...this is after yesterday's upgrade of Windows 10...How do I get that missing .dll?
color missing in Customization
System Spec Computer type:PC/DesktopSystem Manufacturer/Model Number:Lenovo H520sOS:Windows 10CPU:G2020 2.9 GHZMemory:1 TMonitor(s) Displays:DellBrowser:Inteernet Explorer 11Antivirus:Bitdefender 2015 for Windows 10 I read a while ago that...
Solved Missing OpenCL.dll in Drivers and Hardware
Hi All, So, I upgraded to Windows 10 a day back using the media creation tool, and the install went fine. After I restarted the PC for the first time, I got an error saying that OpenCL.dll is missing. I searched online forums and it said that it...
Missing Product key in Windows Updates and Activation
My Daughter has a HP laptop with Windows 8.1 on it, the windows 10 upgrade offered her the upgrade but it is now asking for the product key but her laptop does not have a a sticker on the bottom of her laptop (yes it is a legit copy before...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:15.
Find Us