Windows 10: openGL issues

Page 1 of 2 12 LastLast
  1.    19 Nov 2015 #1

    openGL issues


    I have a desktop, all in one computer, which recently was updated to windows 10. I am currently having issues with a program saying I needed to have openGl 1.3 or later (I have checked and am running at 1.1). I have tried updating drivers , but apparently all drivers are at the max version the graphics card supports. Why was I able to run it before, but can't update now (I haven't updated the program)?
    Last edited by turniprules4; 20 Nov 2015 at 14:43.
      My ComputerSystem Spec


  2. Posts : 2,447
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       19 Nov 2015 #2

    OpenGL support depends on graphics hardware and of course graphics drivers. If your graphics card is not very old, try updating the graphics drivers from manufacturer (Intel, nVidia, AMD), not from Windows Update.
      My ComputerSystem Spec

  3.    20 Nov 2015 #3

    I have tried updating through my graphics card's updater (Intel), no updates were available.
      My ComputerSystem Spec


  4. Posts : 2,447
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       20 Nov 2015 #4

    How old is your card? What model it is? If it is too old, you cannot do anything about it, apart from running the OpenGL application in Direct3D mode (would be fast if can be done) or in software mode (very slow). Examine the program's settings carefully to find how to do it.
      My ComputerSystem Spec

  5.    20 Nov 2015 #5

    It would be helpful if you fill in your system information.

    What graphics drivers are installed? I'm not familiar with OpenGL support in the Microsoft Basic drivers, but it wouldn't be comparable to the support in drivers specific to your hardware.

    You may have to work around the issue if your display adapter doesn't have official Win 10 drivers. (Or, revert to an older, supported OS.)
      My ComputerSystem Spec


  6. Posts : 2,447
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       20 Nov 2015 #6

    If graphics card supports OpenGL 1.3 or higher in hardware, then installing latest OEM (not Microsoft) drivers should fix the problem. Use Aida64 to identify your hardware and update your technical specifications in your profile, so we can guide you.
      My ComputerSystem Spec

  7.    21 Nov 2015 #7

    You could also try running a OpenGL -> D3D wrapper if available.
      My ComputerSystem Spec


  • Posts : 2,447
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       21 Nov 2015 #8

    Can you suggest any?
      My ComputerSystem Spec


  • Posts : 2,447
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       21 Nov 2015 #9

    If you install Aida64, you can see exactly which version of OpenGL and which functions your card supports by going to Display -> OpenGL.

    Click image for larger version. 

Name:	Aid64 OpenGL report.jpg 
Views:	2 
Size:	114.8 KB 
ID:	49751


    Then you can test OpenGL performance with the GpuTest utility.
      My ComputerSystem Spec

  •    22 Nov 2015 #10

    spapakons said: View Post
    Can you suggest any?
    Hmm. I think there is none for OpenGL -> D3D but there are some for the opposite...
      My ComputerSystem Spec


  •  
    Page 1 of 2 12 LastLast

    Related Threads
    App issues in Software and Apps
    I'm having an issue with the Apps. Went to store chose an app installed it said it was complete. The app shows in the start up menu I click on it and all I get is a update screen. Where is the actual app? I'm new to Windows 10 this is getting...
    I have updated my Stream 7 to Windows 10 - I am happy with how it performs, happy with it in general (although there are some things I preferred in Windows 8.1) One thing I am not happy with is the text size issues in Modern/"Metro" apps, and...
    So I installed Broken Age then when I open it, it says that the required openGL features aren't available. Well I installed the latest update on the driver but still no luck. So I also cannot find intel graphics control panel (cannot find it on...
    Anyway to fix USB issues? in General Support
    Hey ho. Running build 10135 and playing with it - got my USB tethering working bueno (with Jolla, Äijänpäivänjärvi build, sailfishOS) yesterday until I was playing around with Asus AI suite. Everything worked until I removed AI suite and rebooted -...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    © Designer Media Ltd
    All times are GMT -5. The time now is 13:22.
    Find Us