I have just (well 4 weeks ago) bought a DELL XPS8700. New (from a 3rd party distributor).
It came with Windows 10.

Now right after I went through startup config routine, I went on-line to download Firefox (from Mozilla website, not some 3rd party, so....).
At which point my internet access stopped.
Long story short I saw my WiFi symbol acquiring a red X.
None of my networks (I have three) were seen.
In Network center it said my WiFi adapter was off. Upon saying "Turn on" it would fail.

Reboots did not help.

I called DELL support and after making me go through BIOS tests etc they said my driver was probably bad. So we downloaded and re-installed WiFi driver.
After this it worked again.

At that point I let the support guy go only to discover I got no sound (via built-in speakers in my DELL HDMI monitor). The speaker symbol also had a red X. I theorized that was also a driver problem, re-installed the driver and the speaker then also worked.
Now that was 4 weeks ago.

Yesterday during attempted access to my other computer's shared folder the WiFi scenario repeated itself. Reboots did not help. Re-installation of the driver did.

Oh...and when I asked DELL why they said "well, 10 is still being debugged".
So....is this problem unique to me or do other people see it too?