1.    11 Nov 2015 #1
    Join Date : Oct 2015
    Posts : 24
    Windows 10 pro x64

    Updated Bios on Gigabyte MoBo -- lost 3 SATA ports


    I built my Intel i5 PC in 2010. The mobo is the Gigabyte GA-P55-USB3 "Ultra Durable"... After recently upgrading to Windows 10, I attempted to upgrade my RAM from 4 to 8 GB. My mobo did not recognize the two available RAM slots. I decided (wrongly) to upgrade my 5+ year old BIOS. I foolishly used the Gigabyte program installed during the build to select the appropriate BIOS upgrade. BIG mistake. The BIOS had to be rolled back to the previous version but now I have 3 dead SATA connectors that cannot be used. My two internal HDs and my DVD/CD had to be moved to other SATA connectors. This mobo comes with a total of 8 SATA connectors. I am using 3 and 3 are dead. Yes, I can live with that -- HOWEVER, if the 3 dead connectors can be resurrected that is what I'd like to do. IF the dead connectors are not physically damaged, can they be repaired with a new driver or BIOS flash? I'm attaching a screen capture of my device manager details of the dead puppies. What is error code 10? Is part of the SATA controller damaged? All suggestions will be appreciated.

    Thanks,

    LouisClick image for larger version. 

Name:	SATA CHANNEL 0 ERROR 10.PNG 
Views:	5 
Size:	255.3 KB 
ID:	47550
      My ComputerSystem Spec
  2.    11 Nov 2015 #2
    Join Date : Feb 2015
    Posts : 3
    Dual Boot 10 Pro v1607 10 Pro rs2 build 14971

    I see the yellow triangles on your screen shot. Have you tried updating the drivers from the driver tab?
      My ComputerSystem Spec
  3.    11 Nov 2015 #3
    Join Date : Oct 2015
    Posts : 24
    Windows 10 pro x64
    Thread Starter

    John, I have not. I got into this mess attempting to update my BIOS. I assumed that Gigabyte and not Microsoft would have the updates for the SATA controller. But I'm no expert. If you think this will fix the problem, I will give it a shot.

    Let me know and I'll do it tonight.

    Thanks,

    Louis
      My ComputerSystem Spec
  4.    11 Nov 2015 #4
    Join Date : Feb 2015
    Posts : 3
    Dual Boot 10 Pro v1607 10 Pro rs2 build 14971

    That is what the yellow triangles tell me that your drivers need updating. Click on the driver tab in your screen shot.(the ATA channel 0 properties). click on update driver and then do the other one. See if it works. It should take care of your problem.
      My ComputerSystem Spec
  5.    11 Nov 2015 #5
    Join Date : Oct 2015
    Posts : 24
    Windows 10 pro x64
    Thread Starter

    I tried it. No such luck. It says I have the best driver for the device. Any other thoughts?
    Thanks...
    Click image for larger version. 

Name:	BEST DRIVER INSTALLED.PNG 
Views:	2 
Size:	217.6 KB 
ID:	47555
      My ComputerSystem Spec
  6.    12 Nov 2015 #6
    Join Date : Sep 2015
    Posts : 2,372
    Windows 10 Pro 64-bit 1706 (CU build 15063.674)

    Download the latest chipset driver. Then delete any non working device in Device Manager. Run the setup of the chipset as Administrator. This will renew the relevant drivers so at next restart the controllers should be detected and working.
      My ComputerSystem Spec
  7.    12 Nov 2015 #7
    Join Date : Oct 2015
    Posts : 24
    Windows 10 pro x64
    Thread Starter

    I've taken this bad boy to the computer repair shop in our community. The technician believes it a BIOS problem and will be installing the appropriate BIOS. I read him your reply. Thanks for your reply.

    Louis
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Second SATA drive showing in BIOS but not Device Manager
I've just added a 2nd HD to my Dell system with Win 10. It shows in the BIOS and Seagate tools finds it. It does not show up in Device manager or Computer Management/Storage - Disc Management or anywhere. Not sure if this si Won 10 specific. Anyone...
Drivers and Hardware
Updated bios - activations stopped working!!!!!
I had issue with my USB Via 3.0 not working so I upgraded the bios to the latest version which has fixed the problem... ( Windows was activated but now I am now having a problem with activation.......... Error code: 0xC004C003 What can I do?
Windows Updates and Activation
Mobo with 2 Intel LAN ports - Intel l211 & l217-V - Both don't work
I used the upgrade tool to install w10x64. Installation went fine, I can use my computer and all. Problem is that both of my LAN ports don't work. I get the usual red icon in the taskbar that shows no internet. I went into networking and it doesn't...
Network and Sharing
Gigabyte UEFI bios -windows 8 or other OS?
Just curious .. Not sure if it makes much difference , but should I pick Win 8 or other OS in my bios?
General Support
I lost 2 Hard Disks after updated from Build 9860 to 9879
Updated to build 9879 with no problems from build 9860. However, I powered down and restarted the next morning to find "Disk Boot Failure - Insert system disk". Whatever I tried to see inside the disk failed because it wasn't recognised in...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:14.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums